X-bEnCh – Support francophone officiel

Forum News Room Projets X-bEnCh – Support francophone officiel

Ce sujet a 167 réponses, 18 participants et a été mis à jour par Zarnal Zarnal, il y a 9 heures et 19 minutes.

15 sujets de 136 à 150 (sur un total de 168)

Partager sur vos réseaux sociaux préférés :
Facebooktwittergoogle_plusredditpinterestlinkedintumblrmail

  • Auteur
    Messages
  • #47870
    Staff
    Jim
    Jim
    • 3 717 Messages

    Ca peut être une solution oui.  :yes:

    A500 Plus - 2Mo de Chip - 128Mo Fast - 8Gb CF - 68080@78Mhz (Vampire V2+ inside)
    A1200 - 256Mo Fast - 80Gb HD - 68060@96Mhz - Delfina DSP - Wifi PCMCIA



    #47903
    triki
    triki
    • 21 Messages

    Royal Jim Merci, ça marche super bien, le retour au Workbench est super rapide. Je vais te montrer ça.

     

     

    #48022
    triki
    triki
    • 21 Messages

    Salut Jim, je te reposte une vidéo, depuis j’ai un peu amélioré la ram. Le temps de démarrage reste plus long qu’amiga boot selector. Par contre le temps que perd X-bench au démarrage, il le gagne au boot du Workbench. Regarde la video en cliquant sur exit je passe au Workbench trés rapidement, ce qui n’ai pas le cas avec ABS.

    Alors je pense sincérement que cela vient de l’émulateur UAE porté sur WII, puisque j’utilise la même configuration sur mon pc, et cela n’a rien a voir, en terme de vitesse.

    Petite question: Dans quel répertoire faut-il mettre les miniatures des jeux?

    Merci pour l’aide  :-)

    #48186
    Tim
    Tim
    • 88 Messages

    Salut Jim et joyeuses fêtes à tous !!!

    Me revoilou… :good:

    L’enquiquineur public No1 revient ! Ah ben oui désolé d’être un gamer avec mon nouveau super PC ce qui me laisse moins de temps pour mon Amiga chéri.

    Bien alors j’ai un peu testé la 1.1b4.

    Comme toujours ce qui marche le mieux jusqu’à maintenant chez moi c’était la 0.94f.

    Mais mais mais… Que voilou avec cette nouvelle mouture !

    Plus stable apparemment et au vu de mes premiers tests plus rapide à effectuer des tâches(ouf génial!) sauf que… Le scanning des slaves est juste abominable en terme de lenteur…

    Bon je sait bien que pour scanner 801 titres ça peut être un long mais bon. Des plombes je te dit…

    Tu a dit que tu pouvait améliorer ça, alors OK do it ! héhéhé

    J’ai aussi le souci que ok il scanne les slaves correctement mais quand on a des programmes sans slaves comme « The Dream of Rowann », il ne l’analyse pas et donc on les a pas dans XB3nch !

    y’a aussi des truc comme « Whorty » (pareil).

    Pour le moment c’est ma 1ère remontée…

    J’ai changé mes roms dernièrement en kick 46.143 grâce à une âme charitable qui a bien voulu me les fournir programmées pour 10€.

    Et du coup, ça marche super !

    Je vais pratiquer d’autres tests mais pour le moment c’est encourageant !

    Bon sinon courage Jim, les lauriers 2019 ne sont pas très loin ! :heart:

    NB: Je confirme après avoir joué à une dizaine de jeux, elle est très stable, pas de plantages ! allez, APPROUVEE !

    NB2:B3ta 5 en test ! ;-)

     

     

    Amiga 1200 / AmigaOS 3.1.4 KS 46.143 / ACA 1233n / HxC Lotharek
    C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
    ATARI 1040STE 4Mo / TOS 1.62+2.06 / HxC Lotharek / UltraSatan
    Amstrad CPC6128 / ZAX Drive 3 / Cyclone RX

    #48353
    Staff
    Jim
    Jim
    • 3 717 Messages

    La voilà enfin ! Après un an d’attente voici enfin venu la traditionnelle release de Noël d’X-bEnCh.

    Il s’agit cette fois de la 1.1 Final en comprendre d’une version venant corriger une foultitude de bugs et soucis en tout genre. Elle a été longuement testée beta après beta et devrait être une des plus fiable voire la plus fiable jamais publiée.

    Comme vous le comprendrez au release text que je vous ajoute ci dessous, elle a nécessité beaucoup de boulot au fil de cette année 2018 et j’espère que vous l’apprécierez.

    Vous pouvez la télécharger à cette adresse :

    http://www.jimneray.com/download/xbench1.1f.lha

     

    X-bEnCh 1.1 Final Public Release (26/12/18)

    This release include all the content of the internal Betas(B2 B3 B4 & B5)
    Merry Xmas to ya all ! =)

    Xinit 4.1
    -No more use the ‘?’ invalid AmigaDos character in tempfiles names.

    Xlaunch 4.7
    -New memory detection method. A lot more accurate.
    -Now display the available memory in MB instead of KB.
    -If you was trying to add to your fav list an entry that was allready
    present in it, the add to fav feature was no more working until you
    have switched your current list to another. Now fixed.
    -After deleting the last entry of your fav list you was no more able
    to add a new one until you restart the launcher (except if you have
    the cd32 game controler enabled). Now fixed.
    -If you launch more than one game from the Toplist without switching
    to another list, the entry of this games was corrupted in the Last15
    list. Now Fixed.
    -Playing a random mod from an audio playlist fixed. (Was not working
    if you were reseting your Amiga after each game, as with a CD32)
    -You can now use playlists with up to 256 mods (limited to 100 before)
    -Bottom part (screenshots) fixed (Was not refreshing correctly in some
    cases)
    -Adding more than one game to your favlist is now working with a CD32
    Pad. (Thanx Akira for the bug report)
    -When you was deleting the last entry of the Favs list with a CD32 pad
    the screen was going back to the first available listing. If you have
    not released your finger as fast as the light from the play/pause
    button the first entry of this list was added to the favs. Now check
    if the button have been released before being pushed.
    -When a game was started from the Toplist (F7), the Last15 list (F8)
    or the Favslist (F9) the update of the F7/F8 list was in some cases
    loosing the source list from where the game come. Fixed.
    -In the last15 listing (F8) a game that was already in this listing
    was not upped to the top of this list if you start it again. Fixed.
    -Whdload tooltypes was not correctly detected and used if a game was
    started from the Toplist (F7) or the Last15 list (F8). Fixed.
    -No more use the ‘?’ invalid AmigaDos character in tempfiles names.

    Checkerboard loader 1.7
    -No more use the ‘?’ invalid AmigaDos character in tempfiles names.

    Xpl0rEr 2.0
    -New memory detection method. A lot more accurate.
    -Replaced the wrong « kb » with « KB » in the available memory display.
    -BetterWB/WonderWB/BlaBlaWB total fix (i hope).
    -You can now create playlists with up to 256 mods (Was limited to 100
    entry before).
    -When you were trying to go back to the volume list in the right side,
    the left side was refreshed to the volume list too. fixed.
    -Now correctly scan the devices even if you use BetterWB. (Thanx to
    spudge/eab for the report)
    -Now check if the selected file is really an Xbench Audio Playlist
    before trying to load it.

    Xcli 1.9
    -No more use the ‘?’ invalid AmigaDos character in tempfiles names.

    Xsetup 4.6
    -New memory detection method. A lot more accurate.
    -Now display the available memory in MB instead of KB.
    -New volume blocksize detection method. A lot more accurate.
    -Now correctly add and remove buffers before and after a scan.
    -Blocksize bigger than the default 512b/1024b no more crash or freeze
    the scan engine.
    -Now display the available memory in MB instead of KB.
    -Fixed the scan engine that was in some cases falling into an infinite
    loop and in other cases adding the same entry 3 or 4 times.
    -BetterWB/WonderWB/BlaBlaWB total fix (i hope).
    -Audio playlists variables was badly initialised and in some case
    failed with a guru 8000 0020. Fixed.
    -ASL requester for Audio Playlists is now full screen.
    -Added a pattern filter to the Audio playlists requester.
    -ASL requester for xbench startup/endup scripts in the setup/startup
    tab is now fullscreen.
    -ASL ‘path to scan’ requester for xbench list is now fullscreen.
    -Listings paths variables were badly initialised and in some cases
    this was ending with a guru. Fixed. (Thanx Tim for the report)
    -Now check if a path is valid and if the listing is enabled before
    starting the update process (Previously this was done in the update
    process).
    -Renamed the useless ‘WhdLBox’ option button in the launcher tab.
    -Replaced the ‘YEs’ value of the 3 useless options buttons in the
    Launcher tab with ‘–‘.
    -Renamed the ‘Show WhdLoad Requester’ button in the Whdload tab with
    ‘Show WhdLoad SplashReq’.
    -Renamed the Show WHDLoad Req button (that was just an On/Off switch)
    in the WHDload option tab to ‘WhdLoad Splash Delay’. Now you can
    setup this at ‘No/2s/4s/8s/WAit’. « WAit »‘ll display a box until you
    haven’t clicked on the button or used space/return key.
    -Added the well named ‘WhdLoad Splash Config’ button in the Whdload
    tab to select the delay of the config window. Disabled at this time,
    will be available in X-bEnCh 1.2.
    -Buffers management fixed when scanning a path.
    -Fixed the scan engine that was freezing into an infinite loop if a
    game dir was located at the root of a volume.
    -The ASL Requester was forgoting the path previously selected in the
    Launcher prefs tab. Fixed.
    -Now you can scan up to 4096 sub dirs inside one single dir.
    -Very big listings gone bad when reorg. Fixed … I hope … =)
    -No more use the ‘?’ invalid AmigaDos character in tempfiles names.

    Xexit 1.5
    -No more use the ‘?’ invalid AmigaDos character in tempfiles names.
    -Some temp files were not correctly deleted after leaving. Fixed.

     

    @triki / @tim : Merci pour vos retours. Je reviens faire le point rapidement ici  ;-)

    A500 Plus - 2Mo de Chip - 128Mo Fast - 8Gb CF - 68080@78Mhz (Vampire V2+ inside)
    A1200 - 256Mo Fast - 80Gb HD - 68060@96Mhz - Delfina DSP - Wifi PCMCIA

    #48357
    Staff
    Zarnal
    Zarnal
    • 2 104 Messages

    La voilà enfin ! Après un an d’attente voici enfin venu la traditionnelle release de Noël d’X-bEnCh. Il s’agit cette fois de la 1.1 Final en comprendre d’une version venant corriger une foultitude de bugs et soucis en tout genre. Elle a été longuement testée beta après beta et devrait être une des plus fiable voire la plus fiable jamais publiée. Comme vous le comprendrez au release text que je vous ajoute ci dessous, elle a nécessité beaucoup de boulot au fil de cette année 2018 et j’espère que vous l’apprécierez. Vous pouvez la télécharger à cette adresse : http://www.jimneray.com/download/xbench1.1f.lha

     

    Il existe déja une doc X-bench (il me semble que oui, c’est pour cela que je n’avais pas attaqué après Tiny) ou bien j’ai déja trouvé un autre truc à faire ultérieurement ? :-p

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - CM A1200 complète ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae.

    #48365
    Tim
    Tim
    • 88 Messages

    Comment je suis trop content !!! Bon je vais tester ça dans les prochains jours !!

     

    Merci Jim ! :yahoo:   :yahoo:   :yahoo:

    Amiga 1200 / AmigaOS 3.1.4 KS 46.143 / ACA 1233n / HxC Lotharek
    C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
    ATARI 1040STE 4Mo / TOS 1.62+2.06 / HxC Lotharek / UltraSatan
    Amstrad CPC6128 / ZAX Drive 3 / Cyclone RX

    #48426
    Staff
    Jim
    Jim
    • 3 717 Messages

    @triki : Merci pour cette seconde vidéo. Pour commencer pour ton retour sous workbench je t’avais répondu a la va vite la dernière fois par manque de temps. Si tu as intégré le lancement d’xbench a ta startup sequence en remplaçant la commande « loadwb » par l’assign et le lancement d’xbench comme indiqué dans la notice tu as une autre option encore plus rapide et simple. Dans le panneau de configuration tu va dans l’onglet « Main Menu ». Là tu as un switch qui s’appel « Exit To » qui te donne trois options. La première (par défaut) « Nowhere » ne fera rien de particulier en quittant. La seconde « Load WB » fera ce que tu cherches à faire, c’est a dire lancer le workbench. La troisième enfin « Reboot » redémarrera l’Amiga.

    Petite question: Dans quel répertoire faut-il mettre les miniatures des jeux?

    Les miniatures doivent être dans le répertoire « xb:datas/db/pix/ ». Leur nom doit correspondre au nom du slave suivi de « _1.iff » par exemple pour un jeu ayant pour slave « toto.slave » l’image correspondant doit avoir pour nom « toto_1.iff ». Je te laisse regarder les images présente pour le format. Tu peux utiliser 32 couleurs mais la couleur 0 sera toujours noire (0,0,0) et la 1 toujours blanche (15,15,15). Le suffixe _1 a été ajouté dès le départ dans l’idée de pouvoir dans une future version faire une sorte de diaporama ou l’image changerait toutes les x secondes si on reste arrêté sur un jeu.

    Bon je sait bien que pour scanner 801 titres ça peut être un long mais bon. Des plombes je te dit… Tu a dit que tu pouvait améliorer ça, alors OK do it ! héhéhé

    Je n’ai pas eu le temps de faire ce que je voulais pour cette version mais c’est une des ultra priorités pour la 1.2. En clair le scan se passe en deux temps majeurs. En premier il scan tout pour trouver des slaves et en second il essaye de déterminer quels tooltypes attribuer a chaque slave et créé une fiche correspondant pour chaque jeu de manière a le lancer directement en lisant cette fiche plutôt qu’en scanant les tooltype au lancement du jeu. Concernant la première partie (la recherche des slaves) j’ai fais quelques essais qui me donnent des performances très intéressantes mais encore trop plantogène pour le moment. Pour la seconde partie (la plus longue) l’idée est qu’il y aurait deux options de scan à l’avenir. Un complet qui chercherait tout les tooltypes et un second mode « allegé » qui ne scanerait que les slaves sans chercher les tooltypes. Cela permettrait par exemple de faire un scan 5 a 6 fois plus rapide en cas de simple mise à jour. De son côté le launcher aurait la capacité, en cas d’absence de « fiche » répertoriant les tooltypes du jeu a lancer, de les scanner et de créer la fiche manquante lors du premier lancement de ce jeu.

    J’ai aussi le souci que ok il scanne les slaves correctement mais quand on a des programmes sans slaves comme « The Dream of Rowann », il ne l’analyse pas et donc on les a pas dans XB3nch !

    Tu veux parler de jeux qui ne sont pas WHDload ?

    Bon sinon courage Jim, les lauriers 2019 ne sont pas très loin ! NB: Je confirme après avoir joué à une dizaine de jeux, elle est très stable, pas de plantages ! allez, APPROUVEE !

      :yahoo:

    Il existe déja une doc X-bench (il me semble que oui, c’est pour cela que je n’avais pas attaqué après Tiny) ou bien j’ai déja trouvé un autre truc à faire ultérieurement ?

    Il existe un tutoriel concernant le paramètrage d’xb que j’avais fait il y a quelques temps pour obligement mais il n’est plus forcément très à jour et il ne concerne pas l’utilisation d’xb et ses fonctions. Ce serait pas mal d’avoir un tuto ici. L’un des principaux soucis est que je n’ai jamais pris le temps de vraiment décrire toutes les fonctions du tool et pourtant il y en a des très puissante comme le moteur de recherche temps réel un peu à la google (les jeux défilent en même temps que tu tape le nom lettre par lettre).

    Comment je suis trop content !!! Bon je vais tester ça dans les prochains jours !!

    En route vers la version 1.2 maintenant !  :lol:

     

    A500 Plus - 2Mo de Chip - 128Mo Fast - 8Gb CF - 68080@78Mhz (Vampire V2+ inside)
    A1200 - 256Mo Fast - 80Gb HD - 68060@96Mhz - Delfina DSP - Wifi PCMCIA

    #48437
    Tim
    Tim
    • 88 Messages

    Salut Jim !

    Lorsque j’utilise ABS v207 et que j’essaye de lancer xbench à partir de celui-ci, j’ai un gros guru meditation !

    Alors je sait pas si c ‘est à toi ou plutot à gibs que je dois poser la question, mais existe t-il une séquence particulière à mettre dans le script d’ABS ?

    Moi j’ai fait:

    cd DH1:utilitaire/xbench

    execute x-bench

    Je précise que xbench se lance bien, enfin je vois la disquette et après Crack !

    –>  Ok, j’ai trouvé, j’ai rajouté dans le script C:SetPatch QUIET et là ca boot nickel

    Amiga 1200 / AmigaOS 3.1.4 KS 46.143 / ACA 1233n / HxC Lotharek
    C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
    ATARI 1040STE 4Mo / TOS 1.62+2.06 / HxC Lotharek / UltraSatan
    Amstrad CPC6128 / ZAX Drive 3 / Cyclone RX

    #48442
    Staff
    Jim
    Jim
    • 3 717 Messages

    Du coup tu t’es auto-répondu. :-p Effectivement setpatch reste obligatoire. D’une manière plus générale le contenu standard d’une startup-sequence est préférable mis à part le loadwb a remplacer par tes deux lignes précédentes.  ;-)

    A500 Plus - 2Mo de Chip - 128Mo Fast - 8Gb CF - 68080@78Mhz (Vampire V2+ inside)
    A1200 - 256Mo Fast - 80Gb HD - 68060@96Mhz - Delfina DSP - Wifi PCMCIA



    #48446
    Tim
    Tim
    • 88 Messages

    Ouep bon j’ai laissé tomber pour le moment ABS car ça a cafouillé grave et xbench plantait alors qu’il a fonctionné dès le départ(j’ai tout réinstallé et avec XB3nch vaut mieux tout effacer…) mais c’est surement comme tu dit il faudrait reprendre la SS et ensuite faire l’exécution, bref, je verrais ça plus tard.

    Sinon pour en revenir à Xbench, au final j’ai compris qu’il fallait renommer les exécutables en .EXE pour ceux qui ne le sont pas et qui n’ont pas de slave donc pas whdload.

    Et dans xbench il suffit donc de scanner les EXE et ça marche.

    Sauf pour ce foutu jeu Dream of Rowann qui, quand je le lance plante lamentablement sur XBench(mais bien sur fonctionne sur mon WB)… Bref de toutes façon,c’est pas grave vu que c’est une vrai daube et je sait même pas pourquoi j’ai acheté ce truc tellement c’est horrible et mal fait, enfin c’est mon avis.

    J’aime vraiment cette version de X-B3nch qui est effectivement aboutie dans l’ensemble. :good:

     

     

     

    Amiga 1200 / AmigaOS 3.1.4 KS 46.143 / ACA 1233n / HxC Lotharek
    C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
    ATARI 1040STE 4Mo / TOS 1.62+2.06 / HxC Lotharek / UltraSatan
    Amstrad CPC6128 / ZAX Drive 3 / Cyclone RX

    #48523
    triki
    triki
    • 21 Messages

    Salut a tous, Jim pour la config c’est tout bon.

    J’ai téléchargé et installé la dernière version. J’ai rencontré le même problème que Tim pour le scan des jeux. Je mis suis repris a deux fois, je pensais que cela buggait ;). En lisant tes explications sur le scan j’ai compris pourquoi.

    Sinon vis a vis de la vitesse, sur ma petite wii c’est bien mieux que la Beta.

    C’est une très bonne idée votre tutorial, a votre niveau tout est facile, et ce qui vous parait évident est pour nous non initiés une montagne de difficultés. Qui une fois passé donne tout sont charme a un émulateur. Vraiment ça claque.

    J’ai quasiment fini ma configuration, une fois fait je vais partager mes hd x-bench et abs sur un forum wii. Je vous donneraient les retours et les liens. Je vous dis tout de suite c’est du jamais vu sur WII, même sur tout autre console possédant UAE.

    Bravo pour votre travail, la classe les gars.

     

     

    #48539
    Staff
    Jim
    Jim
    • 3 717 Messages

    :good:

    A500 Plus - 2Mo de Chip - 128Mo Fast - 8Gb CF - 68080@78Mhz (Vampire V2+ inside)
    A1200 - 256Mo Fast - 80Gb HD - 68060@96Mhz - Delfina DSP - Wifi PCMCIA

    #51538
    Tim
    Tim
    • 88 Messages

    Salut les potos !

     

    Une question Jim:

    Soit mon amiga s’économise tout seul, soit y’a un truc dans la dernière version de xbench qui a changé ou soit je suis fou…(on va exclure la dernière hein ?!!).

    en effet je lance n’importe quel jeu, et si je n’y touche pas et le laisse tourner, au bout d’un moment j’ai pas trop calculé, y’a une sorte de timeout et il me sort du jeu et revient à xbench.

    y’a une option dans xbench que tu aurais rajouté ? ou j’ai un autre soucis ?

    :wacko:

    Amiga 1200 / AmigaOS 3.1.4 KS 46.143 / ACA 1233n / HxC Lotharek
    C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
    ATARI 1040STE 4Mo / TOS 1.62+2.06 / HxC Lotharek / UltraSatan
    Amstrad CPC6128 / ZAX Drive 3 / Cyclone RX

    #51553
    Staff
    Jim
    Jim
    • 3 717 Messages

    Yo !

    Effectivement ca fait ca par défaut maintenant. Tu peux désactiver l’option « MegaloJim » dans le panneau de setup. Elle a été ajoutée et activée par défaut parce qu’il me parait essentiel que mon magnifique soft soit affiché a l’écran plus longtemps que les jeux que l’on lance …

    :lol:

    Bon sinon plus sérieusement ton soucis ne doit pas être lié à XB. Tu as modifié d’autres choses dans ta config logicielle ? Essaye de lancer les jeux qui quittent tout seuls depuis le Workbench pour checker ca.  ;-)

    A500 Plus - 2Mo de Chip - 128Mo Fast - 8Gb CF - 68080@78Mhz (Vampire V2+ inside)
    A1200 - 256Mo Fast - 80Gb HD - 68060@96Mhz - Delfina DSP - Wifi PCMCIA

Partager sur vos réseaux sociaux préférés :
Facebooktwittergoogle_plusredditpinterestlinkedintumblrmail
15 sujets de 136 à 150 (sur un total de 168)

Vous devez être connecté pour répondre à ce sujet.