X-bEnCh – Support francophone officiel

Forum News Room Projets X-bEnCh – Support francophone officiel

  • Ce sujet contient 314 réponses, 25 participants et a été mis à jour pour la dernière fois par subone, le il y a 1 semaine et 1 jour.
  • Créateur
    Sujet
  • #1887
    Staff
    Jim Neray
    • Level 21
    • Messages : 6635

    X-bEnCh est un croisement entre un frontend (un lanceur de jeux whdloads et executables, sous forme de listings de lancement), un gestionnaire de fichier (le fameux X-pl0rEr) et un shell (cli). L’idée de ce projet est de retrouver un look type cracktro à l’ancienne.

    Avec 640 couleurs à l’écran en AGA (128 en OCS/ECS), ce « Frontend » peut scanner votre disque dur (ou carte compact flash) pour y trouver tout vos jeux whdloads ou vos .exe et les organiser en jolies listes de lancements classées par ordre alphabétiques. X-bEnCh vous permet également de créer des listes à la main et possède un système de scripts, les « X-bEnCh Scripts » (Pour les jeux non whdload par exemple ou pour les jeux whdloads qui nécessiteraient des paramètres très particuliers). Il est compatible avec tout type d’Amiga et requiert peu de ressources. Il a un système de playlists audio intégré vous permettant de vous faire des compilations jouées aléatoirement à chaque lancement.

    Liste des features actuelles:
    – Jusqu’a 640 couleurs à l’écran en AGA (128 couleurs en OCS/ECS).
    – Captures d’écrans des jeux (partielle pour le moment).
    – Une playlist avec les meilleures mods des cracktros inclus.
    – Scan automatiquement et organises vos whdload et vos executables en listings.
    – Nombre de sous répertoires illimités pour le scan de vos disque dur.
    – Système de scripts.
    – Jusqu’à 6 listings en parallèle.
    – Longueur des listes illimitées.
    – « Top listing » multi-listes auto généré en fonction de ce que vous exécutez.
    – Détection automatique des Tooltypes Whdload de chaque jeux.
    – Si aucun tooltypes n’est détecté vous pouvez paramètrer des tooltypes par défaut.
    – Mode MegaRam pour économiser le maximum de ram chip.
    – Moteur de recherche temps réel dans vos listings (commencez à taper le nom du jeu)
    – Compatibilité et gestion du pad CD32 à 7 buttons.
    – « CDMode » pour vos compilation CD32/CDTV.
    – Gestionnaire de fichier intégré (Xpl0rEr).
    – cLi 100% compatible avec le cli Amiga (mais avec des commandes supplémentaires).
    – Panneau de paramètrages au look « system friendly ».
    – Installer dédié pour une installation facilitée.

    La dernière version en date est la 1.00 X-Mas 2017 Pre release. Vous pouvez la télécharger sur mon site.

    Si vous voulez me suivre sur Twitter: @jimneray

    Tout vos retours sont les bienvenus  ;-)

    A500 - A500 Plus - A600 HD - A1200 - A2000 - A4000T - CD32 - C=64 - 1040STE - CPC6128
    Ma config principale : Amiga 500 Plus (+A590), 2MB Chip, 2MB Fast, HD 1,2GB, Floppy ext.
    Micromiga.com - La boutique Amiga

Affichage de 15 réponses de 286 à 300 (sur un total de 314)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #133020
    Staff
    Zarnal
    • Level 21
    • Messages : 6505

    La question est donc quelle est la différence qui coince entre Jim:Demos et Jim:Jeux-Collec :scratch:

    Rien pour l’instant. C’est le même répertoire renommé. :unsure:

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



    #133022
    Staff
    Zarnal
    • Level 21
    • Messages : 6505

    Je suis en kick 3.0.

    Je vais voir en 3.1.

    Edit : pas mieux. :unsure:

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #133023
    Staff
    Jim Neray
    • Level 21
    • Messages : 6635

    La question est donc quelle est la différence qui coince entre Jim:Demos et Jim:Jeux-Collec :scratch:

    Rien pour l’instant. C’est le même répertoire renommé. :unsure:

    Ok c’est encore pire que ce que je pensais alors. A tout hasard ajoute un slash manuellement à la fin du path de scan avant de lancer :scratch:

    Je suis en kick 3.0. Je vais voir en3.1.

    Ah pas testé en kick 3.0. Je ne pense pas que le soucis vienne de là mais je suis quand même curieux du retour :scratch:

    A500 - A500 Plus - A600 HD - A1200 - A2000 - A4000T - CD32 - C=64 - 1040STE - CPC6128
    Ma config principale : Amiga 500 Plus (+A590), 2MB Chip, 2MB Fast, HD 1,2GB, Floppy ext.
    Micromiga.com - La boutique Amiga

    #133026
    Staff
    Zarnal
    • Level 21
    • Messages : 6505

    Pas mieux au 3.1. :unsure:

    Mais diantre, pourquoi accepte t’il mon répertoire Demos et pas mon répertoire Jeux ??? :wacko:

    Trop d’éléments ? Je teste d’ici peu.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #133032
    Staff
    Zarnal
    • Level 21
    • Messages : 6505

    @Jim @razstore

    J’ai trouvé la source du problème. Souci de hiérarchie. Depuis la racine/répertoire, l’erreur se manifeste. :unsure:

    Il faut impérativement créer un sous répertoire dans le répertoire des jeux.

    Exemple :

    DH0:Jeux/ ( ou n’importe quel autre répertoire crée ) —-> Ne fonctionne pas  » Object not found « .

    DH0:Jeux/Jeux/ —-> Ok.

    Cela explique également pourquoi mon répertoire Démos fonctionne ( sous dossiers de A à Z ).

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #133039
    Staff
    Jim Neray
    • Level 21
    • Messages : 6635

    Il faut impérativement créer un sous répertoire dans le répertoire des jeux.

    Oui ! Effectivement je n’y avais pas pensé car un simple changement de nom de répertoire semblait changer ce que tu arrivais à scanner ou pas. Il faudra que je regarde mais sur le full mode (old slow) le soucis ne devrait pas exister puisque ce mode est censé prévoir ce genre de cas. A moins que je l’ai raboté sans m’en souvenir pour gagner une étape de scan. Dans les faits avoir des dizaines ou des centaines de jeux à la racine de scan sans sous répertoire parait un peu improbable je pense. Je me trompe ou certain ont réellement beaucoup de jeux sans classement en sous répertoire ? :scratch:

    A500 - A500 Plus - A600 HD - A1200 - A2000 - A4000T - CD32 - C=64 - 1040STE - CPC6128
    Ma config principale : Amiga 500 Plus (+A590), 2MB Chip, 2MB Fast, HD 1,2GB, Floppy ext.
    Micromiga.com - La boutique Amiga

    #133040
    Tempus
    • Level 1
    • Messages : 23

    De mon côté:

    PFS3 sous le core MINIMIG du MISTer.

    Amiga 500+ACA500+ACA1232+Sony Trinitron
    Amiga 500+ ACA500+
    Amiga 3000+FastATA 4000+Big Ram Plus 256mb+1083S
    Amiga 1200+1230IV+Copro+1085S
    Minimig+contrôleur ARM 40MHhz 4M0
    Mist

    #133041
    Staff
    Zarnal
    • Level 21
    • Messages : 6505

    Il faut impérativement créer un sous répertoire dans le répertoire des jeux.

    Oui ! Effectivement je n’y avais pas pensé car un simple changement de nom de répertoire semblait changer ce que tu arrivais à scanner ou pas. Il faudra que je regarde mais sur le full mode (old slow) le soucis ne devrait pas exister puisque ce mode est censé prévoir ce genre de cas. A moins que je l’ai raboté sans m’en souvenir pour gagner une étape de scan. Dans les faits avoir des dizaines ou des centaines de jeux à la racine de scan sans sous répertoire parait un peu improbable je pense. Je me trompe ou certain ont réellement beaucoup de jeux sans classement en sous répertoire ? :scratch:

    @Jim

    Nous nous sommes mal compris. Chaque jeu a son sous répertoire. Voici mon DH0/Jeux qui pose problème :

    Même chose sous WinUae :

    Maintenant, si je crée un sous répertoire quelconque dans mon répertoire  » Jeux  » ( exemple  »  Jeux2  » et que j’y glisse mes répertoires individuels de jeux que tu vois sur l’image au dessus, le scan se passe normalement. :unsure:   Alors que si je scanne directement le répertoire  » Jeux  » l’erreur se manifeste.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #133045
    razstore
    • Level 4
    • Messages : 140

    Ton scanne passe avec un sous répertoire mais en quel mode « Full » ou « Fast »

    En « Full » mon scanne passe bien avec répertoire DH1:Jeux/GAMES1

    J’ai mis EAB_WHDLOAD a jour trié que j’ai divisé en 6

    Donc j’essaie : DH1:Jeux/GAMES1, DH1:Jeux/GAMES2, DH1:Jeux/GAMES2, DH1:Jeux/GAMES3, DH1:Jeux/GAMES4,DH1:Jeux/GAMES5, DH1:Jeux/GAMES6

    En « FAST » ça ne passe pas

     

     

     

     

    Amiga 1200 Blizzard IV 1230 Graveur UltraPlex 40x- 2 CD32- 2 Amiga 500- Nvidia Shield Pro Émulation Amiga UAE4ARM Amikit Amigasys4 HyperSpin

    #133046
    Staff
    Zarnal
    • Level 21
    • Messages : 6505

    Ton scanne passe avec un sous répertoire mais en quel mode « Full » ou « Fast »

    En fast uniquement.

    En « Full » mon scanne passe bien avec répertoire DH1:Jeux/GAMES1

    Pas de mon coté en DH0:Jeux. :unsure:

    J’ai mis EAB_WHDLOAD a jour trié que j’ai divisé en 6

    Pourquoi diviser en 6 si le mode Full ne te pose pas de souci ?  :scratch:   Un peu plus long je te l’accorde.

    Si tu divises en 6, il faut prendre DH0:Jeux comme répertoire de base. Ensuite cela ira chercher tout seul dans les sous répertoires.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



    #133062
    razstore
    • Level 4
    • Messages : 140

    Sur mes clés usb et sur AmigaBootSelector (AmigaSYS4, TinyLauncher et XBench

    Je faisais les scanne direct sur la clé USB, Fast ne fonctionnait pas

    J’ai essayé les scanne clé USB et AmigaBootSelector sur FS-UAE Launcher, Fast

    ne fonctionnait pas

    J’ai essayé les 2 avec WINUAE et c’est bon !!!

    Amiga 1200 Blizzard IV 1230 Graveur UltraPlex 40x- 2 CD32- 2 Amiga 500- Nvidia Shield Pro Émulation Amiga UAE4ARM Amikit Amigasys4 HyperSpin

    #133064
    Staff
    Zarnal
    • Level 21
    • Messages : 6505

    Au moins c’est réglé. :good:

    @chef

    Il y a toujours ce souci avec le retour à l’interface avec certains utilitaires ( exe ). :-p

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #133101
    Staff
    Zarnal
    • Level 21
    • Messages : 6505

    @Jim

    Petit glitch cosmétique au nag screen.

     » please visit unknowncontent.fr « . En 3.1 et 3.2 ( logique ).

    Je poursuis mes tests en 3.2.

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #133104
    Staff
    Zarnal
    • Level 21
    • Messages : 6505

    A prendre avec des pincettes ( jusqu’aux tests plus approfondis ).

    Il semble y avoir encore un souci dans les scans Fast et Full en 3.2 sous WB/Installation fraiche pour les deux.

    Même en créant un sous répertoire comme en 3.1 ( Jeux/Jeux ).

     » Objet non trouvés  » et +-71 jeux/600 trouvés.

    :scratch:

    Je verrai plus en détails demain. Je n’ai plus trop le  temps ce soir. :unsure:

    Edit : cela semble un peu mieux sans JIT. Cela ne semble pas trop aimer le JIT direct en cas de JIT. Edit 2 : en fait non… :lol:

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #133112
    Staff
    Zarnal
    • Level 21
    • Messages : 6505

    @Jim

    J’ai fait des tests au calme avec l’OS 3.2.1.

     

    Important : mes jeux sont placés dans Systeme/Jeux/Jeux/.

     

    Si je scanne ( dans les deux modes  » Fast  » et  » Full  » )  Systeme/Jeux/Jeux l’erreur se manifeste systématiquement. Seuls quelques jeux ( 71 ) sont reconnus.

     

     

    Par contre, si je me contente de scanner Systeme/Jeux/ tout se passe bien et dans les deux modes.

     

    Mais c’est +- la même chose en 3.1/3.0. Ce n’est pas spécifique au 3.2. :unsure:

    Note : j’ai utilisé un Hdf cette fois ci ( en IDE ). Je constate donc que c’est la même chose qu’avec les répertoires. :unsure:

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail
Affichage de 15 réponses de 286 à 300 (sur un total de 314)
  • Vous devez être connecté pour répondre à ce sujet.