X-bEnCh – Support francophone officiel

Forum News Room Projets X-bEnCh – Support francophone officiel

  • Ce sujet contient 270 réponses, 23 participants et a été mis à jour pour la dernière fois par razstore, le il y a 2 semaines.
  • Créateur
    Sujet
  • #1887
    Staff
    Jim Neray
    • Level 21
    • Messages : 6181

    X-bEnCh est un croisement entre un frontend (un lanceur de jeux whdloads et executables, sous forme de listings de lancement), un gestionnaire de fichier (le fameux X-pl0rEr) et un shell (cli). L’idée de ce projet est de retrouver un look type cracktro à l’ancienne.

    Avec 640 couleurs à l’écran en AGA (128 en OCS/ECS), ce « Frontend » peut scanner votre disque dur (ou carte compact flash) pour y trouver tout vos jeux whdloads ou vos .exe et les organiser en jolies listes de lancements classées par ordre alphabétiques. X-bEnCh vous permet également de créer des listes à la main et possède un système de scripts, les « X-bEnCh Scripts » (Pour les jeux non whdload par exemple ou pour les jeux whdloads qui nécessiteraient des paramètres très particuliers). Il est compatible avec tout type d’Amiga et requiert peu de ressources. Il a un système de playlists audio intégré vous permettant de vous faire des compilations jouées aléatoirement à chaque lancement.

    Liste des features actuelles:
    – Jusqu’a 640 couleurs à l’écran en AGA (128 couleurs en OCS/ECS).
    – Captures d’écrans des jeux (partielle pour le moment).
    – Une playlist avec les meilleures mods des cracktros inclus.
    – Scan automatiquement et organises vos whdload et vos executables en listings.
    – Nombre de sous répertoires illimités pour le scan de vos disque dur.
    – Système de scripts.
    – Jusqu’à 6 listings en parallèle.
    – Longueur des listes illimitées.
    – « Top listing » multi-listes auto généré en fonction de ce que vous exécutez.
    – Détection automatique des Tooltypes Whdload de chaque jeux.
    – Si aucun tooltypes n’est détecté vous pouvez paramètrer des tooltypes par défaut.
    – Mode MegaRam pour économiser le maximum de ram chip.
    – Moteur de recherche temps réel dans vos listings (commencez à taper le nom du jeu)
    – Compatibilité et gestion du pad CD32 à 7 buttons.
    – « CDMode » pour vos compilation CD32/CDTV.
    – Gestionnaire de fichier intégré (Xpl0rEr).
    – cLi 100% compatible avec le cli Amiga (mais avec des commandes supplémentaires).
    – Panneau de paramètrages au look « system friendly ».
    – Installer dédié pour une installation facilitée.

    La dernière version en date est la 1.00 X-Mas 2017 Pre release. Vous pouvez la télécharger sur mon site.

    Si vous voulez me suivre sur Twitter: @jimneray

    Tout vos retours sont les bienvenus  ;-)

    A500 - A500 Plus - A600 HD - A1200 - A2000 - A4000T - CD32 - C=64 - 1040STE - CPC6128
    Micromiga.com - Le Webshop Amiga

15 réponses de 241 à 255 (sur un total de 270)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #127344
    Staff
    Zarnal
    • Level 20
    • Messages : 5299

    Essaye cela ( je reproduis ton plantage si cela reste sur  » Original « . :

     

    et au pire, si cela plante toujours, tu pourras refaire une install avec  » x-installer  » après pour voir.

    Je suppose que c’est le même Hdf que celui de ta clé qui est utilisé ?

    J’ai également la 1.2B1 sans compteur.

    Note : ces UAE Roms peuvent être une vraie plaie dans de très rares circonstances mais sont indispensables pour certaines choses ( accès aux répertoires depuis le HD PC par exemple, les émulations de matériels et j’en passe ).

    A la limite, le plus intéressant, à partir du moment où c’est bien la source du problème, est de la désactiver et de coller ton hdf directement en IDE. Surtout si ce n’est que pour jouer.

    Restera à voir le  » cas  » FS-UAE après.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



    #127372
    Staff
    Zarnal
    • Level 20
    • Messages : 5299

    @raztore

    J’ai regardé attentivement la cle et j’ai trouvé une solution potentielle.

    Je n’avais pas vu la première que les configurations étaient séparées et facilement éditables.

    Il faut ouvrir le fichier  » host-props  » dans le réépertoire  » configs  » de ta clé. Il sert à indiquer la configuration par défaut qui sera utilisée. Le contenu :

    #host properties here in bash style
    #every prop need to be prefixed with « export »

    #after uae close do:
    # restart_uae
    # reboot
    # shutdown
    # spawn_shell
    AFTER_UAE_STOP= »spawn_shell »

    #UAE CONFIG FILE TO LOAD (from configs directory on flashdrive)
    UAE_CONFIG_FILE=amiga-1200.fs-uae

     

     

    Ensuite, tu ajoutes ces deux lignes dans le fichier  » amiga-1200.fs-uae  » situé dans le même répertoire :

    uaeboard=full+indirect

     

    et en option :

    cpu_cycle_exact=true
    cpu_memory_cycle_exact=true
    blitter_cycle_exact=true
    cycle_exact=true

    Au moins, on peut facilement éditer. Voir importer directement une configuration WinUae.

    Je vais tester. :-p

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #127381
    Staff
    Zarnal
    • Level 20
    • Messages : 5299

    Oublie. Il y a toujours plantage avec fs-uae. :unsure:

    Et je ne suis pas sûr que les intitulés des options correspondent dans tous les cas entre WinUae et Fs-Uae.

    Il faut que je vérifie.

    On verra ce soir.  ;-)

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #127391
    Staff
    Zarnal
    • Level 20
    • Messages : 5299

    J’ai tout essayé. :unsure:

    Toujours un guru 20 avec la clé. :wacko:

    Il faudrait essayer Fs-Uae sous Windows. Et là c’est game over pour moi à cause de l’openGL.

     

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #127393
    razstore
    • Level 3
    • Messages : 81

    J’ai installé fs-uae-launcher sous Windows et j’ai modifié la config.

    C’est bon plus de Guru au démarrage avec la clé.

    Quand je clique sur un jeux, il ne trouve pas le chemin.

    Ce qui est peut être normal, si je clique sur « Setup » j’ai un Guru :wacko:

    Le Shell et le Xplorer fonctionne

    Amiga 1200 Blizzard IV 1230 Graveur UltraPlex 40x- 2 CD32- 2 Amiga 500- Nvidia Shield Pro Émulation Amiga UAE4ARM Amikit Amigasys4 HyperSpin

    #127396
    Staff
    Zarnal
    • Level 20
    • Messages : 5299

    J’ai installé fs-uae-launcher et j’ai modifié la config et c’est bon plus de Guru au démarrage avec la clé Quand je clique sur un jeux, il ne trouve pas le chemin Ce qui est peut être normal, je clique sur « Setup » j’ai un Guru

    On ne va pas s’en sortir.  :lol: J’ai l’impression qui plus est, que ces plantages sont aléatoires. Je lance ma config sous WinUae et c’est Ok. Je reboote, je relance et je me retrouve avec un guru. Je reboote à nouveau et cela fonctionne. :wacko:

    Dans le réglage CPU, il faudrait l’équivalence du mode Fastest, sans JIT, et le chipset entièrement cyclé.

    Je vais créer un Hdf pour tester une théorie vis à vis de l’IDE.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #127423
    razstore
    • Level 3
    • Messages : 81

    Bon !!!

    Toujours au même point , fonctionne nickel sur WinUAE

    mais sur FS-uae, j’ai toujours un Guru sur « Setup » et un « Can’t allocate ShadowMem » quand je lance un jeux

    Pourquoi cette différence? :wacko:

    Ça commence a fumer la haut :cry:

    Amiga 1200 Blizzard IV 1230 Graveur UltraPlex 40x- 2 CD32- 2 Amiga 500- Nvidia Shield Pro Émulation Amiga UAE4ARM Amikit Amigasys4 HyperSpin

    #127428
    Staff
    Zarnal
    • Level 20
    • Messages : 5299

    Bon !!! Toujours au même point , fonctionne nickel sur WinUAE mais sur FS-uae, j’ai toujours un Guru sur « Setup » et un « Can’t allocate ShadowMem » quand je lance un jeux Pourquoi cette différence? :wacko: Ça commence a fumer la haut :cry:

    Sous FS-Uae tu as suffisament de Fast Ram de configurée ? Généralement ( sous WHDLoad ) c’est ce qui arrive lorsqu’il n’y en a pas assez ( tout comme l’erreur ExpMem ). Surtout si le TT  » Preload  » est activé ( désactivable dans le menu  » WhdLoad  » de X-Bench mais c’est vivement déconseillé pour les conséquences habituelles ).

    Après, je ne vais pas trop m’avancer pour FS-Uae car les raisons peuvent être multiples pouvant aller du simple souci technique jusqu’à un  » décalage temporel  » par rapport au core de WinUae. Ou bien quelque chose de spécifique à la version Linux. Je n’ai pratiquement jamais utilisé cet émulateur à contrario de WinUae. :unsure:   Par contre j’ai commencé à l’utiliser avec le lien que tu as donné pour Amilator.

    Ce n’est peut être qu’un hasard mais j’ai remarqué lors du test de certaines démos AGA, que les problèmes étaient identiques à ceux de l’ancien WinUae 3.1 par exemple. :unsure:   J’irai jeter un oeil dans les docs et changelogs dès que j’aurais un moment.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #127439
    razstore
    • Level 3
    • Messages : 81

    Bon voila tout fonctionne sur la clé usb :yahoo:

    Rajout de 2 mega de fast mémoire pour certains jeux comme

    Sensible Soccer 96-97

    Ajustement de résolution

    Par contre ne prend la configuration A1200 3.1 rom et fonctionne configuration  A500 avec processeur 68020 c’est bizarre

    Si je met la configuration A1200 c’est le Guru

    Amiga 1200 Blizzard IV 1230 Graveur UltraPlex 40x- 2 CD32- 2 Amiga 500- Nvidia Shield Pro Émulation Amiga UAE4ARM Amikit Amigasys4 HyperSpin

    #127448
    Staff
    Zarnal
    • Level 20
    • Messages : 5299

    Le bon coté des choses, c’est que ton Guru arrive après le lancement.

    Le  » mien « , sous Windows est instantané avec Fs-Uae ( driver générique windows 8, tout ce qui demande OGL plante lamentablement et le bon de 7 a des problèmes sous 8.1 :wacko: ). :lol: :lol: :lol:

     

    Avec la clé, cela facilite les choses.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



    #127462
    razstore
    • Level 3
    • Messages : 81

    Je suis sous Windows 10 et je n’ai plus de Guru

    Je me sers de « FS-UAE Launcher » pour récupérer les configs « amiga-1200.fs-uae »

    qui fonctionnent et de les mettre dans l’Amilator de la clé USB

    Amiga 1200 Blizzard IV 1230 Graveur UltraPlex 40x- 2 CD32- 2 Amiga 500- Nvidia Shield Pro Émulation Amiga UAE4ARM Amikit Amigasys4 HyperSpin

    #127464
    Staff
    Zarnal
    • Level 20
    • Messages : 5299

    Je suis sous Windows 10 et je n’ai plus de Guru

    C’est l’essentiel.  ;-)

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #127466
    razstore
    • Level 3
    • Messages : 81

    Merci pour ton aide

    Je vais tenter une clé USB avec AmigaBootSelector

    En ayant TinyLauncher , Xbench et AmigaSYS4

    pour voir si c’est possible

    Amiga 1200 Blizzard IV 1230 Graveur UltraPlex 40x- 2 CD32- 2 Amiga 500- Nvidia Shield Pro Émulation Amiga UAE4ARM Amikit Amigasys4 HyperSpin

    #127491
    Staff
    Zarnal
    • Level 20
    • Messages : 5299

    En principe cela devrait passer. J’ai testé hier soir ( WinUae ). Je mettrai sur la clé ce soir pour voir.

    Attention à X-Bench et au JIT, même souci. :unsure:

    @ Jim

    Serait il possible de modifier une option quelconque à la compilation pour tenter d’arranger cela ?

    De mon coté, je ferai un report coté WinUae. Mais il faut vraiment être certain que cela ne soit pas lié au CPU. :unsure:

    Edit : report fait, et RAS.  :wacko:

    En tout cas, X-Bench n’aime pas du tout le JIT en fastest.

    Et mon Hdf était en OFS parce que j’ai utilisé vite fait ADF Opus pour le créer avec tout par défaut.  :lol:

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #127496
    razstore
    • Level 3
    • Messages : 81

    Bonsoir,

    Voila ce que ça donne au final sur clé USB avec le thème « 1084x_night_wall_white_1.0 » :good:

    J’ai donc fait une clé USB pour TinyLauncher et une pour Xbench

    J’ai commençé celle de AmigaBootSelector

    Le plus long c’est les transferts de fichiers

    Amiga 1200 Blizzard IV 1230 Graveur UltraPlex 40x- 2 CD32- 2 Amiga 500- Nvidia Shield Pro Émulation Amiga UAE4ARM Amikit Amigasys4 HyperSpin

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail
15 réponses de 241 à 255 (sur un total de 270)
  • Vous devez être connecté pour répondre à ce sujet.