X-bEnCh – Support francophone officiel

Forum News Room Projets X-bEnCh – Support francophone officiel

  • Ce sujet contient 270 réponses, 23 participants et a été mis à jour pour la dernière fois par razstore, le il y a 1 mois et 4 semaines.
  • Créateur
    Sujet
  • #1887
    Staff
    Jim Neray
    • Level 21
    • Messages : 6222

    X-bEnCh est un croisement entre un frontend (un lanceur de jeux whdloads et executables, sous forme de listings de lancement), un gestionnaire de fichier (le fameux X-pl0rEr) et un shell (cli). L’idée de ce projet est de retrouver un look type cracktro à l’ancienne.

    Avec 640 couleurs à l’écran en AGA (128 en OCS/ECS), ce « Frontend » peut scanner votre disque dur (ou carte compact flash) pour y trouver tout vos jeux whdloads ou vos .exe et les organiser en jolies listes de lancements classées par ordre alphabétiques. X-bEnCh vous permet également de créer des listes à la main et possède un système de scripts, les « X-bEnCh Scripts » (Pour les jeux non whdload par exemple ou pour les jeux whdloads qui nécessiteraient des paramètres très particuliers). Il est compatible avec tout type d’Amiga et requiert peu de ressources. Il a un système de playlists audio intégré vous permettant de vous faire des compilations jouées aléatoirement à chaque lancement.

    Liste des features actuelles:
    – Jusqu’a 640 couleurs à l’écran en AGA (128 couleurs en OCS/ECS).
    – Captures d’écrans des jeux (partielle pour le moment).
    – Une playlist avec les meilleures mods des cracktros inclus.
    – Scan automatiquement et organises vos whdload et vos executables en listings.
    – Nombre de sous répertoires illimités pour le scan de vos disque dur.
    – Système de scripts.
    – Jusqu’à 6 listings en parallèle.
    – Longueur des listes illimitées.
    – « Top listing » multi-listes auto généré en fonction de ce que vous exécutez.
    – Détection automatique des Tooltypes Whdload de chaque jeux.
    – Si aucun tooltypes n’est détecté vous pouvez paramètrer des tooltypes par défaut.
    – Mode MegaRam pour économiser le maximum de ram chip.
    – Moteur de recherche temps réel dans vos listings (commencez à taper le nom du jeu)
    – Compatibilité et gestion du pad CD32 à 7 buttons.
    – « CDMode » pour vos compilation CD32/CDTV.
    – Gestionnaire de fichier intégré (Xpl0rEr).
    – cLi 100% compatible avec le cli Amiga (mais avec des commandes supplémentaires).
    – Panneau de paramètrages au look « system friendly ».
    – Installer dédié pour une installation facilitée.

    La dernière version en date est la 1.00 X-Mas 2017 Pre release. Vous pouvez la télécharger sur mon site.

    Si vous voulez me suivre sur Twitter: @jimneray

    Tout vos retours sont les bienvenus  ;-)

    A500 - A500 Plus - A600 HD - A1200 - A2000 - A4000T - CD32 - C=64 - 1040STE - CPC6128
    Micromiga.com - Le Webshop Amiga

15 réponses de 256 à 270 (sur un total de 270)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #127525
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    J’ai un truc terminé si tu ne veux pas trop te prendre la tête ( sans le contenu bien sûr ), celui de la vidéo ( ASYS4+Tiny+X-Bench+ABS ).

    En Hdf ou bien en répertoire ( plus pratique à mon avis ).

    Question : ton ratio d’écran, c’est volontaire ? C’est écrasé à première vue.

    HS : je me suis encore trop précipité pour mon report de bug pour X-Bench, le hdf était incomplet. Décidément…

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



    #127543
    razstore
    • Level 4
    • Messages : 123

    Oui le ratio d’écran est a réglé

    Je ferais l’affinage plus tard, je profite un peu du beau temps dehors

    Oui je veux bien ton HDF et ton répertoire ça m’éviterai la prise de chou

    Merçi :good:

     

    Amiga 1200 Blizzard IV 1230 Graveur UltraPlex 40x- 2 CD32- 2 Amiga 500- Nvidia Shield Pro Émulation Amiga UAE4ARM Amikit Amigasys4 HyperSpin

    #127548
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    @razstore

    je t’envoie d’ici 5mn un MP avec le lien pour le récupérer.

    J’ai ajouté la dernière version de WhdLoad mais il faudra régler manuellement toi même les répertoires où sont placés tes jeux ( Tiny Launcher et X-Bench ). J’ai malencontreusement effacé ma version en tout répertoire. :unsure: Là, à ce moment précis, je n’ai pas le temps de la refaire. :unsure:   On verra ce soir.

    Edit du soir : j’ai refait la version tout en répertoires. Dispo au besoin.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #127563
    razstore
    • Level 4
    • Messages : 123

    Merci pour tes fichiers :good:

    j’ai testé sur FS-UAE Launcher et ça fonctionne

    Mais je ne comprend pas que AmigaSYS4 est très lent alors que dans WinUAE

    c’est rapide en paramétrant les 2 en 68060

    Amiga 1200 Blizzard IV 1230 Graveur UltraPlex 40x- 2 CD32- 2 Amiga 500- Nvidia Shield Pro Émulation Amiga UAE4ARM Amikit Amigasys4 HyperSpin

    #127573
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Merci pour tes fichiers :good: j’ai testé sur FS-UAE Launcher et ça fonctionne Mais je ne comprend pas que AmigaSYS4 est très lent alors que dans WinUAE c’est rapide en paramétrant les 2 en 68060

    Tu pars exactement des mêmes paramètres pour WinUae et Fs-Uae en dehors du 060  ?

    Il faut commencer par regarder si une potentielle différence sur les éléments essentiels ( CPU/FPU/RAM/Chipset/RTG ) du coté du réglage du fichier de configuration n’apparait pas.

    Le problème se manifeste t’il juste sur la clé ou bien également sous la version Windows de Fs-Uae ?

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #127585
    razstore
    • Level 4
    • Messages : 123

    Le problème est sous Windows avec WinUAE et FS-UAE

    J’ai installé Amiga Forever pour avoir les bons Kickstarts

    et avec AmigaSYS41 c’est plus rapide

    Je vais repartir sur la base de AmigaSYS41 de Amiga Forever

    Amiga 1200 Blizzard IV 1230 Graveur UltraPlex 40x- 2 CD32- 2 Amiga 500- Nvidia Shield Pro Émulation Amiga UAE4ARM Amikit Amigasys4 HyperSpin

    #127593
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Le problème est sous Windows avec WinUAE et FS-UAE J’ai installé Amiga Forever pour avoir les bons Kickstarts et avec AmigaSYS41 c’est plus rapide Je vais repartir sur la base de AmigaSYS41 de Amiga Forever

    Tu n’as pas de soucis avec X-Bench dans cette config AForever ?

    J’ai bien l’impression que ton souci de vitesse est lié à la désactivation du JIT qui a été faite ( indispensable pour que Xbench ne plante pas, en tout cas sur un WB 3.1 standard ).  :unsure:

    Donne moi des nouvelles stp dès que ton installation AF4/AmiSYS4 est faite. Je suis curieux de connaitre le résultat avec X-Bench par rapport à la vitesse.  :scratch:

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #127702
    razstore
    • Level 4
    • Messages : 123

    Non pas de soucis avec Forever !!!

    Oui effectivement dés que je désactive le JIT, AmigaSYS41 est lent

    Il faut 2 paramétrages de FS-UAE, avec ou sans le JIT d’activé

    Je crois qu’il n’y a pas de solution fiable entre AmigaBootSelector et XBench :cry:

    Avec TinyLauncher pas de soucis avec AmigaSYS41

    Dommage ça aurait été sympa d’avoir AmigaBootSelector,TinyLauncher et XBench sur même clé USB

     

    Amiga 1200 Blizzard IV 1230 Graveur UltraPlex 40x- 2 CD32- 2 Amiga 500- Nvidia Shield Pro Émulation Amiga UAE4ARM Amikit Amigasys4 HyperSpin

    #127707
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Non pas de soucis avec Forever !!! Oui effectivement dés que je désactive le JIT, AmigaSYS41 est lent Il faut 2 paramétrages de FS-UAE, avec ou sans le JIT d’activé Je crois qu’il n’y a pas de solution fiable entre AmigaBootSelector et XBench :cry: Avec TinyLauncher pas de soucis avec AmigaSYS41 Dommage ça aurait été sympa d’avoir AmigaBootSelector,TinyLauncher et XBench sur même clé USB

    J’ai peut être une solution. Cela m’a réglé l’ensemble de mes soucis avec le JIT sous WinUae. Je n’ai plus le temps ce soir pour tester avec FS-Uae car j’ai des obligations. Je testerai demain avec ma clé. Je te tiens au courant.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #127727
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    @razstore

    C’est gagné. :yahoo:   Clé+ Fs-Uae + JIT + ASYS4 + Abs + Tiny.

     

    Solution ( plutôt à appliquer sous Windows )

    Tu lances X-Bench avec une config qui le permet ( sans JIT ).

    Tu vas dans  » Shell « .

    Tu tapes  » resetxset « .

    Et cela devrait aller beaucoup mieux avec le JIT.

    Attention : ne tente rien pour l’instant, je refais un dernier test avec sysinfo pour m’en assurer. :-p

     

    J’ai remis je JIT manuellement dans la config. Seul SysInfo aura le dernier mot.

     

    Edit : tout est Ok. Il est bien activé sur la clé.

    Edit 2 : n’oublie pas d’installer WHDLoad sur ta partition AmigaSys avant le lancement de X-Bench ( sinon plantage assuré, j’avais oublié  de le remettre sur mon hdf de report de bug, je suis allé trop vite :wacko: ).

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



    #127793
    razstore
    • Level 4
    • Messages : 123

    Je dois être une buse, je n’arrive toujours pas à exécuter Xbench avec AmigaBootSelector

    Tu as mis quoi dans le fichier 03 dans le S:AmigaBootSelector

    Même avec le JIT désactivé, il ne démarre pas

    Pas de GURU, mais reste sur amigados :wacko:

    Amiga 1200 Blizzard IV 1230 Graveur UltraPlex 40x- 2 CD32- 2 Amiga 500- Nvidia Shield Pro Émulation Amiga UAE4ARM Amikit Amigasys4 HyperSpin

    #127813
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Je dois être une buse, je n’arrive toujours pas à exécuter Xbench avec AmigaBootSelector Tu as mis quoi dans le fichier 03 dans le S:AmigaBootSelector Même avec le JIT désactivé, il ne démarre pas Pas de GURU, mais reste sur amigados :wacko:

     

    En principe, il y a déja cela :

    Setpatch QUIET

    Assign Env: Ram:
    Cd sys:Xbench
    run >nil: assign xb: «  »
    run >nil: xb:xinit.exe

     

    Une fois sous dos, tu peux vérifier le contenu en tapant : cd sys: puis ed s:amigabootselector/03 .

    Ou tout simplement taper dir pour vérifier que tu es bien dans le répertoire X-Bench ( nommé Xbench et non pas X-Bench ).

     

    Note pour la commande Assign : elle peut être modifiée par un Assign Env: Sys:Prefs/Env-Archive ( cas ordinaire, au lieu de la ram ). Mais dans les deux cas, X-Bench devrait booter correctement. :unsure:

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #127865
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Je t’ai envoyé un MP avec mes répertoires présents sur ma clé.

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #127920
    razstore
    • Level 4
    • Messages : 123

    Merci pour tes fichiers c’est sympa :good:

    Tu as fait du bon boulot :good:

    Ça fonctionne nickel sur WinUAE mais j’ai un plantage AmigaSYS4

    blocage de la souris avec FS-UAE

    Peux tu me donner ta config FS-UAE que tu as sur Amilator

    j’en ai tellement essayer que je suis complètement paumé :wacko:

    Amiga 1200 Blizzard IV 1230 Graveur UltraPlex 40x- 2 CD32- 2 Amiga 500- Nvidia Shield Pro Émulation Amiga UAE4ARM Amikit Amigasys4 HyperSpin

    #127926
    razstore
    • Level 4
    • Messages : 123

    Je vois que tu as un Amiga 1200, as tu changé les condensateurs ?

    Sur le mien, ils ne sont pas changés

    Et je ne sais pas trop ou l’envoyer

    Amiga 1200 Blizzard IV 1230 Graveur UltraPlex 40x- 2 CD32- 2 Amiga 500- Nvidia Shield Pro Émulation Amiga UAE4ARM Amikit Amigasys4 HyperSpin

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail
15 réponses de 256 à 270 (sur un total de 270)
  • Vous devez être connecté pour répondre à ce sujet.