[WinUAE] ApolloOS installation

Forum Autour de l’Amiga Amiga OS 4 – MorphOS – UAE – AROS [WinUAE] ApolloOS installation

  • Ce sujet contient 89 réponses, 8 participants et a été mis à jour pour la dernière fois par Zarnal, le il y a 3 mois.
  • Créateur
    Sujet
  • #109993
    Staff
    Aladin
    • Level 25
    • Messages : 11194

    Méthode pour avoir ApolloOS avec WinUAE.

    Présentation Apollo Os
    https://www.amigafrance.com/forums/topic/apolloos-68k/

    Pour une installation sous WinUAE, il sera nécessaire d’adapter quelques fichiers pour gérer les drivers WinUAE au lieu du SAGA de la Vampire ainsi que le support des CPU 68020-68060 au lieu du 68080.

    Télécharger la distribution Aros68k:

    http://www.aros-platform.de/index.html

    Décompresser l’archive aros_2020_Basis_UAE.7z

     

    Extraction des Roms AROS68k:

    Copier les 2 Roms d’ AROS68k-UAE: aros-rom.bin et aros-ext.bin (elles sont situées dans Boot/Amiga). Et les mettre avec vos autres kickstarts de WinUAE.

    Les sélectionner dans l’onglet ROM de WinUAE.

    Il faut obligatoirement utilisé ces Roms Kickstart d’AROS68k-UAE pourAros68k et pour ApolloOS. Il ne faudra jamais utilisé les roms présente dans ApolloOS dans WinUAE.

     

    Télécharger l’archive d’ApolloOS.

    http://www.apollo-core.com/index.htm?page=downloads
    La décompresser, vous obtenez un fichier de 16 Go : ApollOS_R5_2212.ima

     

    Monter ensuite vos disques durs:

    La partition de boot AROS68k que vous avez extraite en premier: (ajouter répertoire ou Archive)

    Ensuite monter votre fichier ApollOS_R5_2212.ima (Ajouter Hardfile)

     

    Extraction des partitions d’ApolloOS:

    Lancer WinUAE:

    Des petits messages d’erreurs apparaissent, cliquer sur Cancel

    Aller chercher FileMaster (extras/Tools/NewFileMaster)

    Créer deux répertoires dans un de vos Disques durs en les nommant ApolloOS et Work par exemple.

    Copier l’intérieur du disque ApolloOs dans votre nouvelle partition ApolloOS. De même pour le disque Work dans votre nouvelle partition Work.

     

    Préparation Apollo OS:

    F12 puis faites redémarrer dans la fenêtre WinUAE

    Enlever vos disques durs.

    Puis installer vos deux nouveaux disques durs: (ApolloOS et Work)

     

    Lancer Apollo OS:

    Faites un tour dans Prefs/screenmode pour choisir votre mode d’écran. Faites sauver avec le mode désiré puis réinitialiser winuae.

     

    Modification de librairie:

    Remplacer cybergraphics.library dans LIBS: par celle incluse avec aros68k

    Ajout du driver UAE d’AHI: (fourni avec WinUAE dans l’archive ahidriver.zip situé dans « Amiga Programs »)
    uae.audio dans Devs\AHI\
    UAE dans Devs\AudioModes\

     

14 réponses de 76 à 89 (sur un total de 89)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #116565
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    non pour la R5 j’ai juste mis comme dans le tuto: « Remplacer cybergraphics.library dans LIBS: par celle incluse avec aros68k »

    Cela doit expliquer la différence si tu n’utilises pas le RTG. Je vais regarder.

    Edit : uaegfx est bien utilisé d’après tes captures ( avec CGX ).

    Je ne comprends plus rien. :scratch: ;-)

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



    #116571
    Staff
    Aladin
    • Level 25
    • Messages : 11194

    Je n’ai rien installé de plus, uaertg doit faire partie de la cybergraphics.library d’aros68k (aros68k qui est pour winuae, c’est peut être pour cela). Pas d’instal de uaertg ni de picasso96.

    #116590
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Si quelqu’un a une idée ( ou mieux, une solution ). :wacko: :wacko: :wacko:

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #116593
    Staff
    Aladin
    • Level 25
    • Messages : 11194

    Je viens d’installer la R6 en suivant mon tuto. Le seul truc qui change, c’est le disque dur « Work » qui s’appelle maintenant « Stuff »

    Tout fonctionne nickel (Tr-Zero, Tiny Galaga, …) en WHDL/WHDLG

    Par contre oui il y a un problème quand l’os tente d’ouvrir un écran pal/ntsc en direct, il ne bascule pas sur pal/ntsc mais reste sur l’écran RTG.
    C’est pour cela que tu pensais que le decrunch ne se finissais pas dans tiny galaga.
    En WHDL, le jeu se lance normalement.
    Faudrait trouver ou est situé ce réglage comme il n’y a pas d’icone dans monitor pour uae-rtg.
    J’avais remarqué avec la R5 que sysinfo ne voulait pas s’ouvrir, je pensais que c’était juste sysinfo qui plantait (étant donné que je lance tous mes jeux PAL/NTSC en WHDL/WHDLG et que cela fonctionnait. Les jeux RTG fonctionnent aussi).

    #116609
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Tout fonctionne nickel (Tr-Zero, Tiny Galaga, …) en WHDL/WHDLG

    Je pars de la version présente dans le répertoire  » Games « . Je ne sais pas si c’est une version WHDLoad. En tout cas, la version CD a le même problème.

    Pour Tiny, j’avais bien essayé avec end+F9 pour basculer sur le chipset mais cela s’était soldé par un écran désespérément gris. Au bout de plusieurs minutes, on peut considérer que quelque chose ne va pas. :-p

    Tu as les roms aros que tu utilises et la config UAE stp ? Histoire d’en finir pour de bon. :-p :lol: Merci.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #116612
    Staff
    Aladin
    • Level 25
    • Messages : 11194

    non je n’utilise pas les jeux fourni avec qui sont en natifs. J’utilise mon répertoire jeux amiga commun à tous mes systèmes amiga, donc en version whdload ou générique.

    Tiny Galaga (WHDL)
    Tiny invaders (WHDL)
    Tiny Bobble (WHDL)
    Tr-Zero Demo (WHDL)
    T Zer0 (1999 Trauma Zero Team/PXL) (WHDLG) (nécessite les kickstart dans devs)

    #116617
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Et tu peux vite fait essayer la version fournie dans  » Games  » pour voir ?

    Merci pour les WHD.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #116621
    Staff
    Aladin
    • Level 25
    • Messages : 11194

    j’ai juste essayé le tiny galaga sans le whdload en faisant afficher tous les fichiers dans la version whdload, et donc lancer le ays directement, et il s’affiche decompressing puis fichage car basculement sur ecran pal (ce que j’ai expliqué plus haut). il ne commute pas l’écran. pour cela que j’ai dit qu’il fallait trouver ce qu’il fallait modifier car normalement c’est dans les tooltypes du moniteur uaertg mais comme la, il n’y en a pas.

    Edit: je viens de tester avec Aros68k-UAE et cela fait pareil, donc cela vient des roms AROS68k. Peut être en trouver d’autres qui fonctionneraient. Donc cela ne vient pas d’ApolloOs.

    #116624
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    End+F9 pour le switch chipset ( comme avec la voodoo :-p   ).

    J’y retourne.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #116632
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Même en switchant, on en revient à la même chose : ecran noir.

    Et c’est bien la rom AROS qui est en cause puisque la version DK de Tiny me fait la même chose.  :unsure:

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



    #116633
    Staff
    Aladin
    • Level 25
    • Messages : 11194

    Faut faire comme sur Hard, après avoir testé Apollos, tu installes CoffinOs :)

    Faut pas oublier non plus qu’Aros68k n’est pas encore totalement abouti.

    #116635
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Faut faire comme sur Hard, après avoir testé Apollos, tu installes CoffinOs :)

    Je l’ai juste installée pour voir comment cela réagissait par rapport à la vidéo de Jb qui a testé la R6.

    Le problème de powerglove qu’il a  n’apparait pas sous WinUae AOSR6 par exemple ( mais là je compare des pommes et des poires ) puisque lui est sous SAGA et moi sous uaegfx pour le rtg. :unsure:

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #125310
    Staff
    Aladin
    • Level 25
    • Messages : 11194

    Tuto toujours valable avec la version Apollo OS 7.1

    A noter qu’il n’y a plus de message d’erreur lors du montage de l’image Disque et de la copie de fichier.

    #125441
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Je vais revoir cette histoire avec les jeux.

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail
14 réponses de 76 à 89 (sur un total de 89)
  • Vous devez être connecté pour répondre à ce sujet.