[WinUAE] ApolloOS installation

Forum Autour de l’Amiga Amiga OS 4 – MorphOS – UAE – AROS [WinUAE] ApolloOS installation

  • Ce sujet contient 89 réponses, 8 participants et a été mis à jour pour la dernière fois par Zarnal, le il y a 3 mois.
  • Créateur
    Sujet
  • #109993
    Staff
    Aladin
    • Level 25
    • Messages : 11193

    Méthode pour avoir ApolloOS avec WinUAE.

    Présentation Apollo Os
    https://www.amigafrance.com/forums/topic/apolloos-68k/

    Pour une installation sous WinUAE, il sera nécessaire d’adapter quelques fichiers pour gérer les drivers WinUAE au lieu du SAGA de la Vampire ainsi que le support des CPU 68020-68060 au lieu du 68080.

    Télécharger la distribution Aros68k:

    http://www.aros-platform.de/index.html

    Décompresser l’archive aros_2020_Basis_UAE.7z

     

    Extraction des Roms AROS68k:

    Copier les 2 Roms d’ AROS68k-UAE: aros-rom.bin et aros-ext.bin (elles sont situées dans Boot/Amiga). Et les mettre avec vos autres kickstarts de WinUAE.

    Les sélectionner dans l’onglet ROM de WinUAE.

    Il faut obligatoirement utilisé ces Roms Kickstart d’AROS68k-UAE pourAros68k et pour ApolloOS. Il ne faudra jamais utilisé les roms présente dans ApolloOS dans WinUAE.

     

    Télécharger l’archive d’ApolloOS.

    http://www.apollo-core.com/index.htm?page=downloads
    La décompresser, vous obtenez un fichier de 16 Go : ApollOS_R5_2212.ima

     

    Monter ensuite vos disques durs:

    La partition de boot AROS68k que vous avez extraite en premier: (ajouter répertoire ou Archive)

    Ensuite monter votre fichier ApollOS_R5_2212.ima (Ajouter Hardfile)

     

    Extraction des partitions d’ApolloOS:

    Lancer WinUAE:

    Des petits messages d’erreurs apparaissent, cliquer sur Cancel

    Aller chercher FileMaster (extras/Tools/NewFileMaster)

    Créer deux répertoires dans un de vos Disques durs en les nommant ApolloOS et Work par exemple.

    Copier l’intérieur du disque ApolloOs dans votre nouvelle partition ApolloOS. De même pour le disque Work dans votre nouvelle partition Work.

     

    Préparation Apollo OS:

    F12 puis faites redémarrer dans la fenêtre WinUAE

    Enlever vos disques durs.

    Puis installer vos deux nouveaux disques durs: (ApolloOS et Work)

     

    Lancer Apollo OS:

    Faites un tour dans Prefs/screenmode pour choisir votre mode d’écran. Faites sauver avec le mode désiré puis réinitialiser winuae.

     

    Modification de librairie:

    Remplacer cybergraphics.library dans LIBS: par celle incluse avec aros68k

    Ajout du driver UAE d’AHI: (fourni avec WinUAE dans l’archive ahidriver.zip situé dans « Amiga Programs »)
    uae.audio dans Devs\AHI\
    UAE dans Devs\AudioModes\

     

15 réponses de 16 à 30 (sur un total de 89)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #109967
    Staff
    Aladin
    • Level 25
    • Messages : 11193

    Tu dois avoir un truc de mal réglé dans ton winuae…

    Tu as bien utilisé les roms AROS récentes (quand j’édite ma aros-rom.bin (celle d’Aros68k mini spéciale UAE pris dans boot/amiga de la partition aros68k), il y a écrit au début dedans: 13.04.2020).

    Quand tu utilises la ROM d’ApolloOS « aros_68020_v2.rom » seule il n’y a que l’ AGA de disponible. et les autres roms d’ApolloOS font planter (aros.rom ou aros-rom.bin et aros-ext.bin). Donc faut bien utiliser celles d’AROS68K (aros-rom.bin et aros-ext.bin)



    #109974
    Salome
    • Level 6
    • Messages : 251

    Les screenmodes dispos…

    1200 PCMCIA 2MB (piqué dans la cave de mes parents et revendu par mon frère #LESGLANDES )
    FS-UAE OS39+Amikit XE Registred sur Mac
    FS-UAE OS4 FE (FlowerPot) sur Mac
    Powerbook G4+MOS
    Taulière de http://amigadistrowatch.com/ et http://mogeek.fr/

    #109978
    Salome
    • Level 6
    • Messages : 251

    J’ai utilisé les roms du dossier de boot d’ApolloOS. C’est en train de m’énerver…

    1200 PCMCIA 2MB (piqué dans la cave de mes parents et revendu par mon frère #LESGLANDES )
    FS-UAE OS39+Amikit XE Registred sur Mac
    FS-UAE OS4 FE (FlowerPot) sur Mac
    Powerbook G4+MOS
    Taulière de http://amigadistrowatch.com/ et http://mogeek.fr/

    #109980
    Staff
    Aladin
    • Level 25
    • Messages : 11193

    je te proposerai mes reglages winuae des que je rentre du taf dans la nuit.

    #109985
    Salome
    • Level 6
    • Messages : 251

    Merci c’est cool. Pourtant je teste sur un PC avec la dernière version de WinUAE. Je vois pas pourquoi ça merde.

    1200 PCMCIA 2MB (piqué dans la cave de mes parents et revendu par mon frère #LESGLANDES )
    FS-UAE OS39+Amikit XE Registred sur Mac
    FS-UAE OS4 FE (FlowerPot) sur Mac
    Powerbook G4+MOS
    Taulière de http://amigadistrowatch.com/ et http://mogeek.fr/

    #110015
    Staff
    Aladin
    • Level 25
    • Messages : 11193

    Voici mon fichier de configuration WinUAE (il est basé sur ma configuration High End Amikit: 68060 JIT / Fast 512 Mo Z3 / RTG 128 Mo Z3)

    Téléchargement: ApolloOS.uae

    A mettre dans ton répertoire WinUAE\Configurations\

    Tu auras juste a modifier l’emplacement de tes Roms AROS68k et l’emplacement de tes partitions ApolloOs et Work

    #110071
    Salome
    • Level 6
    • Messages : 251

    Ok merci! Je check ça! ;-)

    1200 PCMCIA 2MB (piqué dans la cave de mes parents et revendu par mon frère #LESGLANDES )
    FS-UAE OS39+Amikit XE Registred sur Mac
    FS-UAE OS4 FE (FlowerPot) sur Mac
    Powerbook G4+MOS
    Taulière de http://amigadistrowatch.com/ et http://mogeek.fr/

    #110092
    Salome
    • Level 6
    • Messages : 251

    Ça devient de plus en plus curieux. Avec ta config, j’ai enfin le choix des screenmodes HD en bootant le fichier .IMA. Par contre j’ai extrait le contenu du disque ApolloOS dans un répertoire, mais impossible de booter dessus, il s’arrête au CLI Aros :scratch:

    1200 PCMCIA 2MB (piqué dans la cave de mes parents et revendu par mon frère #LESGLANDES )
    FS-UAE OS39+Amikit XE Registred sur Mac
    FS-UAE OS4 FE (FlowerPot) sur Mac
    Powerbook G4+MOS
    Taulière de http://amigadistrowatch.com/ et http://mogeek.fr/

    #110093
    Staff
    Aladin
    • Level 25
    • Messages : 11193

    donc cela marche, cela venait bien de ton mauvais paramétrage de WinUAE

    Pour ton problème de cli, tu dois encore faire une mauvaise manip en sélectionnant ta partition… je viens d’essayer meme en changeant dh0 par rd0 et en changeant le nom apolloOs, il boot quand même, le seul impératif c’est qu’il lui faut absolument la partition « Work ».

    N’essayes pas de modifier l’emplacement des partitions. Supprimes et recrées les entrées. Le Cli d’affiché, c’est qu’il ne boot sur rien du tout.

    #110097
    Salome
    • Level 6
    • Messages : 251

    Pourtant ça me semble correct :unsure:

     

    1200 PCMCIA 2MB (piqué dans la cave de mes parents et revendu par mon frère #LESGLANDES )
    FS-UAE OS39+Amikit XE Registred sur Mac
    FS-UAE OS4 FE (FlowerPot) sur Mac
    Powerbook G4+MOS
    Taulière de http://amigadistrowatch.com/ et http://mogeek.fr/



    #110098
    Staff
    Aladin
    • Level 25
    • Messages : 11193

    Tu les as supprimés et recréés ? (les entrées pas physiquement)

    Sur ton screenshot, c’est normal qu’il y a un répertoire dossier avant ApolloOs? (il n’y en a pas pour ton work)

    #110102
    Salome
    • Level 6
    • Messages : 251

    Ouais j’ai supprimé et recréé.
    Pour le « dossier » c’est parce que j’ai des copies un peu partout ^^

    1200 PCMCIA 2MB (piqué dans la cave de mes parents et revendu par mon frère #LESGLANDES )
    FS-UAE OS39+Amikit XE Registred sur Mac
    FS-UAE OS4 FE (FlowerPot) sur Mac
    Powerbook G4+MOS
    Taulière de http://amigadistrowatch.com/ et http://mogeek.fr/

    #110131
    Chipset
    • Level 5
    • Messages : 168

    bonjour , je me demandais si on devait forcement avoir une vampire pour installer appollo . il y a une configuration minimal ?

    En théorie, on peut compiler Apollo OS spécialement pour les machines non-Vampire et UAE à partir des sources, le cas est prévu. La dernière fois que j’ai essayé, ce n’était pas vraiment stable. On comprend que ce n’est pas vraiment la priorité actuelle d’Apollo Team, même si, en théorie encore une fois, ça devrait être possible un jour.

    @kaeril merci pour ta réponse.

    #110136
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    (Faudrait une réponse de l’expert Winuae @Zarnal)

    Je suis en train de la télécharger pour voir.

    A la louche  : essayer de virer les lecteurs PC s’ils sont activés dans WinUae. Parfois, il y a conflit avec le lecteur c: qui se transforme en DH0 et ton  » vrai  » lecteur DH0 se transforme en DH0_0 avec les conséquences que tu imagines pour le boot. Ne pas modifier ce réglage à la volée.  Et bien garder à l’esprit que ce n’est qu’une hypothèse et pas forcément la solution. Je verrai précisément lorsque mon téléchargement sera terminé. Et vérifier également que deux unités ne portent pas le même nom ( même conséquence ).

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #110145
    Staff
    Aladin
    • Level 25
    • Messages : 11193

    Reste à faire le ménage dans les libs pour qu’il soit opérationnel sur WinUAE, il veut pas ouvrir de jeu SDL. Alors qu’avec AROS68k, cela fonctionne. Faut trouver la librairie à remettre/remplacer …

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail
15 réponses de 16 à 30 (sur un total de 89)
  • Vous devez être connecté pour répondre à ce sujet.