[WinUAE] ApolloOS installation

Forum Autour de l’Amiga Amiga OS 4 – MorphOS – UAE – AROS [WinUAE] ApolloOS installation

  • Ce sujet contient 89 réponses, 8 participants et a été mis à jour pour la dernière fois par Zarnal, le il y a 3 mois.
  • Créateur
    Sujet
  • #109993
    Staff
    Aladin
    • Level 25
    • Messages : 11190

    Méthode pour avoir ApolloOS avec WinUAE.

    Présentation Apollo Os
    https://www.amigafrance.com/forums/topic/apolloos-68k/

    Pour une installation sous WinUAE, il sera nécessaire d’adapter quelques fichiers pour gérer les drivers WinUAE au lieu du SAGA de la Vampire ainsi que le support des CPU 68020-68060 au lieu du 68080.

    Télécharger la distribution Aros68k:

    http://www.aros-platform.de/index.html

    Décompresser l’archive aros_2020_Basis_UAE.7z

     

    Extraction des Roms AROS68k:

    Copier les 2 Roms d’ AROS68k-UAE: aros-rom.bin et aros-ext.bin (elles sont situées dans Boot/Amiga). Et les mettre avec vos autres kickstarts de WinUAE.

    Les sélectionner dans l’onglet ROM de WinUAE.

    Il faut obligatoirement utilisé ces Roms Kickstart d’AROS68k-UAE pourAros68k et pour ApolloOS. Il ne faudra jamais utilisé les roms présente dans ApolloOS dans WinUAE.

     

    Télécharger l’archive d’ApolloOS.

    http://www.apollo-core.com/index.htm?page=downloads
    La décompresser, vous obtenez un fichier de 16 Go : ApollOS_R5_2212.ima

     

    Monter ensuite vos disques durs:

    La partition de boot AROS68k que vous avez extraite en premier: (ajouter répertoire ou Archive)

    Ensuite monter votre fichier ApollOS_R5_2212.ima (Ajouter Hardfile)

     

    Extraction des partitions d’ApolloOS:

    Lancer WinUAE:

    Des petits messages d’erreurs apparaissent, cliquer sur Cancel

    Aller chercher FileMaster (extras/Tools/NewFileMaster)

    Créer deux répertoires dans un de vos Disques durs en les nommant ApolloOS et Work par exemple.

    Copier l’intérieur du disque ApolloOs dans votre nouvelle partition ApolloOS. De même pour le disque Work dans votre nouvelle partition Work.

     

    Préparation Apollo OS:

    F12 puis faites redémarrer dans la fenêtre WinUAE

    Enlever vos disques durs.

    Puis installer vos deux nouveaux disques durs: (ApolloOS et Work)

     

    Lancer Apollo OS:

    Faites un tour dans Prefs/screenmode pour choisir votre mode d’écran. Faites sauver avec le mode désiré puis réinitialiser winuae.

     

    Modification de librairie:

    Remplacer cybergraphics.library dans LIBS: par celle incluse avec aros68k

    Ajout du driver UAE d’AHI: (fourni avec WinUAE dans l’archive ahidriver.zip situé dans « Amiga Programs »)
    uae.audio dans Devs\AHI\
    UAE dans Devs\AudioModes\

     

15 réponses de 61 à 75 (sur un total de 89)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #110321
    Salome
    • Level 6
    • Messages : 251

    Moi j’avais eu des emmerdements de copie, mais c’était quand j’avais booté sur le fichier .IMA (fichiers en cours d’utilisation notamment).
    Faut booter sur le Aros68k, c’est vraiment important, comme ça t’es sûr de pas avoir de problèmes de copie.
    Et surtout ne pas extraire les fichiers depuis WinImage, y’a que FreeMint (on se demande ce qu’il fout là d’ailleurs).

    1200 PCMCIA 2MB (piqué dans la cave de mes parents et revendu par mon frère #LESGLANDES )
    FS-UAE OS39+Amikit XE Registred sur Mac
    FS-UAE OS4 FE (FlowerPot) sur Mac
    Powerbook G4+MOS
    Taulière de http://amigadistrowatch.com/ et http://mogeek.fr/



    #110325
    marcus28s
    • Level 6
    • Messages : 375

    merci Aladin, je vais pouvoir voir ce qu’il a dans le ventre cet o.s.  :good:

    Amiga 1200 rom 3.1.4,Blizzard IV 1230 128mo,CF 16go + 4go ,lecteur CD,Indivision aga MKII,Gotek...tout ça dans un checkmate 1500 plus

    Because Amiga is great, the owner too !

    #115255
    Magic
    • Level 0 - Newbie
    • Messages : 2

    Bonjour,

    Est ce que quelqu’un à réussi à l’installer sur un Amiga ?

    J’ai essayé de copier sur ma carte Compact Flash le fichier image .ima, mais ça ne fonctionne pas !

    #115257
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    J’ai essayé de copier sur ma carte Compact Flash le fichier image .ima, mais ça ne fonctionne pas !

    Ce n’est pas aussi simple. Sous WinUae, tu as les Roms AROS qui sont utilisées pour l’installation initiale. Ce ne sont pas des 3.1+ donc je suppose qu’il va plutôt falloir se baser sur l’ISO d’AROS 68K et adapter en conséquence.

    C’est pour quel type d’Amiga ? Et avec quelles extensions ?

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #115274
    Magic
    • Level 0 - Newbie
    • Messages : 2

    C’est pour un Amiga 2000 avec une carte Vampire 500 V2+. Actuellement il tourne sous CoffinOS r58 qui était très simple à installer, juste copier le fichier image sur une carte 32GB. :-)

    #116498
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Attention : cet OS est à la base conçu pour la Vampire. Ces tests concernent uniquement WinUae.

    Je me suis amusé avec la R6.

    Quelques jeux fournis d’origine refusent de se lancer :

    Tiny Galaga : décompresse à l’infini.

    Tiny Bubble : décompresse à l’infini.

    T-Zero : il ne détecte pas l’AGA.

    Autre souci :

    Il n’est pas possible de switcher dans une résolution AGA quelconque. La réso reste la même.

    Je vais voir avec la version précédente pour ce souci.

    Edit : pareil. L’absence d’un moniteur PAL dans monitors est probablement la cause de ce souci. A voir plus tard.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #116520
    Staff
    Aladin
    • Level 25
    • Messages : 11190

    Ben avec la R5 (j’ai pas encore installé la R6), j’ai pas ces soucis

    Tr-Zero lancé en WHDLG

    Tiny bobble et Tiny galaga fonctionne bien également.

    (je n’ai pas de PAL ou NTSC dans monitors pour le moment dans cet instal)

     

    #116523
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Ben avec la R5 (j’ai pas encore installé la R6), j’ai pas ces soucis Tr-Zero lancé en WHDLG Tiny bobble et Tiny galaga fonctionne bien également.

    Là, il y a un truc. :scratch:   Et avant que tu ne poses la question : oui je suis bien en AGA ( dans WinUae, pas dans l’OS ). :-p

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #116526
    Staff
    Aladin
    • Level 25
    • Messages : 11190

    Tu as bien les bonnes roms kickstart aros du tuto? (pas celles de la R6)

    #116528
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Tu as bien les bonnes roms kickstart aros du tuto? (pas celles de la R6)

    Oui.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



    #116548
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Tu es sous quelle version de WinUae ? Celle de ta version d’Amikit ?

    J’ai vérifié en 4.3,4.4 et dernière béta.

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #116551
    Staff
    Aladin
    • Level 25
    • Messages : 11190

    en winuae, j’utilise la derniere version officielle (quand je parle d’amikit, je parle seulement de la distri wb, jamais de l’emu)

    #116553
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Idem.

    En rtg, c’est bien l’uaegfx que tu utilises ?

    Là, je sèche. :scratch: :scratch: :scratch:

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #116560
    Staff
    Zarnal
    • Level 20
    • Messages : 5497

    Pourtant l’OS detecte bien l’AGA. :scratch: :scratch: :scratch:

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #116561
    Staff
    Aladin
    • Level 25
    • Messages : 11190

    Idem. En rtg, c’est bien l’uaegfx que tu utilises ? Là, je sèche. :scratch: :scratch: :scratch:

    non pour la R5 j’ai juste mis comme dans le tuto: « Remplacer cybergraphics.library dans LIBS: par celle incluse avec aros68k »

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail
15 réponses de 61 à 75 (sur un total de 89)
  • Vous devez être connecté pour répondre à ce sujet.