Problème pour installer WHDLoad?

Forum Amiga Software Problème pour installer WHDLoad?

This topic contains 230 réponses, has 11 participants, and was last updated by Kaeril Kaeril il y a 4 jours et 8 heures.

15 sujets de 211 à 225 (sur un total de 231)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Messages
  • #80584
    Kaeril
    Kaeril
    • Level 2
    • Messages : 41

    D’après la doc d’Amiga Forever (https://www.amigaforever.com/kb/13-145), les roms qu’ils fournissent ne sont plus chiffrées depuis longtemps. D’ailleurs il n’y a pas de fichier rom.key sur mon installation, ce qui me laisse penser que tu utilises une version assez ancienne d’AF, que tes roms sont effectivement peut-être chiffrées, et que ça pourrait être une explication à tes problèmes…

    Je ne veux pas rentrer dans un débat pour/contre Amiga Forever, je soulignais juste que ça peut faire gagner beaucoup de temps et que, selon moi (mais ce n’est que mon opinion), ça peut suffire à justifier de l’acheter.

    Autrement, des gens mieux renseignés que moi sur EAB semblent dire que tu dois glisser rom.key dans Devs:kickstarts/ , au même endroit que les kickstarts, si tu veux vraiment utiliser des roms chiffrées. Dans le doute tu peux toujours le mettre…



    #80631
    Staff
    Aladin
    Aladin
    • Level 23
    • Messages : 8317

    Amiga Forever, je soulignais juste que ça peut faire gagner beaucoup de temps et que, selon moi (mais ce n’est que mon opinion), ça peut suffire à justifier de l’acheter.

    Je suis d’accord c’est un outils très pratique pour un novice

    #80867
    myxamiga
    myxamiga
    • Level 1
    • Messages : 23

    Re et merci pour vos réponses…! et liens !
    Alors j’ai l’AF de ya quelques jours… seulement !

    Le fichier Rom.key est bien dans la liste des kickstarts de mon disque local C du PC.
    Par contre, une fois dans l’Amiga virtuel, c’est là mon problème de Kickstarts (cf les précédentes photos).

    Je n’ai pas (plus) d’Amiga 1200, alors le problème c’est que je ne sais pas comment glisser ***rom.key dans Devs:kickstarts/*** car dans ma liste de ROM fourni par AF, que j’ai glissé dans le dossier ROMS pour WINUAE, quand je lance classic WB, je n’ai pas autant de ROM apparentes, et dans celles présentes qui doivent coller, même renommées, bah ça coince…
    Je suis Novice oui pour cela, j’aimerais juste m’amuser sur un D :wacko: :cry: D virtuel d’amiga… C’est compliqué pour moi, et même stick346.LHA n’y fait rien (fichiers RTB et PAT que j’ai rajouté dans les ROMS mais je ne sais pas trop à quoi ça sert même si on m’a brièvement expliqué).

    #80871
    myxamiga
    myxamiga
    • Level 1
    • Messages : 23

    #80899
    Kaeril
    Kaeril
    • Level 2
    • Messages : 41

    Tu as bien fait concernant stick346.lha, il faut effectivement les fichiers RTB dans Devs:kickstarts, mais bien sûr ce n’est pas suffisant.

    Comme l’explique la doc de WHDLoad, tu as besoin de placer les kickstarts suivants :

    Pour clarifier : tu prends depuis Amiga Forever le fichier nommé amiga-os-120.rom, tu le renommes kick33180.A500 et tu le places dans Devs:kickstarts, et ainsi de suite.

    À l’arrivée, ton dossier Devs:kickstarts doit ressembler à ceci :

    Si tu avais un fichier rom.key avec tes roms d’AF, place-le là aussi.

    Normalement, c’est tout !

    #81044
    myxamiga
    myxamiga
    • Level 1
    • Messages : 23

    Bonjour Kaeril, j’ai vu un peu tard le message, mais merci, et merci la copie écran.
    Les instructions que tu indiques je les ai déjà mises en place, pour la première partie, et tu mets le point sur le problème plus précisément, le soucis se présente donc ici d’après ta 2e copie écran (j’ai déjà renommé les kickstarts, plus bas dans la fenêtre, cependant, effectivement, j’ai un soucis ici : je ne sais pas comment placer les kickstarts là-dedans, je rappelle que je fonctionne sous winuae 4.3 et classic WB full version 2.8.

    Du coup, je pense vraiment si tu as une idée résolutive, c’est la BA du jour ou de l’année lol..

    #81045
    myxamiga
    myxamiga
    • Level 1
    • Messages : 23

    #81046
    Staff
    Aladin
    Aladin
    • Level 23
    • Messages : 8317

    je rappelle que je fonctionne sous winuae 4.3 et classic WB full version 2.8.

    Qu’importe ta machine, ton émulateur, ta version d’amigaos. Cela ne change strictement rien à l’installation de whdload

    #81062
    Kaeril
    Kaeril
    • Level 2
    • Messages : 41

    Tu as donc besoin de transférer des fichiers depuis un de tes dossiers Windows vers ton disque dur Amiga. Sous WinUAE, le plus simple pour cela est de monter un dossier en tant que partition : dans CD & Hard Drives, clique sur Add Directory or Archive, puis Select Directory. Sélectionne le dossier où tu as placé tes kickstarts renommés. Puis donne un nom de device et de volume (je vais choisir Shared en device name et DH2 en volume label, pour l’exemple).

    Normalement tu dois arriver à quelque chose qui ressemble à ça :

    À partir de là, tu peux lancer Directory Opus depuis l’Amiga, ouvrir Shared: d’un côté, Devs:Kickstarts de l’autre, et transférer les fichiers comme tu veux.

    #81080
    myxamiga
    myxamiga
    • Level 1
    • Messages : 23

    Merci Aladin, j’ai noté l’info et je commence à comprendre…

    Pour Kaeril, franchement, merci de t’être porté à mon niveau d’intelligibilité, j’ai enfin réussi, je crois que bon nombres sauront réussir avec ton intervention, du coup j’ai dune 2 et populous, et d’autres qui fonctionnent.. Ishar 2 demande une autre rom ou une histoire de Slave, mais je n’ai mis que la ROM du 500 dans les Devs dans l’immédiat renommé et avec Majuscule…
    Franchement, c’est génial… Reste à élucider les problématiques save EOB1 à EOB2 Beholder, mais je suis hors sujet du coup…
    Autrement, je ne sais pas comment remercier… !  :yahoo: :good: :rose:



    #81081
    myxamiga
    myxamiga
    • Level 1
    • Messages : 23

    Tu es actif sur tout le site ? je peux t’embêter pour un peu tout ? j’ai fait copie écran de tes écrits, je vais informer mon frère qui en sait encore moins que moi et ui faire une jolie surprise… le top !

    (pour EOB1 à EOB2, je t’embête en privé plus tard si tu me permets, ou en public si on peut aider d’autres…. pour l’instant je suis super soulagé, c’est mon échappatoire)

    #81083
    Kaeril
    Kaeril
    • Level 2
    • Messages : 41

    Je t’en prie ! Je me suis plongé dans l’Amiga depuis un mois à peine et j’en possède un depuis seulement une semaine. Tu es la première personne que j’arrive à aider avec le peu de connaissances que j’ai réussi à accumuler jusqu’à maintenant, alors tu ne me dois rien ! Je suis extrêmement ravi d’avoir pu t’aider. :good:

    Pour tes sauvegardes, je ne sais pas exactement quel est ton problème mais un petit rappel : WHDLoad fait de « fausses » sauvegardes durant l’exécution du jeu, et n’écrit réellement la sauvegarde sur ton disque dur qu’au moment où tu appuies sur le bouton pour quitter le jeu (généralement Pr.Screen, chez moi c’est F10, ça dépend parfois des jeux). Si tes sauvegardes ne fonctionnent pas, il peut être utile de vérifier que WHDLoad est bien configuré pour écrire dans un dossier qui existe ! Avec l’éditeur de ton choix, ouvre le fichier S:WHDLoad.prefs . Tu devrais trouver une ligne qui ressemble à ceci :

    ;SavePath=SYS:WHDSaves

    Enlève le ‘;’ au début de la ligne pour la dé-commenter. Puis sauvegarde et ferme le fichier. Dans Directory Opus, rends-toi dans SYS: et vérifie qu’un dossier WHDSaves existe bien. Sinon, crée-le.

    En espérant que ça t’aide !

    #81084
    Staff
    Aladin
    Aladin
    • Level 23
    • Messages : 8317

    Quand un jeu whdload fait une sauvegarde, il faut que les répertoires existent sinon le jeu quitte avec un message d’erreur (whdload ne peut pas créer de répertoires, juste des fichiers nouveaux). Kaeril a raison pour un whdload officiel, le jeu écrit la sauvegarde que tu as fait dans le jeu sur le disque dur lors de la sortie du jeu et le retour sur le wb. (si pas d’endroit spécifié, il écrit dans le répertoire du jeu directement, donc faire gaffe quand on update de version le jeu)

    Pour un whdload générique, j’ai l’impression qu’il est capable d’enregistrer directement sur le disque pendant le jeu (le jeu clignote lors d’un enregistrement)

    #81088
    myxamiga
    myxamiga
    • Level 1
    • Messages : 23

    Je re demain, car je dois m’en aller, mais Kaeril je suis stupéfait, j’ai connu l’amstrad, l’amiga 500 et enfin 1200 via mon frère aîné mais j’avais entre 5 et 15ans…

    Je faisais des choses intéressantes mais rien de spécial au niveau workbench, à mon niveau bien sûr.
    Là à bientôt 40ans, bien que mon frère ai de bonnes connaissances, il est toujours sur son A1200 d’origine en DD avec Carte blizzard 8Mo sans davantage gérer PC Amiga…

    En tous cas dans le cas d’EOB, c’est bien une disquette EOBDATASAV qu’io demande pour transférer la partie EOB1 à EOB2, mais quand j’enregistre dans un floppy disk la fin d’EOB1, forcément EOB2 ne le reconnait pas…
    Je sauvegarde sinon « virtuellement » sur Save State et Load State pour reprendre sans message d’erreur…
    Alors je verrais la problématique demain des indications, et Aladin, merci pour coroller l’ensemble, c’est une sacrée histoire, car Kaeril en 1mois, chapeau bas, et acquérir un A1200, c’est encore plus dur lol.
    Je reste sur PC, pour jouer, ça me suffira…
    A bientôt et merci à ce forum.  :-)

    #81311
    myxamiga
    myxamiga
    • Level 1
    • Messages : 23

    Rebonjour tout le monde, donc oui merci beaucoup j’ai commencé à enfin comprendre une certaine logique d’antan sur un ordi implantable d’antan..
    Reste les sauvegardes entre deux série de jeux, comme eye of the beholder, mais ça ne rentre pas dans le topic… si quelqu’un sait… Kaeril ? lol :-)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail
15 sujets de 211 à 225 (sur un total de 231)

Vous devez être connecté pour répondre à ce sujet.