[Résolu] DevilutionX installation ?

Forum Amiga Gaming [Résolu] DevilutionX installation ?

  • Ce sujet contient 63 réponses, 4 participants et a été mis à jour pour la dernière fois par Sebiohazard, le il y a 1 année et 3 mois.
  • Créateur
    Sujet
  • #155468
    Sebiohazard
      • Level 7
      • Messages : 414

      Bonjour à tous !

      J’ai un soucis avec DevilutionX. J’ai téléchargé l’installateur ici créé un dossier DevilutionX dans ma partition GAMES & décompressé le contenu de l’archive dedans.

      Ensuite j’ai copié le fichier diabdat.mpq dans le répertoire de DevilutionX. J’ouvre un shell j’exécute la commande suivant -> DevilutionX.exe -x comme indiqué dans le readme & là message d’erreur:

      Où est l’erreur ? Merci

    Affichage de 15 réponses de 46 à 60 (sur un total de 63)

    Partager sur vos réseaux sociaux préférés :
    Facebooktwitterredditpinterestlinkedintumblrmail

    • Auteur
      Réponses
    • #155904
      Sebiohazard
        • Level 7
        • Messages : 414

        Pourquoi dans l’archive .lha y a deux fichiers ” DevilutionX ” ?



        #155905
        Staff
        Aladin
          • Level 25
          • Messages : 14680

          dans ton esprit “PC” considère DevilutionX de 32 octet comme DevilutionX.bat. C’est le script de lancement avec son icone (iconex). Perso je l’ai renommé en “Start DevilutionX”

          #155908
          Sebiohazard
            • Level 7
            • Messages : 414

            OK merci c’est plus facile si tu parles PC & MS-DOS loooooooooool

            #155909
            Sebiohazard
              • Level 7
              • Messages : 414

              Bon j’abandonne… j’ai mis un 68060 + FPU (CPU interne car on peut pas mettre autre chose ?) + 256 Mo de Z3 placé le contenu de l’archive Aminet dans le dossier & remplacé l’exécutable par celui du forum & ???

              Devinez quoi ??? Toujours le même message de m… qui me dit que je n’ai pas de FPU :rant: :rant: :rant:

              #155910
              Staff
              Aladin
                • Level 25
                • Messages : 14680

                Juste par curiosité, tu as quoi comme librairie 68060.library dans libs ? (c’est la librairie qui active le FPU avec setpatch)

                Si tu n’en a pas, copie les 3 librairies d’amikit dans ton 3.9:
                – 68040.library
                – 68040new.library
                – 68060.library
                Ainsi que le setpatch.
                C’est le setpatch qui sélectionne 68040 ou 68060 selon ton processeur. Pour 68020 et 68030 il n’y a pas de librairies supplémentaires (sauf si tu installes MMUlibs pour activer le MMU, mais avec beaucoup de Fast Ram c’est inutile).

                Pour aller plus loin (mais qui ne devrait pas changer quelque chose pour lancer le jeu), Amikit ajoute aussi des librairies FPU Math spéciales UAE:
                – mathieeedoubbas.library
                – mathieeedoubtrans.library
                – mathieeesingbas.library
                – mathieeesingtrans.library
                qui sont lancé avec PatchMSB daans la startup-sequence
                Mais je ne les ai pas sur mon 3.9, et le jeu se lance.

                Mais j’en revient à ce que je t’ai dit depuis le premier Post. La surcouche amikit ajoute tout ce que tu as besoin sur un 3.9 initial. Cela évite de devoir y mettre un par un tous les logiciels ou librairies supplémentaires. Je ne me sers que d’amikit au quotidien. J’ai un 3.9 (un peu modifié) a coté, mais je m’en sers juste pour tester des trucs.

                #155914
                Sebiohazard
                  • Level 7
                  • Messages : 414

                  Faut que je regarde…

                  Par contre je suis repassé en 68030 + FPU & là le jeu se lance avec l’écran rouge + un bouton en bas sans police de caractère je clique dessus & voici un nouveau message:

                  Il peut pas ouvrir les .ttf ? Mais ils y sont pourtant ?

                  #155920
                  Sebiohazard
                    • Level 7
                    • Messages : 414

                    Merci pour ton HDD alors comment dire… je dois rire ou pleurer ?! J’ai exactement ce que j’ai chez moi, c’est à dire cet écran:

                    Si je clique dessus message d’erreur… on va arrêter les frais je crois je vais jouer sur Windows ou sur AmiKit :lol:

                    #155921
                    Staff
                    Aladin
                      • Level 25
                      • Messages : 14680

                      OK donc maintenant c’est sûr que tu as mal réglé WinUAE. Je t’ai envoyé un fichier config.

                      Mais tu aurais fait ce que je t’avais demandé: utiliser la base de ta config winuae amikit pour ton winuae 3.9, cela aurait marché aussi :) (juste changer le disque dur amikit par le disque dur du 3.9).

                      #155928
                      Sebiohazard
                        • Level 7
                        • Messages : 414

                        Bravo avec ta config + ton HDD tout fonctionne nickel :good:

                        Par contre j’ai essayé ta config avec mon HDD & ça plante !!! Donc il doit manquer un truc dans le mon WB 3.9 malheureusement… dommage je pourrais pas reproduire l’installation par moi même si je n’ai pas ton HDD ?

                        L’histoire des librairies ? & si j’installe le WB Classic 3.9 avec mon HDD j’aurais tout ce qu’il faut non ?!

                        #155929
                        Staff
                        Aladin
                          • Level 25
                          • Messages : 14680

                          wb classic c’est juste une autre surcouche à 3.9 comme amikit, du coup je vois pas bien l’intérêt vu que tu as déjà amikit. C’est la même chose en moins bien.

                          Amikit a proprement parlé, c’est juste le disque dur amikit. Le reste, winuae etc, c’est du rajout fait pour marcher directement pour celui qui n’a rien du tout. Mais tu peux mettre le disque dur amikit dans ton winuae normal.

                          Dans mon 3.9 j’ai installé stormmesa (opengl) dedans, c’est peut-être cela qui te manque … Bref c’est un 3.9 légèrement modifié permettant de lancer tous les jeux SDL.



                          #155933
                          Sebiohazard
                            • Level 7
                            • Messages : 414

                            Bon… j’aimerais jute savoir pourquoi avec mon HDD ça plante ? La rom du A4000 est obligatoire ? J’ai pas installé les Boing dans mon 3.9 ça peut être ça aussi ?

                            Disons que le WB Classic est plus proche d’un WB original que AmiKit qui ne ressemble plus du tout à un Amiga en fait :lol:

                            #155935
                            Staff
                            Aladin
                              • Level 25
                              • Messages : 14680

                              euh je t’ai pas fourni de rom 4000. Donc ce n’est pas cela déjà. ce n’est pas non plus les boing, bien que la 3.9.2 est fortement recommandé.

                              Amikit ressemble à mon amiga réel de 1999. Il était exactement comme cela. de plus amikit cela se règle (morpheus). tu peux lui donner la tronche que tu veux. C’est juste un 3.9.

                              #155938
                              Sebiohazard
                                • Level 7
                                • Messages : 414

                                euh je t’ai pas fourni de rom 4000. Donc ce n’est pas cela déjà. ce n’est pas non plus les boing, bien que la 3.9.2 est fortement recommandé.

                                Non mais je l’ai cette rom mais même avec elle mon HDD plante.

                                Amikit ressemble à mon amiga réel de 1999. Il était exactement comme cela. de plus amikit cela se règle (morpheus). tu peux lui donner la tronche que tu veux. C’est juste un 3.9.

                                OK intéressant mais j’imagine que pour configurer tout ça faut de supers connaissances que je n’ai pas ? Y a peut-être des tutos sur Morpheus ?

                                #155940
                                Staff
                                Aladin
                                  • Level 25
                                  • Messages : 14680

                                  Je ne sais pas si sur Amikit 10 c’est toujours comme cela, mais avec le 8.5 :

                                  Dedans, tu peux remettre le bureau workbench si tu n’aimes pas celui de dopus5

                                  Et dans Wbstartup+ dans prefs, tu peux désactiver des trucs comme amistart:

                                  #155946
                                  Sebiohazard
                                    • Level 7
                                    • Messages : 414

                                    OK merci je vais voir tout ça :good: ce qui est bien avec l’Amiga c’est qu’il y a toujours un truc à découvrir :wacko:

                                  Partager sur vos réseaux sociaux préférés :
                                  Facebooktwitterredditpinterestlinkedintumblrmail
                                  Affichage de 15 réponses de 46 à 60 (sur un total de 63)
                                  • Vous devez être connecté pour répondre à ce sujet.