[Résolu] T-Zero message d’erreur au lancement ?!

Forum Amiga Gaming [Résolu] T-Zero message d’erreur au lancement ?!

  • Ce sujet contient 57 réponses, 5 participants et a été mis à jour pour la dernière fois par Sebiohazard, le il y a 1 année et 2 mois.
  • Créateur
    Sujet
  • #155417
    Sebiohazard
    • Level 7
    • Messages : 414

    Bonjour à tous !

    Gros soucis avec le jeu T-Zero je vous explique mon problème:

    1. Si je lance le jeu en mode RTG (UAEGFX) en Full-windows le jeu passe en mode fenêtré alors que sous mon WB je suis en fullscreen, mais au moins il démarre.

    2. Si je lance le jeu en mode normal toujours en Full-windows, le jeu démarre bien en fullscreen mais plante tout de suite après avec ce message:

    C’est juste incompréhensible je m’arrache les cheveux :wacko: quelqu’un a eu le même soucis ? Une solution ?

    Merci d’avance :good:

Affichage de 15 réponses de 16 à 30 (sur un total de 57)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #155563
    Sebiohazard
    • Level 7
    • Messages : 414

      En cliquant sur « boot auto » quand tu sélectionnes un répertoire dans winUAE :) Il te suffit juste d’avoir un répertoire « S » et dedans un fichier « startup-sequence » avec dedans le nom du fichier exécutable que tu veux lancer. Selon l’exécutable tu devras y ajouter des librairies si nécessaire dans un répertoire « libs ».

      Alors j’ai essayé ta méthode (je me réjouissais) j’ai donc copié le contenu du jeu T-Zer0 dans un dossier nommé T0 puis créé un dossier S avec la startup-sequence dedans à la racine du HDD & enfin copié tout le dossier Libs également à la racine.

      J’ai édité la startup-sequence en mettant la ligne suivante: T0/T-zer0 j’ai rendu le HDD bootable & démarré WinUAE, j’ai entendu la musique du jeu démarrer puis plus rien ? Une fenêtre s’est ouverte avec ce message:

      Qu’est-ce que j’ai oublié ?!



      #155565
      Staff
      Aladin
      • Level 25
      • Messages : 14604

        Quel message? je ne vois rien …

        Le 1> sur amiga c’est comme c:/> sur Ms-Dos. Il n’y a pas de message :lol:

        j’ai donc copié le contenu du jeu T-Zer0 dans un dossier nommé T0 puis créé un dossier S avec la startup-sequence dedans à la racine du HDD & enfin copié tout le dossier Libs également à la racine. J’ai édité la startup-sequence en mettant la ligne suivante: T0/T-zer0 j’ai rendu le HDD bootable & démarré WinUAE Qu’est-ce que j’ai oublié ?!

        Je n’ai jamais dit de créer un répertoire T0. Je t’ai dit d’y copier à la racine de ton nouveau disque dur.

        #155612
        Sebiohazard
        • Level 7
        • Messages : 414

          Oui j’ai bien monté l’ISO du jeu dans WinUAE ?

          Comment on initialise le lecteur CD ?

          #155614
          Staff
          Aladin
          • Level 25
          • Messages : 14604

            Comme sur PC quand tu en ajoutes un à ton MsDos … Tu l’installes avec l’utilitaire fourni avec (CacheCDFS, AsimCDFS, etc…) (De mémoire sur Ms-Dos tu installes MSCDEX)

            Pour l’initialisation, c’est surtout quand on part d’un 3.0/3.1.

            Normalement avec un 3.9, il y est déjà. Tu dois avoir un fichier CD0 dans devs/dosdrivers. Il utilise CacheCDFS installé dans « L ».

            Quand tu regardes dans le fichier CD0 dans devs/dosdrivers il y a:

            /*CD MOUNT*/
            FileSystem = L:CacheCDFS /* The name of the game */
            Device = « uaescsi.device » /* Name of exec device driver */
            Unit = 0 /* exec device unit */
            Etc …

            #155628
            Sebiohazard
            • Level 7
            • Messages : 414

              Merci pour ton aide mais y a un truc que je ne comprends pas ?

              Tu m’as dit qu’on pouvait rendre bootable un HDD avec un jeu dedans très facilement non ? Hors là je vois qu’il y a 40 manipulations à faire :lol:

              J’avoue ne pas avoir tout compris désolé… du coup j’ai réussi à démarrer T-Zer0 automatiquement avec AmigaOS 3.9 en éditant la user-startup avec cette ligne:

              dh1:t0/t-zer0

              J’ai les musique dans le jeu & il tourne nickel. Pour ça j’ai juste du aller dans le setup du jeu & changer cd.device en uaescsi.device.

              Comme sur PC quand tu en ajoutes un à ton MsDos … Tu l’installes avec l’utilitaire fourni avec (CacheCDFS, AsimCDFS, etc…) (De mémoire sur Ms-Dos tu installes MSCDEX)

              Oui tout à fait dans l’autoexec.bat tu dois ajouter la ligne:

              C:\DOS\MSCDEX.EXE /D:MSCD001

              & dans config.sys la ligne:

              DEVICE=C:\DOS\SSCDROM.SYS /D:MSCD001

              Mais là sur l’Amiga je suis perdu…

              #155632
              Staff
              Zarnal
              • Level 22
              • Messages : 7451

                Mais là sur l’Amiga je suis perdu…

                Sur Amiga, il faut utiliser IDEFix97/AmiCDFS pour la gestion des lecteurs CD ( comme sur une vraie machine ). l’uaescsi, c’est la facilité.  :lol:   :-p

                A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                #155646
                Staff
                Aladin
                • Level 25
                • Messages : 14604

                  Je ne vois pas ce que tu ne comprends pas.

                  D’ailleurs dans l’iso de Tzer0 il y a une archive « Atapi_PnP300.Lha » qui sert à installer un lecteur CD ATAPI IDE à ton wb 3.0/3.1 sur un a12000/a4000

                  #155651
                  Staff
                  Aladin
                  • Level 25
                  • Messages : 14604

                    Mais y a un truc que je ne comprends pas ? Tu m’as dit qu’on pouvait rendre bootable un HDD avec un jeu dedans très facilement non ? Hors là je vois qu’il y a 40 manipulations à faire

                    Oui et j’ai dit aussi :

                    Fallait commencer par la, il te faut les musiques. Donc il te faut un lecteur CD sur ton wb. Du coup c’est beaucoup plus chiant à faire un truc mini. Je n’en ai pas le courage personnellement.

                    Mais cela ne doit pas être bien compliqué à faire. c’est juste chiant…

                    #155684
                    Staff
                    Aladin
                    • Level 25
                    • Messages : 14604

                      Mais cela ne doit pas être bien compliqué à faire. c’est juste chiant…

                      En fait il n’y en a même pas besoin avec WinUAE…

                      Sur WinUAE c’est beaucoup plus simple que sur un vrai amiga. Je viens de tester avec mon package WHDLG en bootant directement dans le répertoire DATA avec WinUAE, il faut juste enlever l’assign T0: de la startup-séquence et insérer l’iso de Tzero. (Et il faut que tu coches dans WinUAE: Activation auto CDFS pour lecteur CD/DVD)

                      PS: La sélection du lecteur CD du jeu se fait normalement en lançant l’outils « T0SetUp » qui écrit le fichier de configuration « T0Prefs/T0.Prefs » et comme dans mon package j’ai réglé device=uaescsi.device et unit=0. Il n’y a pas besoin d’y régler.

                       

                      Si tu veux faire l’installation du jeu toi-même: (avec musique)

                      1. Copier tous les fichiers du jeu depuis le CD de Tzer0 dans un répertoire vide ou un HDF

                      2. Copier un setpatch d’amigaOS3 minimum (AGA) que tu mets dans un répertoire « C » ou à la racine.

                      3. Créer un répertoire « S » et dedans un fichier texte « Startup-sequence » et écrire dedans:

                      Setpatch QUIET
                      t-zer0

                      4. éditer le fichier « T0.Prefs » qui est dans le répertoire « T0Prefs » comme ceci:

                      CD_Device = « uaescsi.device »
                      CD_Unit = « 0 »

                      5. Préparer WinUAE: réglage CPU/RAM/Chipset etc donc un 68030, 8 Mo de Fast, AGA par exemple. Mettre le HDF ou le répertoire que tu as créé comme disque dur. Mettre l’iso de Tzero dans le lecteur virtuel CD de WinUAE. Cocher la case d’automount CDFS.

                      6. C’est fini, tu peux y lancer

                       

                      #155685
                      Kimy
                      • Level 15
                      • Messages : 2793

                        Tout ça m’a donné l’envie d’y jouer ! J’ai pris l’archive de ton lien…

                        Merci. :yes:



                        #155686
                        Staff
                        Zarnal
                        • Level 22
                        • Messages : 7451

                          Mais cela ne doit pas être bien compliqué à faire. c’est juste chiant…

                          Après, il faut savoir ce que l’on veut :unsure: :

                          soit mettre les mains dans le cambouis en apprenant au passage et en essayant de comprendre comment cela fonctionne.

                          soit utiliser des trucs déjà faits sans avoir à réfléchir et là les trucs  » déjà tout prêts et configurés  » sont la solution.

                          C’est au choix. Ce sont deux visions bien différentes des choses.  :-p

                          A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                          #155696
                          Staff
                          Aladin
                          • Level 25
                          • Messages : 14604

                            Chiant dans le sens que sur un vrai amiga on lancera le WB. Si c’est juste pour y lancer depuis un frontend PC, cela ne m’intéresse pas d’y perdre du temps. J’y laisse aux PCistes et sur leurs forums de PCistes.

                            #155699
                            Staff
                            Zarnal
                            • Level 22
                            • Messages : 7451

                              Pas faux. :-p

                              A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                              #155706
                              Kimy
                              • Level 15
                              • Messages : 2793

                                Chiant dans le sens que sur un vrai Amiga on lancera le WB. Si c’est juste pour y lancer depuis un Front-end PC, cela ne m’intéresse pas d’y perdre du temps. J’y laisse aux PCistes et sur leurs forums de PCistes.

                                Et pour ceux qui font ça sur les deux, ils tombent où ? :lol:

                                #155736
                                Sebiohazard
                                • Level 7
                                • Messages : 414

                                  Mais cela ne doit pas être bien compliqué à faire. c’est juste chiant…

                                  Après, il faut savoir ce que l’on veut :unsure: : soit mettre les mains dans le cambouis en apprenant au passage et en essayant de comprendre comment cela fonctionne. soit utiliser des trucs déjà faits sans avoir à réfléchir et là les trucs » déjà tout prêts et configurés » sont la solution. C’est au choix. Ce sont deux visions bien différentes des choses. :-p

                                  Apprendre oui mais faut pas sauter les étapes :lol: quand on débute comme moi dans le monde de l’Amiga faut y aller progressivement. Déjà je suis content d’avoir installé AmigaOS 3.9 + les drivers Picasso + T-Zer0 + éditer la user-startup & que mon jeu se lancer automatiquement en double cliquant simplement sur mon fichier .uae :yes:

                                  Chiant dans le sens que sur un vrai amiga on lancera le WB. Si c’est juste pour y lancer depuis un frontend PC, cela ne m’intéresse pas d’y perdre du temps. J’y laisse aux PCistes et sur leurs forums de PCistes.

                                  Je fais ça pour un ami qui ne connaît pas grand chose en informatique… j’aimerais lui faire découvrir l’Amiga, depuis un front end ce sera idéal pour lui, & pour moi c’est un défi que tout fonctionne en un clique :good:

                                  Mais cela ne doit pas être bien compliqué à faire. c’est juste chiant…

                                  En fait il n’y en a même pas besoin avec WinUAE… Sur WinUAE c’est beaucoup plus simple que sur un vrai amiga. Je viens de tester avec mon package WHDLG en bootant directement dans le répertoire DATA avec WinUAE, il faut juste enlever l’assign T0: de la startup-séquence et insérer l’iso de Tzero. (Et il faut que tu coches dans WinUAE: Activation auto CDFS pour lecteur CD/DVD) PS: La sélection du lecteur CD du jeu se fait normalement en lançant l’outils « T0SetUp » qui écrit le fichier de configuration « T0Prefs/T0.Prefs » et comme dans mon package j’ai réglé device=uaescsi.device et unit=0. Il n’y a pas besoin d’y régler. Si tu veux faire l’installation du jeu toi-même: (avec musique) 1. Copier tous les fichiers du jeu depuis le CD de Tzer0 dans un répertoire vide ou un HDF 2. Copier un setpatch d’amigaOS3 minimum (AGA) que tu mets dans un répertoire « C » ou à la racine. 3. Créer un répertoire « S » et dedans un fichier texte « Startup-sequence » et écrire dedans: Setpatch QUIET t-zer0 4. éditer le fichier « T0.Prefs » qui est dans le répertoire « T0Prefs » comme ceci: CD_Device = « uaescsi.device » CD_Unit = « 0 » 5. Préparer WinUAE: réglage CPU/RAM/Chipset etc donc un 68030, 8 Mo de Fast, AGA par exemple. Mettre le HDF ou le répertoire que tu as créé comme disque dur. Mettre l’iso de Tzero dans le lecteur virtuel CD de WinUAE. Cocher la case d’automount CDFS. 6. C’est fini, tu peux y lancer

                                  OK merci je vais essayer cette procédure & vous tiens au courant ;-) le SetPatch c’est un fichier j’imagine ?

                                Partager sur vos réseaux sociaux préférés :
                                Facebooktwitterredditpinterestlinkedintumblrmail
                                Affichage de 15 réponses de 16 à 30 (sur un total de 57)
                                • Vous devez être connecté pour répondre à ce sujet.