[Résolu] T-Zero message d’erreur au lancement ?!

Forum Amiga Gaming [Résolu] T-Zero message d’erreur au lancement ?!

  • Ce sujet contient 57 réponses, 5 participants et a été mis à jour pour la dernière fois par Sebiohazard, le il y a 1 semaine.
  • Créateur
    Sujet
  • #155417
    Sebiohazard
    • Level 5
    • Messages : 220

    Bonjour à tous !

    Gros soucis avec le jeu T-Zero je vous explique mon problème:

    1. Si je lance le jeu en mode RTG (UAEGFX) en Full-windows le jeu passe en mode fenêtré alors que sous mon WB je suis en fullscreen, mais au moins il démarre.

    2. Si je lance le jeu en mode normal toujours en Full-windows, le jeu démarre bien en fullscreen mais plante tout de suite après avec ce message:

    C’est juste incompréhensible je m’arrache les cheveux :wacko: quelqu’un a eu le même soucis ? Une solution ?

    Merci d’avance :good:

Affichage de 15 réponses de 1 à 15 (sur un total de 57)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #155418
    Staff
    Aladin
    • Level 25
    • Messages : 12707

      En mode RTG ? Le jeu est AGA.

      Peut-être un manque de Chip, il t’indique 1.7 Mo au lieu de 2 Mo.

      En lançant en WHDLG (donc sans musique)



      #155421
      Sebiohazard
      • Level 5
      • Messages : 220

        Hello j’ai mis 8 Mo de Chip RAM & ça fonctionne merci :yahoo:

        1. Par contre pourquoi en mode RTG WinUAE passe en mode fenêtré au lancement du jeu ?!

        2. J’aimerais lancé T-Zero directement au démarrage de WinUAE c’est possible ? J’ai lu qu’il fallait éditer la startup-sequence ? Comment on fait ?

        Merci

        #155455
        Sebiohazard
        • Level 5
        • Messages : 220

          Alors j’ai réussi à lancer mon jeu automatiquement au démarrage du WB avec cette commande dans la startup-sequence sur la dernière ligne:

          dh1:games/t0/t-zer0

          Le problème est qu’en quittant le jeu mon WB n’est plus en couleurs ?! :scratch:

          Comment y remédier ? Merci

          #155457
          Staff
          Zarnal
          • Level 21
          • Messages : 6824

            Comment y remédier ? Merci

            En créant un HD dédié par exemple.

             

            A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

            #155461
            Sebiohazard
            • Level 5
            • Messages : 220

              C’est à dire ? J’ai créé une partition dédiée (DH1) ?

              Le problème est que maintenant quand j’édite la startup-sequence je ne trouve plus la ligne de commande que j’ai ajouté ??? Elle a disparue… par contre mon jeu se lance toujours automatiquement ?!

              Comment revenir à l’origine ?!

              #155463
              Staff
              Zarnal
              • Level 21
              • Messages : 6824

                C’est à dire ? J’ai créé une partition dédiée (DH1) ?

                Il y a un DH0 ? Ce sont des HDF ou bien des répertoires ?

                Tu peux la startup dans DH1 et tu bootes directement depuis DH1 ( en changeant la priorité depuis l’interface WinUae ou bien directement depuis l’Amiga ).

                A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                #155464
                Sebiohazard
                • Level 5
                • Messages : 220

                  J’ai deux partition sur un seul HDD. Une pour le WB & l’autre pour les jeux. Le HDD est au format .hdf.

                  Tu m’as pas répondu, comment je fais pour rétablir la startup-sequence d’origine ? Pourquoi je ne trouve plus la ligne que j’ai ajouté ?

                  On m’a parlé de user-startup ? C’est mieux ? Comment on fait je suis perdu ?

                  #155465
                  Staff
                  Aladin
                  • Level 25
                  • Messages : 12707

                    la user-startup est une dépendance de la startup-sequence et est utilisé seulement si tu as dans la startup-sequence:

                    IF EXISTS S:User-Startup
                    Execute S:User-Startup
                    EndIF

                    Pour TZer0 le plus dur est d’initialiser le CD-Rom pour lire les musiques en format CD (CDDA).

                    Si tu y joues sans musique, tu as juste a utiliser mon WHDL Générique. Et si tu veux booter directement sur le jeu, tu boot avec WinUAE directement dans le répertoire DATA. (Dans les paramètres de WinUAE tu vas sur l’onglet « CD et Disque Dur », tu cliques sur « Ajouter répertoire ou archive » et tu pointes l’intérieur du répertoires « DATA »).

                    Trauma Zero AGA (1999 PXL)

                    #155467
                    Staff
                    Zarnal
                    • Level 21
                    • Messages : 6824

                      Tu m’as pas répondu, comment je fais pour rétablir la startup-sequence d’origine ? Pourquoi je ne trouve plus la ligne que j’ai ajouté ?

                      Aucune idée.

                      Va voir dans le répertoire WBStartup au cas où le jeu se soit niché dedans.

                      On m’a parlé de user-startup ? C’est mieux ? Comment on fait je suis perdu ?

                      Si tu veux juste booter directement le jeu, je ne comprends pas pourquoi tu installes un WB complet. Il suffirait de rendre autonome ton DH1 en lui ajoutant une startup.

                      Globalement, tu veux faire quoi au juste ?

                      Booter uniquement sur le jeu sans te soucier du WB ?

                      Tu veux pouvoir utiliser le WB et lancer le jeu directement  ? Le plus intéressant dans ce second cas c’est Amiga Boot Selector qui permet de gérer différentes Startups.

                      A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                      #155474
                      Sebiohazard
                      • Level 5
                      • Messages : 220

                        Alors ce que je veux c’est intégrer l’Amiga dans un front end, en l’occurence Attract Mode tu connais ?

                        Le but est de cliquer dans le front end une seule fois & que le jeu se lance direct :good:

                        Donc oui si je peux me passer d’un WB je prends (je ne savais pas que c’était possible) mais comment rendre une partition sans WB bootable ?



                        #155487
                        Staff
                        Aladin
                        • Level 25
                        • Messages : 12707

                          En cliquant sur « boot auto » quand tu sélectionnes un répertoire dans winUAE :)

                          Il te suffit juste d’avoir un répertoire « S » et dedans un fichier « startup-sequence » avec dedans le nom du fichier exécutable  que tu veux lancer. Selon l’exécutable tu devras y ajouter des librairies si nécessaire dans un répertoire « libs ».

                          #155494
                          Sebiohazard
                          • Level 5
                          • Messages : 220

                            D’accord tout simplement ? C’est incroyable !

                            Le plus simple est que je copie mon répertoire libs actuel alors ?

                            & pour l’histoire des couleurs qui disparaissent lorsque je quitte le jeu & que je reviens dans le WB tu as une idée ? Comment relancer le WB ? Ou comment enlever ma ligne de commande qui a disparu dans startup-sequence ?

                            #155506
                            Staff
                            Aladin
                            • Level 25
                            • Messages : 12707

                              Pourquoi mettre des libs inutiles ?

                              Non, moi cela ne le fait pas, mais je le lance en WHDLG :) (sans la musique)

                              #155508
                              Sebiohazard
                              • Level 5
                              • Messages : 220

                                WHDLG c’est quoi ? Sans les musiques y a pas d’intérêt c’est tout ce qui fait la beauté de ce jeu :unsure:

                                Comment je peux savoir quelles sont les libs nécessaires ?

                                #155510
                                Staff
                                Aladin
                                • Level 25
                                • Messages : 12707

                                  Fallait commencer par la, il te faut les musiques. Donc il te faut un lecteur CD sur ton wb. Du coup c’est beaucoup plus chiant à faire un truc mini. Je n’en ai pas le courage personnellement.

                                  Quand je veux la musique, (je mets l’iso de Tzer0 dans CD0:) et je lance le jeu en natif.

                                  Le réglage de la sélection du lecteur CD se fait en cliquant sur l’outils « T0SetUp » avant de lancer le jeu la première fois.

                                   

                                  Mais pourquoi tu n’utilises pas un truc prêt à l’emploi comme : Tzer0 HDF+CD

                                  D’ailleurs DamienD tient à jour un « frontend » et les jeux préinstallés pour winuae permettant de lancer tous les jeux depuis winuae sans passer par AmigaOs. Perso cela ne m’intéresse pas car ce n’est plus de l’amiga mais du PC (ce qui aurait plus sa place sur un forum PC que sur un forum amiga).

                                  http://eab.abime.net/showthread.php?t=90314

                                Partager sur vos réseaux sociaux préférés :
                                Facebooktwitterredditpinterestlinkedintumblrmail
                                Affichage de 15 réponses de 1 à 15 (sur un total de 57)
                                • Vous devez être connecté pour répondre à ce sujet.