Recherche de glitchs des démos A500/A1200 sous WinUae ou Mister FPGA.

Forum Amiga Divers Recherche de glitchs des démos A500/A1200 sous WinUae ou Mister FPGA.

  • Créateur
    Sujet
  • #125944
    Staff
    Zarnal
    • Level 21
    • Messages : 6505

    Voici donc la nouvelle mouture du fil consacré à la recherche de glitchs et de bugs concernant les démos OCS/AGA au travers des émulateurs et du FPGA Mister.

    A moins qu’un volontaire ne se présente pour la Vampire, cette dernière ne fera pas partie de ces tests. Notez bien que pour tester il faut être fiable et motivé ( en plus d’être patient ).

    Contrairement à l’ancien fil, je vais faire en sorte que cela ne soit pas imbuvable. C’est pour cette raison que désormais, la liste des démos compatibles sera uniquement disponible sous la forme d’un fichier disponible prochainement ( puisqu’il faut tout retester ). Ici, nous ne traiterons que des cas problématiques. N’importe qui peut faire un rapport occasionnel ( et je vous encourage à le faire ) ici même bien sûr et ce ,quel que soit le support.

    Notez que certaines vidéos sont reprises d’anciens tests avec WinUae 4.1 ou du Mister, les problèmes étant strictement identiques avec les dernières versions, je ne vais pas refaire inutilement les vidéos.  :-p  

     

    Les testeurs réguliers actuels ( quand ils ont du temps :-p   ) :

     

    • JeanFred64
    • Kathleen
    • Mutt2828
    • Zarnal

     

    Comment cela se passera t’il ?

     

    Eh bien c’est très simple, une démo quelconque sera testée sous WinUae et/ou sur le Mister et si un souci quelconque est découvert, il sera vérifié sur une vraie machine  avec des caractéristiques identique à celles du protocole WinUae. Le problème sera alors confirmé ou infirmé. Chaque démo problématique sera documentée via une capture d’écran ou une vidéo. Je ne prends en considération que les versions officielles pour les tests ( pour ne pas les biaiser ). Les versions fixées sont juste un bonus.

    S’il est confirmé sur le vrai hard la démo est considérée comme OK.

    S’il est infirmé sur une machine réelle mais qu’il y a un moyen de la faire fonctionner en dehors du protocole WinUae la solution sera donnée par une lettre se référant à la légende ci dessous :

    Attention Attention Attention : pour l’ensemble des tests, les versions WHDLoad des démos A500 ou A1200 ne devront en aucun cas être utilisées. Cela n’aurait aucun sens.

     

    Légende :

     

    • A : Soluble en mode Fastest ( WinUae ).
    • B : Soluble avec cache activé/désactivé ( Mister ).
    • C : Insoluble à ce jour ( WinUae et/ou Mister ).
    • D : Une version fixée existe ( WinUae et/ou Mister ). Le lien sera donné.
    • E : Gérable avec WHDLoad générique et modif à la volée ( WinUae ).

     

    Dans la mesure du possible, une vidéo sera proposée afin d’illustrer le souci rencontré.

     

    Protocole sous WinUae 4.9 :

     

    AGA : WinUae 4.9 Quickstart A1200+4MB Fast avec ajout d’un disque dur. Commande NoFastMem au besoin.

    OCS  : WinUae 4.9 Quickstart A500 512+512. Commande Nofastmem au besoin.

     

    Protocole Mister :

     

    Dernier core en date, A1200 020 cache désactivé. A500 OCS 512+512 avec nofast autorisée.

     

    Soucis non lies à l’émulation :

     

    • Zones hors écran : le plus gros  » souci  » avec les LCD. Sur un CRT la zone d’affichage est inférieure. Sur le LCD, vous vous prenez tout sur la figure. Sans même parler du scale.

     

    • 60Hz : si une bascule est effectué par la démo en 60Hz au lieu de vous retrouver avec une image agrandie, il y aura un écrasement de la zone ( un peu comme si vous passiez d’un 60Hz à un 50Hz sur une console ). C’est tout à fait normal. Note : si vous sortez WinUae sur un CRT, tout rentre dans l’ordre.

     

    • Fichiers/ADF corrompus : un classique ADF ou bien fichier contenu dans l’ADF corrompu avant ou après la conversion.

     

    • Une démo en version non finale : cela peut arriver de temps en temps.

     

    • Les soucis d’entrelacement : le fond du jeu  » Agony  » en est le plus bel exemple. Mais cela peut arriver avec quelques démos. Idem qu’avec le 60Hz, si vous sortez WinUae sur CRT, tout redevient normal. Sur votre LCD, vous pouvez palier au souci en sélectionnant  » Double Field  » ( dans ce cas l’entrelacement est simulé mais vous vous retrouvez avec les défauts inhérents à ce mode ). Vidéo avec et sans.

     

    • Soucis liés à un mauvais ratio d’affichage : soyez vigilant au respect de ce dernier, cela peut mener à des choses innatendues. Exemple sans et avec.

     

    • Soucis liés à la version du Kickstart : certaines démos peuvent exiger une version spécifique de la ( ou des ) roms pour s’exécuter correctement ( Kickstart 1.2 ou 1.3 sur A500  ou bien Kickstart 3.0 ou 3.1+ sur A1200 ). C’est peu fréquent sur A500, un tout petit peu peu plus sur 1200 mais il n’y en a pas une tonne non plus.

     

    Les démos problématiques :

     

    WinUae A500 OCS.

    Mister A1200 AGA.

    Mister A500 OCS.

    WinUae A1200 AGA.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

Affichage de 5 réponses de 76 à 80 (sur un total de 80)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #149915
    Staff
    Zarnal
    • Level 21
    • Messages : 6505

    Ben alors, c’est quoi ? :lol:

    Ce qui est censé se passer avec une RAM NEC PD42S4260 dans une vraie machine.

    Le 1200 de @Kathleen doit avoir une autre ref dedans. :-p

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



    #152277
    Staff
    Zarnal
    • Level 21
    • Messages : 6505

    Améliorations avec la dernière beta.

    Ramses-Benoit : 100% fonctionnelle en Fastest ( plus de barres noires ) sans fast. Pas encore testée avec de la Fast.

    Freezers-Symptom : 100% fonctionnelle sans Fast au cycle.

    Régression : 

    Silents-SoulKitchen : Logo TSL brouillé ( DK et WhdLoad ) au cycle. 100% fonctionnelle en mode fastest. Tunnel problématique ( ce n’est pas nouveau ).

    Globalement, on marche sur des braises avec les derniers changements. On risque d’avoir des surprises avec tout ce qui fonctionnait par  » accident « . C’est pourtant assez stable dans l’ensemble.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #152282
    Kimy
    • Level 10
    • Messages : 1183

    C’est toujours le gros problème lors de changement en informatique, et surtout à notre époque. :-p

    C’est vrai ! L’Amiga est d’une autre époque !! :heart:

    #152293
    Staff
    Zarnal
    • Level 21
    • Messages : 6505

    Bon, qui se charge de décapsuler/analyser/retranscrire un 020 pour que l’on en finisse avec ces conneries ? :whistle: :lol:

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #152296
    Kimy
    • Level 10
    • Messages : 1183

    Moi ! Moi !! Moi !!! :yahoo:

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail
Affichage de 5 réponses de 76 à 80 (sur un total de 80)
  • Vous devez être connecté pour répondre à ce sujet.