Souci avec la pile Genesis sous WinUae.

Forum Autour de l’Amiga Amiga OS 4 – MorphOS – UAE – AROS Souci avec la pile Genesis sous WinUae.

  • Ce sujet contient 34 réponses, 4 participants et a été mis à jour pour la dernière fois par Zarnal, le il y a 9 mois et 1 semaine.
  • Créateur
    Sujet
  • #141518
    Staff
    Zarnal
    • Level 21
    • Messages : 6820

    Modération : j’ai crée un sujet spécifique.

    Ce matin, j’ai trouvé et essayé ceci en cherchant de la doc sur Genesis ( j’ai mis de coté le transfert de fichiers pour l’instant, je n’y arrive pas avec une seule machine, il faudra voir avec 2 machines ) :

     

    J’ai adapté le device ( ariadne ii ).

    J’ai ensuite tenté de lancer Wookichat qui se bloque lors de la sélection du chat AI. J’ai repris le contrôle en déconnectant via Genesis. Je vais regarder les valeurs de ma box avec un petit coup d’ipconfig et adapter. Edit : les valeurs sont pourtant les mêmes. :scratch:

    A espérer qu’il ne faille pas jouer avec des variables d’environnement. Parce que là, sans doc… :wacko:

    Note :  avec la pile WinUae cela a toujours été directement Ok par contre. :unsure:

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

Affichage de 15 réponses de 1 à 15 (sur un total de 34)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #141594
    Staff
    Zarnal
    • Level 21
    • Messages : 6820

      @stephbb75

      Bon, là je ne comprends pas.  :wacko: :wacko: :wacko:

       

      Suite à ta question initiale, j’ai fait des tests avec l’ariadne II.

      Impossible de se connecter à ma box contrairement à la pile de WinUae. Les adresses sont Ok, la Network s’allume mais c’est comme si cela partait dans le vide alors qu’avec la pile WinUae tout se passe bien ( c’est certainement conçu pour tu me diras :unsure:   ). Et cela explique peut être l’intérêt de cette pile WinUae spécifique.

      Mais à partir du moment où l’émulation de l’ariadne II revoie vers le LAN physique de mon PC, je ne vois pas où cela coince.  :scratch:

      Si quelqu’un a une idée, je suis preneur. :-p

       

      A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



      #141602
      Staff
      Zarnal
      • Level 21
      • Messages : 6820

        Ok, je viens d’apprendre par une lecture que Genesis ne gère pas le DHCP… :wacko: :wacko: :wacko: :lol:

        Mais il semble y avoir un contournement possible.

        Je poursuis mes investigations demain. :-p

        Mais là on rentre plus dans l’usage du réseau sur Amiga que de l’usage de WinUae. Je m’auto-modère et, au passage, j’essaye d’apprendre. B-) :lol:

        A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

        #141605
        stephbb75
        • Level 7
        • Messages : 509

          @Zarnal

          Ok, je viens d’apprendre par une lecture que Genesis ne gère pas le DHCP…

          Oui il faut utiliser dhcp_amitcp.lha (sur Aminet) pour avoir le DHCP (mais faut installer ixemul).

          https://youtube.com/@stephbb75

          #141609
          Staff
          Zarnal
          • Level 21
          • Messages : 6820

            @Zarnal

            Ok, je viens d’apprendre par une lecture que Genesis ne gère pas le DHCP…

            Oui il faut utiliser dhcp_amitcp.lha (sur Aminet) pour avoir le DHCP (mais faut installer ixemul).

            @stephbb75

            Je récupère le CD de Geek  Gadgets et je poursuis mes tests. Je n’ai pas la commande sh dans mon répertoire bin.  Elle semble indispensable pour le fonctionnement d’après la doc. :unsure:

            A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

            #141620
            Staff
            Zarnal
            • Level 21
            • Messages : 6820

              @stephbb75

              J’ai crée un sujet spécifique.

              A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

              #141653
              stephbb75
              • Level 7
              • Messages : 509

                @Zarnal

                Pas de problème, se seras plus claire en plus ;-)

                Par trop le temps de tester pour le moment, je suis sur d’autre truc, mais je vais m’y remettre (quand les journées aurons au moins 48h de plus :cry: )

                 

                https://youtube.com/@stephbb75

                #141654
                Staff
                Zarnal
                • Level 21
                • Messages : 6820

                  quand les journées aurons au moins 48h de plus

                  Eh oui. C’est parfois compliqué de prendre le temps. :-p

                  Je verrai demain pour Genesis, je n’ai toujours pas trouvé la commande sh ( et une partie de la doc d’amitcp_dhcp ne me semble pas bien claire ). :wacko:

                  Là, je regarde avec Roadshow qui a l’avantage d’avoir le DHCP d’intégré. Mais cela fait au moins deux fois que la limite des 15mn me rappelle à l’ordre… :lol:

                  A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                  #141657
                  Staff
                  Zarnal
                  • Level 21
                  • Messages : 6820

                    @stephbb75

                    Bon ben, avec Roadshow c’est Ok avec l’Ariadne II. :yahoo:

                    Le tout manuellement.  :-p

                     

                     

                    Le DHCP  géré en natif a bien aidé.

                    Maintenant, reste à le gérer avec Genesis. :-p

                     

                    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                    #141732
                    Staff
                    Zarnal
                    • Level 21
                    • Messages : 6820

                      Résultats avec mes tests d’hier : il y a du mieux mais ce n’est pas encore cela. J’ai pourtant bien utilisé x.x.255.0 mais cela persiste avec x.x.255.255.

                      Il ne me reste donc plus qu’à trouver le bon fichier de config et à corriger. :unsure:

                      De plus, il n’est fait mention nulle  part de ce besoin d’assignations diverses en plus ( l’explication à mes premiers echecs, AmiTCP est pourtant bien assigné par défaut au répertoire de Genesis ).

                      Edit : je crois que j’ai compris.

                      Contenu de tmp/dcs994696 :

                      #!/bin/sh

                      reason= »NBI »
                      export reason
                      /etc/dhclient-script
                      exit $?

                      Avec mon assignation pour etc, cela fout le boxon. Je verrai en soirée, je me suis assez pris la tête avec cela hier en fin de journée. :-p

                      Je me demande si le souci avec l’erreur de la commande » sh  » vient du fichier dcsxxxxxx lui même ou bien du contenu de  » dhclient-script « . :scratch:   A voir.  :unsure:

                      @stephbb75

                       

                      A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                      #141782
                      Staff
                      Zarnal
                      • Level 21
                      • Messages : 6820

                        @stephbb75

                        Alors là, j’en perds mon latin. Après avoir testé sous 3.2.1 après le PPC et strictement dans les mêmes conditions et options qu’en 3.9, j’ai une erreur différente.

                        Non seulement il ne trouve pas la commande UNIX uname pour Amiga ( impossible à trouver, même dans les gcc-utils ), j’ai trouvé les autres. J’ai regardé sur Aminet mais je ne la trouve pas non plus, ni ailleurs… :wacko: :wacko: :wacko:

                         

                        A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



                        #141848
                        Staff
                        Zarnal
                        • Level 21
                        • Messages : 6820

                          J’ai réussi avec MiamiDx du premier coup ( tout comme avec Roadshow ). :unsure:

                          Mais avec Genesis, toujours nada. Le script DHCP du plugin se lance et puis une erreur  » no broadcast interface found « . A savoir s’il ne faut pas créer un fichier  » interfaces  » et/ou en modifier d’autres.

                          Par ailleurs, il semble y avoir plusieurs niveaux de support DHCP ( partiel ou complet suivant les piles ). Qu’en est il du plugin Genesis ?

                          Note : je n’ai volontairement pas mis ma box en mode routeur.

                          A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                          #141904
                          Staff
                          Zarnal
                          • Level 21
                          • Messages : 6820

                            Par ailleurs, il semble y avoir plusieurs niveaux de support DHCP ( partiel ou complet suivant les piles ). Qu’en est il du plugin Genesis ?

                            J’ai trouvé.

                            En fait, le DHCP via un pont ou bien un routeur. :unsure:

                            Est ce que le plugin Genesis gère les deux ? Mystère pour l’instant. :unsure:

                            A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                            #141913
                            stephbb75
                            • Level 7
                            • Messages : 509

                              Moi j’avance peut !

                              J’ai juste réussit avec Geneis de faire une config avec IP fix.
                              J’aurais peut être plus de temps demain et se WE…..

                              https://youtube.com/@stephbb75

                              #141915
                              Staff
                              Zarnal
                              • Level 21
                              • Messages : 6820

                                De mon coté, j’ai du mieux. :-p

                                Et là au moins, il y a une indication :

                                 

                                A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                                #141918
                                Staff
                                Zarnal
                                • Level 21
                                • Messages : 6820

                                  Ok, pour info en attendant la suite :

                                  Contenu correct du fichier  » Interfaces  » après mes modifs :

                                  #Ethernet AriaDNEII
                                  ekp dev=devs:networks/ariadne_ii.device UNIT=0
                                  # EOF

                                  Il trouve bien l’interface. Mais cela ne se connecte toujours pas. Aucune erreur pourtant au debug. :unsure:   :wacko:

                                  Je vais aller chercher du coté du fichier startnet.

                                  A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                                Partager sur vos réseaux sociaux préférés :
                                Facebooktwitterredditpinterestlinkedintumblrmail
                                Affichage de 15 réponses de 1 à 15 (sur un total de 34)
                                • Vous devez être connecté pour répondre à ce sujet.