Classic WB 3.9 installation dans WinUAE ?

Forum Autour de l’Amiga Amiga OS 4 – MorphOS – UAE – AROS Classic WB 3.9 installation dans WinUAE ?

  • Ce sujet contient 45 réponses, 5 participants et a été mis à jour pour la dernière fois par Kimy, le il y a 1 année et 4 mois.
  • Créateur
    Sujet
  • #156406
    Sebiohazard
      • Level 7
      • Messages : 416

      J’ai eu un problème pour l’installation de Classic WB 3.9. Mon HDD est en RDB & dans l’interface de WinUAE (CD & Hard drives) il est en  » UAE:0  »

      Lors de l’installation de Classic WB 3.9 il a refusé de poursuivre je ne sais pas pourquoi, donc impossible de l’installer. Lorsque j’ai mis ce même HDD en DH0 (donc je l’ai forcé dans ” Properties “) comme indiqué dans les instructions, au redémarrage de WinUAE j’ai eu un plantage avec une fenêtre rouge comme un  » Guru Meditation  »

      Si j’utilise le HDD de Zarnal il passe direct en DH0 (le HDD de Classic WB étant lui en DH1) & non en UAE:0 comme avec le mien & là l’installation est possible… je pige pas ?! :unsure:

    Affichage de 15 réponses de 16 à 30 (sur un total de 45)

    Partager sur vos réseaux sociaux préférés :
    Facebooktwitterredditpinterestlinkedintumblrmail

    • Auteur
      Réponses
    • #156586
      Staff
      Zarnal
        • Level 22
        • Messages : 7492

        Je me plaçais plus du côté émulateur et utilisateur lambda ( alors c’est pas péjoratif) qui en fait s’en fout de savoir comment cela fonctionne

        Alors pourquoi poser autant de questions différentes dans ce cas  si l’apprentissage n’est pas le but ? Là, je coince. Il faut bien comprendre comment cela fonctionne pour comprendre pourquoi cela ne fonctionne pas.

        Si osef de la technique, dans ce cas autant prendre un truc déjà tout prêt. :unsure:

        Parce que le hdf ( sur l’uaehf.device ) sans RDB, cela va être coton avec un outil de partitionnement. Et après la question sera ” Je ne comprends pas, mes partitions n’apparaissent pas au reboot alors que tout s’est bien passé lors du partitionnement” .  :-p :unsure:

        Ce qui est bien sûr différent de WinUae qui fait sa sauce avec son HDF ” brut ” avec son ” RDB virtuel ” à formater directement. La nuance est là.

        Ou alors, je  n’explique pas convenablement, mais là cela serait encore autre chose. :lol: :-p

        A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



        #156587
        Staff
        Aladin
          • Level 25
          • Messages : 14724

          Ce qui est bien sûr différent de WinUae qui fait sa sauce avec son HDF » brut » avec son » RDB virtuel » à formater directement.

          Ce n’est pas spécifique à WinUAE. Tous les hdf fait dessus sans rdb fonctionne nickel sur le RPI.

          Tous les jeux au format HDF, qui sont sans rdb, fonctionnent partout.

          Je pense que c’est plutôt une caractéristique du format HDF.

          #156592
          Staff
          Zarnal
            • Level 22
            • Messages : 7492

            Tous les jeux au format HDF, qui sont sans rdb, fonctionnent partout.

            La plupart des émulateurs étant tous déviés d’UAE à la base ( WinUae compris ), rien d’anormal. Cela gère le format de la même façon je suppose ) Je n’ai pas utilisé ce terme de ” RDB virtuel ” par hasard même s’il n’est pas forcément le plus approprié.

            Essaye juste de faire une partition ( HdToolBox ou bien HDInsTools ) avec un HDF sur l’uaehf.device sans le Full RDB. Les partitions n’apparaitront pas. Cela ne peut pas fonctionner. :unsure:

            Démonstration avec un HDF de 200MO :

            Au début, le DH0:NDOS apparait et bien entendu, si tu formates directement cela fonctionnera puisque UAE et ses dérivés feront le nécessaire avec ce que j’ai nommé peut être à tort le ” RDB virtuel “. Mais à partir du moment où tu utilises un outil de partitionnement, ce n’est plus du tout la même musique. :unsure:

            A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

            #156593
            Staff
            Aladin
              • Level 25
              • Messages : 14724

              Oui j’ai testé il y a pas longtemps de faire un rdb sur un hdf pour avoir deux partitions. Au bout d’une heure le hdf était mort. Chose qui n’arrive jamais avec un hdf simple partition sans rdb. J’en ai déduit que ce n’est pas fait pour cela. C’est possible de la faire mais c’est pas fait pour. Bref pour moi, plus jamais.

              Mais je pense que dire qu’il n’y a pas de RDB est une inexactitude, il doit en coller un par défaut qui remplit le HDF d’une partition unique à la création du HDF. Pour vérifier, il suffit de créer un HDF avec WinUAE, le formatter sous AmigaOS, puis d’ouvrir HDToolbox, je suis presque sûr qu’il doit montrer une partition existante remplissant tout le disque.

              #156599
              Staff
              Zarnal
                • Level 22
                • Messages : 7492

                Oui j’ai testé il y a pas longtemps de faire un rdb sur un hdf pour avoir deux partitions. Au bout d’une heure le hdf était mort. Chose qui n’arrive jamais avec un hdf simple partition sans rdb. J’en ai déduit que ce n’est pas fait pour cela. C’est possible de la faire mais c’est pas fait pour. Bref pour moi, plus jamais. Mais je pense que dire qu’il n’y a pas de RDB est une inexactitude, il doit en coller un par défaut qui remplit le HDF d’une partition unique à la création du HDF.

                C’est ce que je me tue à essayer d’expliquer plus ou moins maladroitement il semblerait. :-p   Parlons plutôt de ” RDB Light virtuel ” # ” Full RDB mode “.  :lol:   Bref, WinUae fait sa sauce si on ne partitionne pas. Ce n’est pas pour rien que Toni avait expliqué qu’un HDF sans RDB cela n’existait pas. C’est juste géré de manière différente au travers d’un même HDF.

                D’ailleurs, pour faire suite à ma vidéo du dessus, tout se passe bien mieux avec le RDB. On récupère les partitions. :-p

                A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                #156615
                Sebiohazard
                  • Level 7
                  • Messages : 416

                  Alors pourquoi poser autant de questions différentes dans ce cas si l’apprentissage n’est pas le but ? Là, je coince. Il faut bien comprendre comment cela fonctionne pour comprendre pourquoi cela ne fonctionne pas.

                  Exactement j’adore apprendre même si ce n’est pas toujours évident, je vous remercie pour votre aide, j’ai appris plein de choses ces dernières semaines, & désolé si j’ai certainement posé des questions ” bêtes ”

                  Mais je pense que dire qu’il n’y a pas de RDB est une inexactitude, il doit en coller un par défaut qui remplit le HDF d’une partition unique à la création du HDF. Pour vérifier, il suffit de créer un HDF avec WinUAE, le formatter sous AmigaOS, puis d’ouvrir HDToolbox, je suis presque sûr qu’il doit montrer une partition existante remplissant tout le disque

                  En fait si tu n’actives pas le RDB à la création d’un .hdf il est impossible d’utiliser HDToolBox ou HDInstTool preuve qu’il n’y a pas d’émulation de la géométrie du disque dur j’imagine ? Après je ne sais pas comment WinUAE gère ça :unsure:

                  Je me suis documenté sur le RDB qui veut en fait dire ” Rigid Disk Bloc ” dans la doc il le compare au ” Master Boot Record ” sur le HDD d’un PC.

                  Par contre j’avais une question concernant HDToolBox & HDInstTool quelles sont les différences entre ces deux programme ? Lequel est mieux ? J’aime bien HDToolBox pour son interface :lol:

                  Sinon j’ai vraiment une très grande admiration pour les devs de WinUAE (& des émulateurs en général) je pense que ce sont des génies de l’informatique, c’est juste incroyable d’avoir autant de connaissances & de pouvoir émuler un Amiga aussi précisément.

                  J’avais lu un article qui disait que WinUAE était plus précis qu’un vrai Amiga :yes:

                  #156619
                  Staff
                  Aladin
                    • Level 25
                    • Messages : 14724

                    Pour info, sur un disque dur scsi, ce n’est pas hdtoolbox que l’on utilise :)

                    Sur les cartes Phase5 c’est: SCSIConfig

                    http://obligement.free.fr/articles/accelerer_disque_dur.php
                    http://obligement.free.fr/articles/blizzard1230iv_scsi.php

                    MBR, cela existe encore? je croyais que le standard maintenant en RBD pour un PC c’était le GPT :yahoo: à cause des gros disques.

                    #156626
                    Staff
                    Zarnal
                      • Level 22
                      • Messages : 7492

                      Par contre j’avais une question concernant HDToolBox & HDInstTool quelles sont les différences entre ces deux programme ? Lequel est mieux ? J’aime bien HDToolBox pour son interface

                      Avis n’engageant que moi :

                      l’avantage de HDToolBox c’est qu’il est fourni avec le WB et que c’est l’outil historique du WB ( à partir du 600 ).

                      Le gros plus de HDInstTools est qu’il permet de faire une sauvegarde du RDB et de la restaurer au besoin en cas de crash ( surtout utile en cas de soucis sur une vraie machine, sur l’émulateur, une simple copie du HDF suffira :-p ).

                      A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                      #156627
                      Staff
                      Zarnal
                        • Level 22
                        • Messages : 7492

                        MBR, cela existe encore? je croyais que le standard maintenant en RBD pour un PC c’était le GPT à cause des gros disques.

                        Tu rigoles mais je suis toujours en MBR sur mon portable avec son disque de 1To, pas d’autre choix. Le GPT n’était pas encore d’actualité, ni même ces bios modernes tout beaux et tout jolis.  :-p

                        Il est bien loin le temps du fdisk. :lol:

                        A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                        #156629
                        Sebiohazard
                          • Level 7
                          • Messages : 416

                          MBR, cela existe encore? je croyais que le standard maintenant en RBD pour un PC c’était le GPT :yahoo: à cause des gros disques.

                          Je déteste les nouveaux BIOS UEFI & les disques en GPT ça te crée plein de partitions cachées… suis encore en MBR avec Windows 7 & en BIOS Legacy :yes:



                          #156640
                          Sebiohazard
                            • Level 7
                            • Messages : 416

                            Encore un truc bizarre… si je crée un HDD au format HDF en RDB que je l’attache en ” Commodore A600/A1200/A4000 IDE ” HDToolBox ne le reconnaît pas mais HDInstTool oui ?! :unsure: :unsure: :unsure:

                            Par contre si je le partitionne avec HDInstTool (merci le Zarnal Boot Disk) & qu’ensuite je l’attache en ” uaehf-device ” que je reboot avec la disquette Install WB 3.1 là HDToolBox le reconnaît ?! Je pige rien ?! :unsure:

                            Au fait quelle différence entre ” IDE (Auto) ”  & ” Commodore A600/A1200/A4000 IDE ” ?

                            #156641
                            stephbb75
                              • Level 10
                              • Messages : 1168

                              Pour HDToolBox il faut dans les info de l’icone lui mettre le bon device, de base il est sur le SCSI (c’est le nom de l’IDE sur 600/1200/4000).

                              HDInstToolje ne connais pas trop mais il doit faire tous les device qu’il trouve ?

                              Au fait quelle différence entre » IDE (Auto) » & » Commodore A600/A1200/A4000 IDE » ?

                              IDE auto c’est l’émulation faite pas UAE, le reste c’est une émulation du hard des machine ou des différent contrôleurs qui existe pour Amiga.

                              https://youtube.com/@stephbb75

                              #156646
                              Staff
                              Zarnal
                                • Level 22
                                • Messages : 7492

                                Sinon j’ai vraiment une très grande admiration pour les devs de WinUAE (& des émulateurs en général) je pense que ce sont des génies de l’informatique, c’est juste incroyable d’avoir autant de connaissances & de pouvoir émuler un Amiga aussi précisément. J’avais lu un article qui disait que WinUAE était plus précis qu’un vrai Amiga

                                Techniquement et actuellement, il n’y a qu’un seul développeur pour WinUae, après, il y a les aides diverses de codeurs tiers  pour les ajouts et au bout il y a les testeurs.

                                WinUae est passé par deux autres codeurs majeurs ( avant que Toni ne prenne le relai ) dont le créateur initial de WinUae.

                                Le jour où WinUae sera plus précis qu’une vraie machine il pleuvra des javelots dehors. :lol: Plus rapide c’est certain mais pas plus précis.

                                Cela reste du cycle, pas du transistor ( dans le meilleur des cas pour les 500/600 ). Dans le cas du cycle, c’est très proche de la réalité. Tout n’est qu’une question de vitesses diverses et de synchronisation à respecter.

                                Exemple : dans le cas des machines OCS/ECS, les vitesses sont bonnes. Pour l’AGA, c’est trop lent ou trop rapide ( toujours dans le cas du cycle et c’est lié au CPU ). Pour imager, on pourrait dire que ce n’est pas un A1200 mais plutôt un A1275. :lol:

                                Les disques durs émulés sont bien différents de la réalité. Là, suivant les cas, c’est de la F1 assurée.

                                A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                                #156652
                                Kimy
                                  • Level 16
                                  • Messages : 3087

                                  MBR, cela existe encore? je croyais que le standard maintenant en RBD pour un PC c’était le GPT à cause des gros disques.

                                  Tu rigoles mais je suis toujours en MBR sur mon portable avec son disque de 1To, pas d’autre choix. Le GPT n’était pas encore d’actualité, ni même ces bios modernes tout beaux et tout jolis. :-p Il est bien loin le temps du fdisk ! :lol:

                                  Copain !

                                  Et même sur un 2 To, je suis toujours en MBR… :yahoo: 2.2 To au maximum pour le MBR, donc pas de soucis !

                                  J’ai même de grosses partitions en FAT32, genre 200 Go ! :yes:

                                  Et évidement, même sur Seven (32 / 64 bits), en plus d’XP, c’est en Legacy sur les “BIOS à la noix d’UEFI” !

                                  Qui utilise vraiment les UEFI avec leur interface… ?

                                  C’est surtout un souci du fait que c’est un véritable OS, je trouve !

                                  #156657
                                  Staff
                                  Zarnal
                                    • Level 22
                                    • Messages : 7492

                                    Moralité : on est déja des vieux cons avant l’heure. :lol:

                                    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                                  Partager sur vos réseaux sociaux préférés :
                                  Facebooktwitterredditpinterestlinkedintumblrmail
                                  Affichage de 15 réponses de 16 à 30 (sur un total de 45)
                                  • Vous devez être connecté pour répondre à ce sujet.