WinUAE prob vsync

  • Créateur
    Sujet
  • #178243
    Keade
      • Level 0 - Newbie
      • Messages : 4

      Salut les amigaistes !

      J’espère que je suis au bon endroit pour une question de support ?

      En lançant WinUAE l’autre, je vois qu’il y a des options d’affichage intitulées “beam racing”. Cela m’intrigue car j’avais déjà lu 2-3 trucs à ce sujet sur Blurbusters. Donc j’essaye.

      Et là, boum :wacko: Bon, ça ne fonctionne pas. Ca fait ramer atrocement. Du coup, je me demande si ça fonctionne pour quelqu’un ici ? J’ai esssayé un paquet de réglages sans succès. Et je suis très (très) confus sur certains réglages dans WinUAE. Par exemple :
      – Pourquoi dans Host > Display > Settings > Native > dropdown de droite, il y a des choix 50/60Hz et des choix pas 50/60Hz ? Le choix de la fréquence de l’écran (le mode d’affichage “demandé” au driver graphique, quoi), il est en haut à droite dans une autre liste déroulante
      – Pourquoi “double buffering” et “triple buffering” sont disponibles en même temps que le choix de la vsync dans la liste déroulante Host>Display>Settings>Native>dropdown de droite ? Si double buffering ou triple buffering c’est bien qu’il y a la vsync, non ? Pas de vsync = pas de buffering, j’ai bon ?
      – Quel est le meilleur mode d’affichage pour le beam racing ? J’ai un écran 1080p 144Hz la logique serait de n’utiliser aucune forme de buffering ou vsync et un mode d’affichage 1080p 144Hz n’est-ce pas ?

      J’ai un PC gamer largement assez puissant, RX 7900 XT, Windows 10, des drivers à jour (et WinUAE à jour évidemment). J’ai testé dans divers jeux, le problème ne vient pas du software ou de l’émulation.
      Dans le panneau de contrôle GPU j’ai Radeon enhanced sync activé et la vsync activée par défaut (mais non forcée).

      Merci à vous ! :bye:

    Affichage de 15 réponses de 1 à 15 (sur un total de 28)

    Partager sur vos réseaux sociaux préférés :
    Facebooktwitterredditpinterestlinkedintumblrmail

    • Auteur
      Réponses
    • #178248
      rnuls
        • Level 7
        • Messages : 509

        Voilà une question intéressante que je me pose aussi (indirectement).

        On avait évoqué la chose lors d’un concours du mois sur un flipper (Aladin me semble t’il mais ma mémoire n’est plus ce qu’elle était :wacko: )

        1200 (l'est bien malade) - 500 - Amikit/AGS - A500mini



        #178251
        stephbb75
          • Level 10
          • Messages : 1188

          Salut @Keade,

          Alors tu rentre dans les réglage pointue de WinUae. ;-)

          Franchement dans 99% des cas il ne sert pas a grand choses d’y toucher.
          c’est utile si tu veut émuler par exemple un moniteur d’origine, voire multisync pour utiliser des softs qui utilisais les modes spécifique comme productivité et avoir un rendu des plus fidèle.
          Cela peut être utile si tu veut faire des vidéos avec une représentation “exacte” du moniteur…

          de mémoire une partie est pour ta carte graphique et l’autre pour l’émulation.
          Mais cela fait bien longtemps que je n’ai pas jouer avec ces réglages.

          J’ai un écran 1080p 144Hz

          Heuuu comment dire, l’Amiga (de base) ne sais pas sortir autre choses que du 720×576 (résolution D1) à 50hz sauf quelques modes qui de toute façon ne passais pas sur un moniteur ou une TV.
          (oui oui le 31khz VGA, utiliser par 0,0001% :lol: )
          Donc sur ton moniteur 1080 tu est obligé d’avoir soit des lignes en double (ou plus) et pareil pour les colonnes pour afficher en plein écrans l’image de l’Amiga.
          Le pire c’est bien de tenter de faire un scaline (la on invente des pixels qui n’existe pas !).

          donc 144hz, l’Amiga (de base et même +) ne l’a jamais connu :lol:

          J’ai un PC gamer largement assez puissant, RX 7900 XT,…

          Alors moi j’ai un I5-2300, une carte graphique qui date de la même époque :wacko:
          Et tout tourne bien plus vite que sur un vrais Amiga.
          il faut pas trop jouer avec les setting de display et Chipset, sinon cela casse tout :scratch:
          Ensuite tout ceci peut prendre effectivement du temps et ralentir l’émulation.

          https://youtube.com/@stephbb75

          #178260
          hyruz
            • Level 1
            • Messages : 29

            En émulation UEA ou autre, je n’ai jamais réussi à avoir un rendu totalement fluide même en configurant de base pal en 50hz, ainsi que le moniteur et drivers nvidia en 50hz.
            Un simple scrolling ne reste pas parfaitement fluide des micros saccadent apparaissent.
            c’est pour moi je GROS problème de l’émulation du pc.
            Je crois bien que les pc actuels (fonctionnant tous avec des synchronisations  anarchiques) sont incapables de restituer un vrai 50 ou 60hz stable comme le fait un vrai amiga.

             

            #178265
            Kimy
              • Level 16
              • Messages : 3131

              Exactement ce que j’ai dit plusieurs fois ici pour les scrollings. Fellow sous DOS faisait mieux que WinUAE (OK, je suis resté sur une ancienne version, la 2.0.0), mais je ne pense pas que ça ait changé d’après ce que tu dis.

              En rigolant, sur le box Kaze de 2008 des Cités d’or, j’avais dit que la fluidité des travellingd me faisaient penser à un Amiga…

              #178268
              hyruz
                • Level 1
                • Messages : 29

                Pour simplifier: l’essentiel qui fait la qualité de l’Amiga est sont rendu graphique 2D super fluide, chose que l’émulation uea ne sait ou peut pas faire.
                Sur amiga la synchro était fixe 50 ou 60hz stable. La vitesse d’exécution des programmes était basée dessus.
                C’est pourquoi les jeux était un peu plus lent chez nous en Pal.
                Sur pc même si la normale est 60hz, il n’y a (plus) de vrai standard et la syncro change à chaque config pc.
                Pire avec le gsync la fréquence s’adapte au débit du fps.
                La vitesse est gérée par calcul de delta time et cela n’est forcement pas un nombre juste, des sauts d’images de temps en temps rattrapent le retard (ou l’avancement).
                L’émulation est intéressante pour développer plus confortablement, tester, mais cela s’arrête là. Jouer à pinball dream avec le scrolling qui par moment fait de saccades me dégoute grave et me rappelle que l’on a perdu l’essentiel, c’était BEAU sur Amiga B-)

                #178270
                Kimy
                  • Level 16
                  • Messages : 3131

                  Je comprends, surtout pour ce style de jeux !

                  Là, je suis sur WinUAE avec “Beast” justement, et ce n’est pas la fluidité de l’Amiga. Il suffit de regarder les premiers plans au niveau des scrollings de l’intro de l’écran titre, même avec la Vsync.

                  Ça le fait également aux moments des défilements de textes et aussi sur “Wrath of the Demon” pour les mêmes choses et les mêmes raisons.

                  La liste doit être assez longue…

                  #178273
                  hyruz
                    • Level 1
                    • Messages : 29

                    Beaucoup d’écrans pc ne sont pas compatible 50hz.
                    Si c’est votre cas configurer uea en 60 comme votre écran avec la vsync activé. Cela doit déjà aller mieux, cela rend  fluide quelques seconde mais espacées de saccades forcées pour recaller la vitesse au vrai 60hz

                    #178289
                    Kimy
                      • Level 16
                      • Messages : 3131

                      J’ai testé sur des CRT Iiyama et Targa en 50 Hz, ce n’est pas comme sur Amiga. Je me rappelle même que c’était comme ça avec les anciennes cartes graphiques (début des années 2000 et 2010).

                      Ça pourrait également venir de DirectX qui gère les fréquences et le reste différemment.

                      #178294
                      Staff
                      Zarnal
                        • Level 22
                        • Messages : 7505

                        J’ai testé sur des CRT Iiyama et Targa en 50 Hz, ce n’est pas comme sur Amiga. Je me rappelle même que c’était comme ça avec les anciennes cartes graphiques (début des années 2000 et 2010). Ça pourrait également venir de DirectX qui gère les fréquences et le reste différemment.

                        Donc en 31 Khz ? Tu es sorti sur un moniteur PC ou bien sur une TV std ( la Targa ) ?

                        A moins d’utiliser un truc du genre soft15Khz ?

                        Et tu es sorti avec quelle prise. Mieux vaut privilégier une VGA ana je pense.

                        A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                        #178296
                        flaco
                          • Level 5
                          • Messages : 189

                          Bonjour,

                          Si je comprens bien les release notes ” Beam Racing Lagless VSync which reduces input latency to sub-5ms. Replaces old Low Latency VSync. (Use 1-2 slice Lagless VSync to match old Low Latency VSync behavior)”, la fonction beam racing sert à réduire le lag entre l’entrée et l’affichage et donc pas à réduire le tearing (le fait que le framebuffer soit rafraichi en cours d’affichage ce qui provoque un effet de brisure au milieu de l’image).

                          L’impression de saccades pourrait être aussi dû justement au vsync qui, en raison de la différence de rafraichissement de l’écran du pc par rapport à celle de l’amiga émulé, fait que le temps d’affichage de chaque image n’est pas le même de l’une à l’autre.

                          Mais donc y-a-t-il un compromis entre les deux…



                          #178302
                          hyruz
                            • Level 1
                            • Messages : 29

                            La fluidité constante que l’on avait sur amiga a pour ainsi dire disparue sur les pc actuel. Et ce malgré la puissance décuplé.
                            La vitesse n’est plus simplement basée sur la synchronisation, mais calculé par rapport à chaque configuration de pc.
                            Bien sur, on obtient un rendu fluide mais difficilement dans la durée.
                            Windows génère des micro interruption systèmes aléatoire qui se répercute par des perte frames et donc des micros freez.
                            Pour éviter cela il est important d’avoir un rendu plein écran exclusif qui monopolise la priorité. mais tout ce qui est des rendu à la mode en fenêtrée ou sur navigateur n’est pas constamment fluide sur windows.

                            #178303
                            Keade
                              • Level 0 - Newbie
                              • Messages : 4

                              Pour réagir vite faits à vos posts de réponse (je pensais pas qu’il y en aurait autant !)

                              a) Des capacités de la machine “guest” (l’Amiga) et celle de la machine “hôte” (ici un PC)
                              Le fait que l’Amiga ait des capacités d’affichage ridicules n’a pas de lien avec l’utilisation que WinUAE en fait en interne.
                              Oui, les jeux de l’époque calculaient jusqu’à 50 images par seconde (plutôt 25 ou moins pour la plupart).
                              Non, ça ne veut pas dire que WinUAE ne sait pas utiliser à sa façon des périphériques d’entrée et de sortie plus rapides. Ca n’a pas vraiment de rapport

                              b) Au sujet des scrollings pas fluides
                              Avec freesync et du double buffering, on devrait avoir des scrollings parfaitement propres, c’est absolument certain. C’est le cas sur mon PC avec MAME, où il n’y a littéralement rien à configurer : l’écran sur son mode d’affichage standard (1080p@144Hz pour le mien) + option “waitvsync” de MAME (dans mame.ini) et tout roule. Les jeux MVS sont parfaitement fluides, sans tearing malgré leur refresh rate de 59.18Hz.
                              On devrait pouvoir faire la même dans WinUAE, simplement, je n’ai à priori pas les bons settings :
                              – Si je garde 144Hz comme mode d’affichage, ça tourne trop vite
                              – Avec 50Hz -car mon écran le supporte-, WinUAE ça tourne trop vite aussi.
                              J’ai mis VSync 50/60Hz et suis en 50Hz dans Windows, double buffering sélectionné, le jeu tourne à fond les ballons alors qu’il devrait tourner exactement à la bonne vitesse. Même si j’utilise le setting “FPS adjust” pour bricoler.
                              Donc soit bug dans WinUAE et/ou mes drivers GPU, soit je n’ai pas compris quoi faire de tous les settings à disposition. Je vais également poser la question sur Abime (mes problèmes ne se limitant même pas au beam racing, ça je voulais juste tester en somme) car franchement je pige pas trop …

                              #178304
                              Keade
                                • Level 0 - Newbie
                                • Messages : 4

                                En fait, sans parler de solutions (franchement je pense que je vais laisser tomber vu que j’ai tout essayé, les réglages un peu basiques fonctionnent tant pis pour la latence) j’ai trouvé réponse à certaines de mes interrogations là bas https://eab.abime.net/showthread.php?t=93113&highlight=beam+racing.
                                Par exemple :
                                – si le mode beam racing peut fonctionner sans problèmes si la VRR est active, quels modes d’affichage utiliser pour l’écran, etc.
                                – les modes vsync (ou beam racing) estampillés 50/60Hz forceraient à priori 50Hz ou 60Hz (lequel des deux ? Je pense 50Hz pour un Amiga PAL 60Hz pour Amiga NSTC) au niveau de l’écran

                                #178313
                                Kimy
                                  • Level 16
                                  • Messages : 3131

                                  @Zarnal
                                  En VGA 50 Hz sur Windows avec VSync.

                                  #178375
                                  hyruz
                                    • Level 1
                                    • Messages : 29

                                    En vga tu crois ?
                                    faut une sortie vga sur la carte graphique et un écran vga qui veuille du 50hz :scratch:

                                  Partager sur vos réseaux sociaux préférés :
                                  Facebooktwitterredditpinterestlinkedintumblrmail
                                  Affichage de 15 réponses de 1 à 15 (sur un total de 28)
                                  • Vous devez être connecté pour répondre à ce sujet.