WinUAE prob vsync

  • Ce sujet contient 28 réponses, 8 participants et a été mis à jour pour la dernière fois par Kimy, le il y a 1 mois et 1 semaine.
  • Créateur
    Sujet
  • #178243
    Keade
      • Level 0 - Newbie
      • Messages : 4

      Salut les amigaistes !

      J’espère que je suis au bon endroit pour une question de support ?

      En lançant WinUAE l’autre, je vois qu’il y a des options d’affichage intitulées “beam racing”. Cela m’intrigue car j’avais déjà lu 2-3 trucs à ce sujet sur Blurbusters. Donc j’essaye.

      Et là, boum :wacko: Bon, ça ne fonctionne pas. Ca fait ramer atrocement. Du coup, je me demande si ça fonctionne pour quelqu’un ici ? J’ai esssayé un paquet de réglages sans succès. Et je suis très (très) confus sur certains réglages dans WinUAE. Par exemple :
      – Pourquoi dans Host > Display > Settings > Native > dropdown de droite, il y a des choix 50/60Hz et des choix pas 50/60Hz ? Le choix de la fréquence de l’écran (le mode d’affichage “demandé” au driver graphique, quoi), il est en haut à droite dans une autre liste déroulante
      – Pourquoi “double buffering” et “triple buffering” sont disponibles en même temps que le choix de la vsync dans la liste déroulante Host>Display>Settings>Native>dropdown de droite ? Si double buffering ou triple buffering c’est bien qu’il y a la vsync, non ? Pas de vsync = pas de buffering, j’ai bon ?
      – Quel est le meilleur mode d’affichage pour le beam racing ? J’ai un écran 1080p 144Hz la logique serait de n’utiliser aucune forme de buffering ou vsync et un mode d’affichage 1080p 144Hz n’est-ce pas ?

      J’ai un PC gamer largement assez puissant, RX 7900 XT, Windows 10, des drivers à jour (et WinUAE à jour évidemment). J’ai testé dans divers jeux, le problème ne vient pas du software ou de l’émulation.
      Dans le panneau de contrôle GPU j’ai Radeon enhanced sync activé et la vsync activée par défaut (mais non forcée).

      Merci à vous ! :bye:

    Affichage de 13 réponses de 16 à 28 (sur un total de 28)

    Partager sur vos réseaux sociaux préférés :
    Facebooktwitterredditpinterestlinkedintumblrmail

    • Auteur
      Réponses
    • #178394
      Kimy
        • Level 15
        • Messages : 2926

        J’ai tapé trop vite… 60 Hz !

        Par contre, mon Targa 14″ prenait bien le PAL 50 Hz avec ma TNT2 M64 et TVTools, j’avais testé des vidéos. Je ne l’ai plus depuis pas mal d’années maintenant…



        #178727
        hyruz
          • Level 1
          • Messages : 29

          A force de tester..
          Pour les maniaques du fluide .. lisse du rendu 2D de l’Amiga  .. B-)
          Sur Windows le mode plein écran exclusif (celui qui oblige un alt+tab pour basculer sur le bureau) permet une animation fluide sans interruption. l’écran prend la priorité d’affichage.
          Un mode plus ou moins abandonné car pas vraiment multitâche donc peu pratique pour l’utilisation actuelle que l’on fait du pc.
          J’ai donc chercher à configurer UEA en plein écran exclusif en “retournant” au possible les paramètres de l’émulateur et ceux de nvidia. En vain ..
          J’ai découvert une ancienne version de UEA adaptée pour utiliser AmosPro sur pc,
          Et j’ai réussi (enfin) à avoir ce rendu fluide et lisse sans “hoquet” (comme sur l’Amiga) avec cette version dont les paramètres sont un peu différents.
          J’ai testé directement avec Amos en lançant des exemples. (tutorial, amal ..)
          60hz et (si vous avec) 50hz fonctionnent. Ratio et mode pixel art respectés.
          Personnellement mon test est sur un écran tv en hdmi 4k mais configuré sur Windows en 1920 x 1080 et pour respecter le Pal de l’Amiga 50hz.
          https://www.itek.fi/Amos_Launcher/
          Ici 60hz ntsc, basculer en 50hz pal (comme moi) suivant votre config.

          Ceci pour dire que l’émulation FLUIDE est possible sur pc.
          A voir comment configurer les dernières version de UEA :scratch:

          #178735
          Kimy
            • Level 15
            • Messages : 2926

            Très bien !

            Tu devrais mettre dans ton post la version de WinUAE utilisée.

            J’aurai donc “Beast” avec les premiers plans fluides !!

            #178742
            hyruz
              • Level 1
              • Messages : 29

              Bonjour,
              Y’a le lien de l’amos qui utilise la dite version.
              Sinon la version est la 2.3.2  trouvable  ici:
              https://sourceforge.net/projects/winuae/files/WinUAE/2.3.2/
              J’ai encore fait des test de fluidité avec la derniere version 5.2.0 ce matin, impossible d’avoir un rendu fluide.
              Je suis en train de me configurer une version 2.3.2
              Pour développer et programmer plus confortablement que sur l’amiga   :-)
              Certaines versions plus récentes de UAE doivent être fluide, faudrait tester.

              #178743
              Kimy
                • Level 15
                • Messages : 2926

                Comme quoi, c’est toujours dans les vieux pots…

                Avec ma 2.0.0, ça marche peut-être bien également !

                #178744
                hyruz
                  • Level 1
                  • Messages : 29

                  le mieux est souvent l’ennemi du bien :unsure:

                  #178745
                  Kimy
                    • Level 15
                    • Messages : 2926

                    On le dit souvent… Je reste sur ma 2.0.0 qui marche bien.

                    Juste un IPF d’un jeu du concours du mois qui n’a pas voulu passer dessus, je me suis rabattu sur l’ADF du coup.

                    Evidement, on a pas la précision et la compatibilité qusi-totale comme sur les 4.9 / 5.x, mais ça me va quand même.

                    #178746
                    hyruz
                      • Level 1
                      • Messages : 29

                      Comme je disais plus haut, sur windows seul le mode plein écran exclusif permet une fluidité comme on a connue sur amiga au tout ancien système dont la vitesse d’exécution était basé sur la syncro qui était fixe à cette époque  50 ou 60 .
                      Maintenant windows doit savoir gérer tout un tas de syncro de v sync et autre ulmb et donc n’utilise plus la syncro pour régler la vitesses mais un tas de calcul qui ne tombe jamais juste et donc génère du “hoquet” pour retomber à la syncro.
                      De plus Windows génère des micro interruptions systèmes qui ajoute des perte des frames de temps en temps.
                      Le mode plein écran exclusif  adapte la vitesse à l’ancienne soit à la syncro et n’est pas sujet aux micros freez . c’est un mode qui prend la priorité au détriment de fonction multitâches au autres.
                      Malheureusement ce mode est de plus en plus délaissé car non adapté à l’usage de multifenêtres à la mode actuelle.
                      De plus très peu de personne comme nous sont sensible à la pureté du fluide de l’affichage, la plupart des utilisateurs s’en moque. surtout que depuis la 3d et les pc qui rament, ils ont pris l’habitude et il est “normal” de ne plus êtres parfaitement synchro.
                      Misère en cela, on en perd l’essentiel :unsure:
                      La syncro n’est pas la seule chose à regretter. depuis l’abandon des crt pour les lcd fini la netteté dans les mouvement .. bonjour la bave ..
                      Cela a été amélioré avec l’ ulmb et ou les écrans oled, mais cela ne rend toujours pas aussi bien que sur un bon vieux tube.
                      Le mieux est souvent l’ennemi du bien  :unsure:

                      #178748
                      Kimy
                        • Level 15
                        • Messages : 2926

                        Il est malheureusement vrai que les gens s’habituent à mal ?!

                        Pour le tramage, soit je n’y suis pas sensible (pourtant ça se voit), soit je n’en ai jamais eu sur mes écrans !

                        On peut aussi parler de Mame avec des jeux en 59 Hz, heureusement, il y a des version du programme pour gérer ça. Mais comme la version officielle ne supporte pas la sauvegarde de trop de réglages, ce n’est pas possible de démarrer en mettant genre 60 Hz pour les jeux concernés.

                        Ce n’est pas bien grave, mais ça aurait été sympa…

                        Le mieux est souvent l’ennemi du bien ! :unsure:

                        C’est très souvent la morale de pas mal d’histoires ?!

                        #178749
                        Staff
                        Mutt2828
                          • Level 18
                          • Messages : 4297

                          Merci pour toutes ces infos intéressantes. :good:

                          A force je vais finir par croire que l’émulation peut être quasi parfaite. :lol: Je pense qu’il y en a un que ça va faire rire. :-p

                          En tout cas ça donne envie de faire des essais pour obtenir une émulation nickel.

                           

                           

                           

                          Très belle chute Bud!



                          #178753
                          hyruz
                            • Level 1
                            • Messages : 29

                            Suite des tests:
                            J’ai repris le dernier uae 5.2.0 avec les réglages suivant et le rendu est fluide !
                            J’avais pourtant testé et retesté .. là faut dire que c’est très propre.
                            en hdmi sur tv 4k résolution Windows 1920 1080 50hz paramètres 3d nvidia par default et mise a l’échelle “rapport largeur /hauteur” processeur graphique.
                            Le gros avantage de la 5.2.0 est l’input lag très bas, on se crois sur un amiga B-)  

                            #178768
                            Kimy
                              • Level 15
                              • Messages : 2926

                              Ben,  voilà ! C’est donc possible sur toutes les versions !

                              Je garde quand même la mienne.

                              Je vais faire un petit test avec “Fellow” sous “DosBox” pour voir et me rappeler des superbes souvenirs !!

                              Dire que je m’étais dit qu’UAE ne pouvait pas être battu à l’époque…

                              #178771
                              Kimy
                                • Level 15
                                • Messages : 2926

                                Juste pour la Nostalgie…

                                Beast (Intro Paranoimia) DOSBox Kimy

                                Beast (Interécran N°1) DOSBox Kimy

                                ChipChop17 (Music Disk) DOSBox Kimy

                                Il y a même des rippers dans “Fellow”, je l’avais complètement oublié, tout comme toutes son tas d’options, hors du choix des 68×00 !

                              Partager sur vos réseaux sociaux préférés :
                              Facebooktwitterredditpinterestlinkedintumblrmail
                              Affichage de 13 réponses de 16 à 28 (sur un total de 28)
                              • Vous devez être connecté pour répondre à ce sujet.