ClassicWB et upgrade en KS 3.2 et OS 3.2

Forum Amiga Software ClassicWB et upgrade en KS 3.2 et OS 3.2

  • Créateur
    Sujet
  • #130849
    chrisbati
    • Level 1
    • Messages : 18

    Bonjour,

    J’ai un A1200 avec une CF HD (ClassicWB Lite avec workbench 3.1 et rom KS 3.0).

    Je vais bientôt recevoir une carte accélératrice ACA1221lc et des rom KS 3.2 ainsi que l’OS 3.2

    J’aimerais bien conserver mon install classicwb et upgrader vers workbench 3.2, comment faire ?

    D’avance merci

    Chrisbati

15 réponses de 1 à 15 (sur un total de 15)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #130850
    demether
    • Level 6
    • Messages : 316

    question intéressante, mais tu trouves pas que le workbench 3.2 est plus sympa, avec ses glow icons ?



    #130853
    Staff
    Aladin
    • Level 25
    • Messages : 11174

    J’aimerais bien conserver mon install classicwb et upgrader vers workbench 3.2, comment faire ?

    Ben juste remplacer tes fichiers os3.1 ou os3.9 par ceux de l’os3.2 .

    Pour rappel classicwb, c’est juste un ajout d’une collection d’utilitaires préinstallé sur un wb comme amikit ou les milliers d’autres distributions customisant un wb pour ceux qui ne veulent pas le faire aux mêmes. Le défaut de ces distributions, c’est d’installer des trucs que l’on a pas besoin.

    Les différents packages ClassicWb à ajouter sur un os3.1/os3.9 :
    http://classicwb.abime.net

    #130885
    Staff
    Zarnal
    • Level 20
    • Messages : 5489

    Ben juste remplacer tes fichiers os3.1 ou os3.9 par ceux de l’os3.2 .

    Cela ne suffira pas je pense. Il   faudra réadapter certains scripts.

    Tu vas récupérer la startup et autres scripts du 3.2 en te contentant de copier les fichiers. Et perdre les scripts initiaux du Classic.

    A moins que l’ensemble des extras soient dans WbStartup ( et encore, il manquera peut être certaines assignations ). :scratch:

    Je vais tenter le coup. :-p Je vous tiens au jus.

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #130887
    Staff
    Zarnal
    • Level 20
    • Messages : 5489

    @chrisbati

    Quelle est ta version exacte du ClassicWB ?

    Lite, Full, Adv ou une autre ?

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #130907
    chrisbati
    • Level 1
    • Messages : 18

    J’ai une version lite.

     

    #130923
    Staff
    Zarnal
    • Level 20
    • Messages : 5489

    Je regarderai plus en détails en fin de journée mais c’est encourageant

     

    L’installation se passe bien. Un seul petit souci ( qui explique peut être le souci final des icônes ), il me demande les modules A2000 en  lieu et place des 1200.  :scratch:

     

     

     

    Maintenant, au final, seules les icônes posent un problème au niveau des couleurs :

     

    J’ai tenté de rectifier dans les prefs de NI mais rien à faire.

    Probable qu’il faille remettre quelque chose manuellement dans la startup.

    Le  reste semble demeurer correct ( avec réserves, je n’ai pas  tout vérifié ).

     

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #130945
    Staff
    Zarnal
    • Level 20
    • Messages : 5489

    C’est bien un souci de startup.  :unsure

     

    Une fois le 3.2 installé, il faudra juste faire un petit copier/coller.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #130947
    Staff
    Zarnal
    • Level 20
    • Messages : 5489

    En   fait, il faudra également un peu adapter. J’avais loupé un morceau coté classicWB. :lol:

    Exemple : le 3.2 n’aime pas fblit par exemple. :unsure:

    Il y d’autres détails dans le genre.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #130948
    Staff
    Zarnal
    • Level 20
    • Messages : 5489

    J’ai effectué les modifs nécéssaires. Avant :

     

    Après :

     

     

    Donc pour répondre à ta question initiale : oui c’est possible avec une ou deux adaptations.

    Tu charges ton classicWB, tu fais une sauvegarde de la startup-séquence d’origine, tu installes le 3.2 par dessus et tu procèdes aux quelques modification de la nouvelle startup.

    Note : je n’ai pas touché à la startup du 3.2. Elle est complète de son coté. J’ai juste procédé aux ajouts/retraits nécessaires.

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #131040
    chrisbati
    • Level 1
    • Messages : 18

    Un tout grand merci pour toutes ces recherches !!

    Donc, si j’ai bien compris (et rien n’est moins sûr):

    1- Je boot normalement sur mon classicwb actuel et je sauve la startup séquence. ==>Comment sauver la startup séquence ?

    2- Je suis toujours dans mon classicwb actuel et là je lance les adf de l’os3.2 ?

    3- une fois l’installation terminée, j’édite la nouvelle startup séquence et je repère les éléments de mon ancienne startup séquence qui ne sont pas dans la nouvelle. Je recopie les lignes manquantes.

    C’est bien ça ?

    Dans le dernier screenshot, le fond d’écran n’est plus celui « rétro », on le remet comment ?

    Merci

    Chrisbati



    #131056
    Staff
    Zarnal
    • Level 20
    • Messages : 5489

    Un tout grand merci pour toutes ces recherches !! Donc, si j’ai bien compris (et rien n’est moins sûr): 1- Je boot normalement sur mon classicwb actuel et je sauve la startup séquence. ==>Comment sauver la startup séquence ? 2- Je suis toujours dans mon classicwb actuel et là je lance les adf de l’os3.2 ? 3- une fois l’installation terminée, j’édite la nouvelle startup séquence et je repère les éléments de mon ancienne startup séquence qui ne sont pas dans la nouvelle. Je recopie les lignes manquantes. C’est bien ça ? Dans le dernier screenshot, le fond d’écran n’est plus celui « rétro », on le remet comment ? Merci Chrisbati

    Nornal qu’il n’apparaisse pas, je ne l’ai pas installé ( le thème ) en faisant une  seconde installation pour vraiment repartir de zéro.

    Cela ne change rien pour  le reste :

     

    Avant :

     

     

    Après :

     

    Ma rom  » physique  » est une 3.1. La  3.2 se charge au boot. Ce détail ne changera rien  si ce n’est que tu auras 3.2 en lieu et place de 3.1 (  puisque tu as  des roms physiques ).

    Si je mets une 3.2  » physique  » :

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #131062
    Staff
    Zarnal
    • Level 20
    • Messages : 5489

    Un tout grand merci pour toutes ces recherches !! Donc, si j’ai bien compris (et rien n’est moins sûr): 1- Je boot normalement sur mon classicwb actuel et je sauve la startup séquence. ==>1/Comment sauver la startup séquence ? 2- Je suis toujours dans mon classicwb actuel et là je lance les adf de l’os3.2 ? 3- une fois l’installation terminée,2/ j’édite la nouvelle startup séquence et je repère les éléments de mon ancienne startup séquence qui ne sont pas dans la nouvelle. Je recopie les lignes manquantes. C’est bien ça ? Dans le dernier screenshot, le fond d’écran n’est plus celui « rétro », on le remet comment ? Merci Chrisbati

    1/ En renommant juste le fichier s/startup-sequence en startup-ori ( par exemple ) juste avant l’installation  du 3.2 ( ne reboote surtout pas entre temps, uniquement à la fin de l’installation du 3.2 ). Une sauvegarde auto pourra également se faire à l’installation du 3.2 au moins en mode intermédiaire. Au choix.

    2/ Pas tout à fait. Tu recopies juste les lignes indispensables. Celles concernant les utilitaires et l’exécution des scripts. Il ne   faut pas faire de doublons. Et ne pas remettre Fblit.

     

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #131071
    chrisbati
    • Level 1
    • Messages : 18

    ok merci !

    J’ai vaincu l’installation de l’os 3.2, je l’ai faite à l’adf je ne suis jamais arrivé à la faire depuis le cd, toujours le même message d’erreur (pourtant cd bien monté et reconnu):

    Bref, ça boot bien mais j’ai le souci des couleurs, mais je ne vois pas trop quoi recopier de mon ancienne startup seq que voici:

    ;ClassicWB Startup-Sequence
    ;————————–
    ;LITE 3.1

    IF EXISTS DEVS:scsi.device
    C:LoadModule DEVS:scsi.device
    EndIF

    C:GetMouseInput LOCAL

    IF $MouseInput EQ 1
    Unset MouseInput
    C:SetPatch QUIET
    C:Assign >NIL: ENV: RAM:
    C:Assign >NIL: T: RAM:
    C:Execute S:Maxmem-Sequence
    EndCLI >NIL:
    EndIF

    IF $MouseInput EQ 2
    Unset MouseInput
    C:Execute S:Bootmenu-Sequence
    EndCLI >NIL:
    EndIF

    Unset MouseInput

    C:SetPatch QUIET

    IF EXISTS C:StackAttack
    C:StackAttack
    EndIF

    C:Version >NIL:
    FailAt 21

    IF EXISTS SYS:WBstartupD
    C:Rename >NIL: SYS:WBStartup SYS:WBStartupM
    C:Rename >NIL: SYS:WBStartupD SYS:WBStartup
    EndIF

    Resident >NIL: C:IconX PURE
    Resident >NIL: C:WBRun PURE
    Resident >NIL: C:Assign PURE
    Resident >NIL: C:Execute PURE

    IF EXISTS L:env-handler
    C:MakeDir RAM:T RAM:Clipboards
    L:env-handler
    C:Copy >NIL: ENVARC:Sys/def_kick.info ENV:Sys/def_kick.info
    ELSE
    C:MakeDir RAM:T RAM:Clipboards RAM:ENV RAM:ENV/Sys
    C:Copy >NIL: ENVARC: RAM:ENV ALL NOREQ
    Assign >NIL: ENV: RAM:ENV
    EndIF

    IF EXISTS C:PatchRAM
    C:PatchRAM
    EndIF

    IF EXISTS C:TagLiFE
    C:TagLiFE
    EndIF

    Assign >NIL: T: RAM:T
    Assign >NIL: CLIPS: RAM:Clipboards
    Assign >NIL: REXX: S:
    Assign >NIL: PRINTERS: DEVS:Printers
    Assign >NIL: KEYMAPS: DEVS:Keymaps
    Assign >NIL: LOCALE: SYS:Locale
    Assign >NIL: LIBS: SYS:Classes ADD
    Assign >NIL: HELP: LOCALE:Help DEFER

    IF EXISTS C:BlazeWCP
    C:BlazeWCP
    EndIF

    IF EXISTS SYS:System/FBlit/FBlit
    SYS:System/FBlit/FBlit
    SYS:System/FBlit/FText
    EndIF

    BindDrivers
    C:Mount >NIL: DEVS:DOSDrivers/~(#?.info)

    IF EXISTS DEVS:Monitors
    IF EXISTS DEVS:Monitors/VGAOnly
    DEVS:Monitors/VGAOnly
    EndIF

    C:List >NIL: DEVS:Monitors/~(#?.info|VGAOnly) TO T:M LFORMAT « DEVS:Monitors/%s »
    Execute T:M
    C:Delete >NIL: T:M
    EndIF

    SetEnv Language « english »
    SetEnv Workbench $Workbench
    SetEnv Kickstart $Kickstart
    UnSet Workbench
    UnSet Kickstart

    IF EXISTS C:IconBeFast
    C:IconBeFast 0
    EndIF

    C:AddDataTypes REFRESH QUIET
    C:IPrefs
    SYS:System/FPalette/FPPrefs
    C:ConClip

    Path >NIL: RAM: C: SYS:Utilities SYS:Rexxc SYS:System S: SYS:Prefs SYS:WBStartup SYS:Tools SYS:Tools/Commodities

    IF EXISTS S:User-Startup
    Execute S:User-Startup
    EndIF

    Resident Execute REMOVE
    Resident Assign REMOVE

    IF EXISTS C:StackAttack
    C:StackAttack AUTO
    EndIF

    C:LoadWB
    EndCLI >NIL:

    D’avance merci

    Chrisbati

    #131119
    Staff
    Zarnal
    • Level 20
    • Messages : 5489

    ok merci ! J’ai vaincu l’installation de l’os 3.2, je l’ai faite à l’adf je ne suis jamais arrivé à la faire depuis le cd, toujours le même message d’erreur (pourtant cd bien monté et reconnu):  ref, ça boot bien mais j’ai le souci des couleurs, mais je ne vois pas trop quoi recopier de mon ancienne startup seq que voici:

    D’avance merci Chrisbati

    Tu devrais avoir une nouvelle icône sur ton WB. C’est de là qu’il faut lancer l’installation.

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #131131
    Staff
    Zarnal
    • Level 20
    • Messages : 5489

    @chrisbati

    Pour ne pas s’embêter, voici ma startup. Tu renommes ton originale comme tu veux puis tu copies ce fichier en remplacement après avoir décompressé l’archive.

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail
15 réponses de 1 à 15 (sur un total de 15)
  • Vous devez être connecté pour répondre à ce sujet.