Plan de bataille pour mon A600

Forum Amiga Hardware Plan de bataille pour mon A600

This topic contains 37 réponses, has 10 participants, and was last updated by Mutt2828 Mutt2828 il y a 2 semaines et 2 jours.

8 sujets de 31 à 38 (sur un total de 38)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Messages
  • #83084
    Kaeril
    Kaeril
    • Level 3
    • Messages : 75

    Il s’est passé beaucoup de choses en une semaine ! Que de déceptions, que de désillusions ! Cet Amiga est en train de tourner à la farce grotesque, mais reprenons dans l’ordre…

    1) Le Rys MKII

    J’ai reçu mon Rys MKII, cet adaptateur pour utiliser les joysticks et manettes USB sur le port DB9 de l’Amiga. Super, je tente de le brancher et…

    Bah ça ne rentre pas, l’embout métallique est trop gros pour le 600. Bon, sur ce coup-là c’est de ma faute, Micromiga prévenait très bien du problème et je l’avais oublié. Pas de problème, je commande la rallonge de câble qu’ils recommandent pour ce souci. Quelques jours plus tard, je reçois la rallonge et…

    Ça ne rentre toujours pas ? Il s’avère que les modèles les plus récents du MKII possèdent une espèce d’embout métallique, en haut et en bas de la prise DB9, qui empêche d’enfoncer la prise dans la rallonge.

    Il a donc fallu entièrement désosser le MKII pour pouvoir le brancher, à la pince comme un barbare !

    Là, super ! Je vais enfin pouvoir utiliser mon Joystick Competition Pro USB. Et ça ne fonctionne pas. Le joystick ne réagit à aucun bouton, aucune direction, dans aucun des modes du MKII. Inquiet, je teste le MKII avec une souris USB, et là, tout fonctionne. Je le teste ensuite avec une manette Megadrive USB de chez Retro-bit (sous licence officielle de SEGA), et il fonctionne.

    Que se passe-t-il avec mon stick ? J’ai pourtant vu plusieurs vidéos et témoignages sur forum de gens utilisant le Competition Pro USB sans problème avec cet adaptateur, je l’avais vérifié avant d’acheter. Peut-être faut-il mettre à jour le firmware du MKII ? L’ennui, c’est que pour faire ça, il faut le brancher sur un PC avec un câble USB mâle-mâle, câble qui n’est évidemment pas fourni.

    Quelques jours et une nouvelle commande plus tard, j’ai mon câble. Je mets le firmware du MKII à jour. Pas de meilleur résultat. Mon stick refuse de fonctionner.

    Après de longues recherches, j’ai fini par découvrir une petite fourberie : il existe différents modèles du Competition Pro USB. Le Rys MKII est compatible avec les modèles SL-6603-GOLD et SL-6603-SBK. Le modèle le plus récent, celui qu’on trouve sur Amazon et la plupart des boutiques en ligne, celui que j’ai acheté donc, est le Competition Pro « Anniversary Edition », modèle SL-650212-BKRD. Modèle parfaitement incompatible avec le Rys MKII.

    J’ai écrit aux polonais qui fabriquent le MKII pour leur demander si une mise à jour de leur firmware est prévue, je n’ai pour l’instant aucune réponse. La dernière version datant de début 2016, j’ai peu d’espoir.

    Tant pis, je me passerai donc de joystick pour le moment.

    2) La Furia 020

    J’en étais resté à cette carte qui refusait de s’insérer sur le 68000. Après un total de 4 heures d’acharnement, qui ont impliqué pêle-mêle un chiffon doux, de l’alcool isopropylique, une disqueuse pour élargir le slot (!) et un marteau pour l’enfoncer (!!), et après avoir cru casser l’Amiga une bonne demi-dizaine de fois, VICTOIRE ! La carte s’insère enfin.

    La grande question étant, après cette torture : est-ce qu’elle fonctionne ? La réponse est : c’est compliqué.

    Au premier démarrage, j’ai un écran noir. Je retire la carte (qui peut désormais s’insérer et se retirer sans problème), et l’Amiga démarre normalement. Ouf, je ne l’ai pas cassé. Qu’est-ce qui coince, alors ? Il semble que l’Amiga commence à démarrer sur la CF normalement, mais que quelque chose bloque et tout s’arrête. Le voyant témoin du disque dur reste fixement allumé et plus rien ne se passe.

    Après quelques recherches, je me laisse dire qu’il faut peut-être démarrer l’Amiga avec l’option « Disable CPU Caches » activée dans les options de démarrage (maintenir les deux boutons de souris enfoncés à l’allumage). Je tente donc ça… bonne nouvelle déjà, j’atterris bien sur le menu d’options de démarrage, ce qui semble indiquer que la Furia n’est pas complètement flinguée. Encore mieux, elle est reconnue et indiquée comme fonctionnelle dans la liste des cartes d’extension :

    Mais « Disable CPU Caches » n’aide pas à démarrer la CF.

    Je tente de démarrer sans rien sur le port IDE, histoire d’être sûr : j’arrive bien sur l’écran de démarrage de la ROM, avec la disquette, la Boing Ball et le copyright Hyperion 2018.

    Après d’autres recherches, il semble que la Furia est une carte capricieuse qui n’accepte que certaines CF suffisamment rapides. Conseillé par Amigastore.eu, je commande le bon modèle de CF, une Sandisk Ultra 30MB/s de 8Go. À ma grande déception, ça ne fonctionne pas mieux, j’ai exactement le même résultat : début de démarrage, blocage sur le voyant disque dur allumé, écran noir.

    Après encore davantage de recherches, il apparaît qu’utiliser des Compact Flash avec une carte Furia est de toute façon trop hasardeux : mieux vaut utiliser un adaptateur IDE2SD, passer aux cartes SD et c’est la fin des ennuis. Tous ceux ayant eu des problèmes avec leur Furia et les Compact Flash ont fait ça, et en ont été ravis.

    Soit. Donc je commande une carte SD et un IDE2SD, que je reçois environ 10 jours plus tard. Devinez quoi ? Ça ne démarre toujours pas.

    En désespoir de cause, je tente de réinstaller la ROM d’origine (2.05) et un Workbench 2.11, au cas où la 3.1.4 serait la source de mes ennuis. Pas mieux. La Furia semble reconnue et fonctionnelle, mais il n’y a absolument aucun moyen de démarrer sur le port IDE quand je l’utilise. Si je retire la Furia, pourtant, le port IDE fonctionne très bien et je peux démarrer sans souci.

     

    3) Conclusion et bonus

    À ce stade, je vous avoue que je suis perplexe, contrarié et pour tout dire, déçu. J’ai dépensé largement plus de 400€ dans cet Amiga et rien ne fonctionne comme ça devrait. Absolument tout ce qui pouvait aller de travers a mal tourné, et pire encore.

    Au mieux, je peux l’utiliser sans la Furia, mais avec ses 2Mo de chipram et sans aucune fastram, presque aucun jeu WHDLoad ne passe. Même Gravity Force finit par planter après le niveau 2. Et je dois me passer de mon joystick, auquel j’avais vraiment pris goût.

    Il y a deux bonus à toute cette histoire, deux ennuis supplémentaires qui sont venus s’ajouter à la liste…

    Le premier bonus, c’est que j’ai commandé des disquettes pour tenter un boot depuis une disquette Workbench, et que le colis est arrivé, et moins de 2 heures plus tard et avant que j’aie pu le récupérer, le bâtiment dans lequel il a été livré était évacué, condamné et placé en quarantaine jusqu’à nouvel ordre pour cause de Covid-19 détecté dans les locaux. J’ignore quand je pourrai retourner récupérer ces disquettes, et vu comme on est partis maintenant, ça pourrait prendre des mois.

    Le deuxième bonus : ce soir, à force d’ouvrir l’Amiga et de retirer le clavier pour accéder à l’intérieur de la bête, j’ai malencontreusement arraché l’un des trois câbles qui alimentent les témoins LED.

    Pourriez-vous m’indiquer où doit se relier le fil rouge ? Je vais le souder, ça semble facile à faire, même pour moi. Mais c’est vraiment la goutte d’eau qui menace de faire déborder le vase de ma patience…

     

    J’avoue que je ne m’attendais pas à autant d’ennuis quand j’ai décidé de m’acheter un vrai Amiga, et si j’avais su, j’en serais peut-être resté au FPGA. :-(



    #83097
    Kathleen
    Kathleen
    • Level 6
    • Messages : 290

    @Kaeril,

    Ben là tu as accumulé tous les problèmes les uns à la suite des autres avec ton A600, c’est bien triste. Ca me conforte encore plus dans mon idée de A600 je laisse tomber et cartes enfichables sur CPU idem.

    En ce qui concerne ton souci, j’en ai parlé à mon ami qui m’a de suite dit en lisant ton post que tu as peut-être (voir probablement) endommagé une soudure et/ou une piste lors de tes essais d’assemblage de la Furia. La CM n’est pas rigide, elle se plie sous une force appliquée dessus ce qui pourrait engendrer ce type de problème.

    J’ai regardé sur le net et ai trouvé plusieurs choses dont ceci qui corrobore ce qu’il dit (maintenant ça peut aussi venir d’autre part mais bon avec ce système je serais pas étonnée qu’il ait raison)

    http://www.lemonamiga.com/forum/viewtopic.php?t=14249&sid=c82f6f8996b0d0044aa62884443961b1

    Pour ton câble, avec la plaque vu du dessus, le rouge va en haut et l’orange en bas comme ceci :

    Par rapport au FPGA, je confirme, depuis que je l’ai, l’Amiga est mis de côté. Au pire tu peux mettre un FPGA dans ton boitier A600 pour bénéficier du clavier d’origine.

    #83115
    demether
    demether
    • Level 4
    • Messages : 106

    T’as vraiment pas eu de bol, je suis dégouté pour toi :-(

     

    J’ai pas de soluce à proposer, t’as déja fait ce que j’aurai fait aussi (changer la cf) et puisqu’elle fonctionne quand t’as pas la furia, c’est pas elle qui est en cause.

     

    Sur la furia, t’as pas des switchs ou autre pins à cavalier ?

    #83135

    paranormal
    • Level 1
    • Messages : 26

    Mais quelle galère ! J’ai plus ou moins le même setup que toi (mais qui fonctionne bien), je te mets une photo détaillée pour que tu vois les différentes version. J’utilise 3.1.4. Image CF faite avec HstWB https://hstwb.firstrealize.com

     

     

     

    #83160
    Kaeril
    Kaeril
    • Level 3
    • Messages : 75

    Merci pour le schéma ! Je vois très bien où c’est. C’est le témoin Power qui ne s’allume plus, c’est juste un peu dommage, mais absolument pas grave. Je vais m’en occuper ce week-end. :good:

    Vous savez ce qu’on dit, la nuit porte conseil. Alors ce matin j’ai repris l’Amiga calmement, et… je n’ai pas entièrement compris ce qui s’est passé, mais il s’est passé un truc.

    Furia et IDE2SD branchés, j’ai tenté à nouveau de démarrer en mode « Disable CPU Caches », mais cette fois j’ai tenté le « Boot without Startup-Sequence ». Et là, il y a eu du nouveau : Guru Meditation, puis… j’atterris sur l’invite AmigaDOS. Je ne sais pas vraiment pourquoi ceci fonctionne alors que je l’avais tenté hier… Toujours est-il que je pousse un énorme soupir de soulagement, car désormais c’est un comportement constant, reproductible à 100% (sans Guru d’ailleurs, allez savoir pourquoi).

    J’ai installé l’utilitaire furiatune au préalable sur la SD, donc je tente un furiatune status pour savoir si la Furia est reconnue. Elle l’est !

    Fébrile, j’entre successivement les commandes suivantes :

    furiatune ide on
    furiatune cache on
    furiatune shadowrom
    furiatune addmem

    Puis furiatune reboot. Et… incroyable, j’arrive sur le Workbench. La carte est bien reconnue, tout est incroyablement réactif dans les menus, et la mémoire supplémentaire est bien présente :

    Ça dépote ! Et tous les jeux WHDLoad que je lui ai envoyé fonctionnent impeccablement.

    J’ai modifié le début de mon startup-sequence pour ne plus avoir à m’occuper de furiatune. Désormais, si j’allume mon Amiga à froid il ne boot pas, mais si je l’allume à froid en maintenant les deux boutons, que je choisis « Disable CPU Cache » puis « Boot » (le boot normal, avec la startup-sequence), tout fonctionne bien. Ce qui correspond exactement au fonctionnement que beaucoup d’autres possesseurs de Furia ont décrit. Légèrement frustrant mais « normal », et puis, entre nous… j’ai déjà eu des PC bien plus longs et pénibles à faire démarrer :lol:

    Voilà, je vais enfin pouvoir souffler et commencer à utiliser cet Amiga pour faire des choses intéressantes et fun avec ! Du ProTracker, du Wordperfect, probablement un peu d’assembleur… Mon envie d’explorer cet univers est toujours intacte !

    À plus long terme, je chercherai sans doute à me trouver une petite TV ou un moniteur pour l’installer sur mon bureau, car ce n’est pas très pratique de le mettre sous ma télé de salon. Puis je changerai probablement de stick, même si en attendant je peux très bien utiliser la manette Megadrive USB. Mais tout ça viendra plus tard… Je vais m’accorder après ce week-end une « pause bidouille » bien méritée !

    @kathleen : Très franchement, après tous ces déboires je ne peux décemment pas te conseiller les cartes enfichables sur CPU, tu imagines bien… Même si à l’arrivée, « quand ça marche c’est génial », on voit bien à quel point c’est soumis aux aléas d’un peu tout et n’importe quoi. C’est bien dommage, parce que je continue d’aimer et défendre le 600 pour toutes ses autres qualités, mais un vrai port Zorro n’aurait pas été du luxe… (Même si je ne vois pas trop comment Commodore aurait pu faire, bon nombre de cartes étant plus grandes que le 600 lui-même !) J’avais envisagé de vider tout l’intérieur de l’Amiga pour y rentrer le FPGA, mais ça aurait été dommage, après avoir sollicité les talents de @halifax , de tout balancer à la fin ! :wacko:

    @paranormal : Super, l’Indivision ECS ! Ça m’a tenté, mais j’ai décidé que je préfère attendre de me retrouver une petite TV ou un moniteur cathodique :good: Est-ce que ta Furia démarre facilement, ou bien comme moi tu dois cocher Disable CPU Caches au premier démarrage à froid ?

    #83161
    demether
    demether
    • Level 4
    • Messages : 106

    Ahhh  ! Je suis content pour toi :good:

    #83206

    paranormal
    • Level 1
    • Messages : 26

    > Est-ce que ta Furia démarre facilement, ou bien comme moi tu dois cocher Disable CPU Caches au premier démarrage à froid ?

     

    Non ça démarre facilement.

    #83276
    Staff
    Mutt2828
    Mutt2828
    • Level 9
    • Messages : 988

    @ Kaeril: Belle ténacité, et beau résultat! :good:

    Content pour toi. Et dommage pour le competition pro usb! Il ne te reste plus qu’a en trouver un vrai en db9! On en trouve encore dans certains boui-boui, cash, ou vide-greniers. Sans parler du bon coin.

    Après peut-être existe-t-il un autre adaptateur?…

    En tout cas tes déboires, auront aussi fait avancer la science (pour cette histoire d’incompatibilité en tout cas).

     

     

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail
8 sujets de 31 à 38 (sur un total de 38)

Vous devez être connecté pour répondre à ce sujet.