Utilisation d’une carte Voodoo3 PCI avec un Médiator.

Forum News Room Actualités Utilisation d’une carte Voodoo3 PCI avec un Médiator.

  • Ce sujet contient 14 réponses, 2 participants et a été mis à jour pour la dernière fois par sink, le il y a 1 mois et 1 semaine.
Affichage de 14 réponses de 1 à 14 (sur un total de 14)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #116213
    Staff
    Zarnal
      • Level 22
      • Messages : 7476

      Quelques précisions :

      • La version 4.5 finale de WinUae n’est pas encore sortie, mais c’est parfaitement fonctionnel avec les Bversions.

       

      • Privilégiez l’OS 3.9 bien plus rapide que le 3.1 sur les très vieilles configurations PC.

       

      Quelques exemples en vidéo depuis un vieux Pc portable Core2Duo de 2007 avec ” superbe ” chipset intel intégré :lol: :

       

      A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



      #116431
      sink
        • Level 2
        • Messages : 51

        génial et passionnant, merci!!! sacré bon travail, t’arrête surtout pas. ;)

        #116664
        Staff
        Zarnal
          • Level 22
          • Messages : 7476

          Pour ceux qui auront le courage de tester :

          n’utilisez pas les versions b18 et  b19 si vous voulez tester avec OS4. Il y a un nouveau problème. Je n’ai pas tenté une nouvelle installation fraiche avec ces deux dernières, je verrai plus tard.

          Cela ne concerne pas OS3 par contre.

          A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

          #141776
          Staff
          Zarnal
            • Level 22
            • Messages : 7476

            Le fonctionnement A4000D/3.2.1/Cyberstorm :

             

            A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

            #150492
            Staff
            Zarnal
              • Level 22
              • Messages : 7476

              Petite info si vous décidez d’installer la version CD de Shogo : installez là manuellement à la console sinon vous risquez de vous retrouver avec un beau plantage. En effet, un bug de QEMU empêche de lancer deux applications PPC à la suite. Exemple avec l’enchainement de deux décompressions distinctes :

               

              Tout se passe normalement.

              Maintenant, si vous lancez une seconde décompression dans la foulée :

               

              Plantage en règle. C’est ce qui bloque l’installation du jeu depuis le CD. Il lance plusieurs fois d’affilée la décompression d’un fichier.

              Le plus curieux est que cela ne plante qu’une fois sur deux. Si vous relancez une troisième fois cela fonctionne et ainsi de suite. En gros, c’est sur la base de ce schèma : Ok —> Plantage —> Ok —> Plantage —> Ok et ainsi de suite.

              Ceci vaut pour la Cyberstorm ou bien la Blizzard PPC.

              Edit : je ferai une fiche dédiée un peu plus tard. Il y a une autre manipulation à faire. Ceci ne concerne que l’OS 3. Aucun souci en OS4.

              A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

              #178998
              sink
                • Level 2
                • Messages : 51

                coucou,

                je me suis lancé dans ton tuto pour tester , je pense que j’ai tout bien fait mais aucune demos ( de la scene) se lance, je suis sous 3.1, j’aurais raté quelque chose? :)

                #179019
                Staff
                Zarnal
                  • Level 22
                  • Messages : 7476

                  Bonjour,

                  probablement car cela devrait fonctionner. :-p

                  Commençons par quelques questions :

                  Les roms PPC et Voodoo 3 sont elles en place et fonctionnelles ?

                  Attention pour la Voodoo3, il faut maintenant aller indiquer son emplacement dans ” Expansion/Graphics Board ” en choisissant Voodoo3 et en indiquant le chemin de la Rom.

                  Mediator est-il bien sur Enabled dans l’onglet Expansion/PCI Bridgeboards ?

                  Warp3D est il installé. De même que les librairies PPC ?

                  A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                  #179027
                  sink
                    • Level 2
                    • Messages : 51

                    alors, j’ai tout repris a zero , j’ai fait une installation fraiche de os4.1 ;)

                    mediator est enable dans winuae.

                    pci.library est bien ds libs:

                    voodoo.rom est bien dans le répertoire kikstarts de winuae (bien pris en compte dans le scan des roms)

                    j’utilise la dernier version de winuae qui vient de sortir aujourd’hui.

                    la voodoo est bien reconue avec une jolie resolution

                    tout a l’air en place sauf quand je lance une demo, j’ai toujours la meme erreur.

                    voir photo :)

                    #179029
                    Staff
                    Zarnal
                      • Level 22
                      • Messages : 7476

                      Ok, c’est sous OS4 et pas sous OS3. Donc :

                      as tu bien installé ReWarp ?

                      Ensuite, pour cette histoire de ” Force Version “, il faudra potentiellement créer une variable d’environnement dans Prefs/Env-Archive/Warp3D ( ou Warp3DPPC je ne sais plus, autant le faire dans les deux répertoires à créer lors de l’installation de Rewarp après la copie des variables de ce dernier  ).

                       

                      A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                      #179064
                      sink
                        • Level 2
                        • Messages : 51

                        alors j’ai bossé l’affaire et je progresse ;)

                        j’ai mis le disque dur en sfs et ca va beaucoup mieux

                        ps:j’utilise winuae que pour de la demos

                        tout fonctionne pas trop mal et vite maintenant grace a ton tuto (merciiiiiiii)

                        juste deux question regarde comment l’image (pas centré) est sur le screenshot, c’est normal?

                        et aussi meme si ca voit pas j’ai des artefact (sorte de trait ) en bas de l’image qui apparaisse comme si ct lié au son, une idée? stp



                        #179082
                        Staff
                        Zarnal
                          • Level 22
                          • Messages : 7476

                          juste deux question regarde comment l’image (pas centré) est sur le screenshot, c’est normal?

                          Non, il doit manquer une résolution dans Prefs/Picasso96Mode. Ajoute un 640*480 et un 320×240 au besoin.

                          et aussi meme si ca voit pas j’ai des artefact (sorte de trait ) en bas de l’image qui apparaisse comme si ct lié au son, une idée? stp

                          Tu peux essayer la VSYNC BeamRacing ou bien le Lagless VSYNC. C’est un souci que l’on avait remarqué lors des tests Bêta de WinUae 4.9. Cela semble lié à l’émulation Voodoo 3 incomplète concernant certaines spécificités sur Amiga et OS4. Shogo aussi est affecté ( la version d’époque, pas la plus récente version d’Hyperion ). A noter qu’il peut y avoir le même souci avec PayBack 68K. A confirmer.

                          A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                          #179092
                          sink
                            • Level 2
                            • Messages : 51

                            genial!!! merci pour l’histoire des résolutions , ca fonctionne parfaitement !!

                            par contre , toujours des glitchs  en bas de l’écran , j’espère une update pour  cette carte, tu as peut etre une idée secondaire a me proposer ou a tester car je n’utilise winuae que pour la demoscene.

                            en tout cas, merci de ton aide et ton excellent tuto!! ;)

                            #179098
                            Staff
                            Zarnal
                              • Level 22
                              • Messages : 7476

                              par contre , toujours des glitchs  en bas de l’écran , j’espère une update pour  cette carte, tu as peut etre une idée secondaire a me proposer ou a tester car je n’utilise winuae que pour la demoscene.

                              Tu peux aussi essayer avec le slider ” Stopped M68K CPU Idle mode ” dans CPU/FPU.

                              Une autre solution serait de passer en Grex ou en Prometheus.

                              Le truc, c’est que l’auteur de WinUae ne souhaite pas s’en méler puisqu’il me semeble que l’émulation Voodoo 3 est récupérée de PCem. Mais surtout, la 3D ne l’intéresse pas. :unsure:   A moins que quelqu’un d’autre ne s’y colle. :unsure:

                              A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                              #179134
                              sink
                                • Level 2
                                • Messages : 51

                                oki merci pour ta reponse mais je m’en doutais un peu par contre certaine demos passent parfaitement de A a Z sans bug.

                                encore merci pour ton tuto qui fonctionne parfaitement!!! j’ai appris plein de trucs

                              Partager sur vos réseaux sociaux préférés :
                              Facebooktwitterredditpinterestlinkedintumblrmail
                              Affichage de 14 réponses de 1 à 14 (sur un total de 14)
                              • Vous devez être connecté pour répondre à ce sujet.