Protracker 68k

Forum Amiga Software Protracker 68k

  • Ce sujet contient 11 réponses, 4 participants et a été mis à jour pour la dernière fois par Jim Neray, le il y a 1 semaine et 1 jour.
  • Créateur
    Sujet
  • #15212
    Staff
    Aladin
    • Level 25
    • Messages : 10337

    Protracker (1990)

    Protracker est dérivé d’Ultimate Soundtracker, le premier logiciel de ce type à avoir été créé et dont le code source a été divulgué par ses concepteurs. La première version, pour l’Amiga, date de 1990 et est l’œuvre d’un groupe intitulé Amiga Freelancers qui distribue le logiciel dans le domaine public ; il est mis à jour plusieurs fois au cours des années suivantes, y compris par d’autres groupes de développeurs.

     

    Protracker v2.3 (1992)

    8bitbubsy vient d’updater Protracker dans sa version 2.3F amiga (correction de bug de la v2.3D)

    http://eab.abime.net/showthread.php?t=81145

    Téléchargement gratuit v2.3Fhttps://16-bits.org/PT23F.LHA (01/2021)

    Configuration requise pour une utilisation agréable:
    – 2 Mo Chip
    – 1 Mo Fast
    – 68020 ou plus

    Téléchargement autres systèmes v2.3D: Win/OSX (2017 v2.3D), AROS (2016 v2.3D), OS4 (2005 v2.3D)

     

    Protracker 3.15 (1993)

    Téléchargement gratuit 3.15 (Fix y2k 2016): Aminet

    Configuration requise: OCS

     

    Protracker 3.62 (2000)

    Télechargement gratuit 3.62 (Fix y2k 2004): Pouet.net

    Configuration requise: 020

     

    Autre version de protracker sur amiga (v1 à v4)Pouet.net / Aminet

    Fasttracker 2 clone: Wikipedia
    Téléchargement autre système: Win/OSX (2017)

    Hively tracker: HDD (OS3-020/MOS/OS4/AROS/WIN/…) / HDD

     

    Source:
    https://16-bits.org/
    Wikipedia

    Retour au sommaire utilitaire

Viewing 11 replies - 1 through 11 (of 11 total)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #15223
    Staff
    Jim Neray
    • Level 21
    • Messages : 6066

    J’ai toujours eu du mal avec l’interface de PT2.x et prédécesseurs. Certainement parce que j’ai commencé avec le 3.15 :scratch:

    A500 - A500 Plus - A600 HD - A1200 - A2000 - A4000T - CD32 - C=64 - 1040STE - CPC6128
    Micromiga.com - Le Webshop Amiga



    #116916
    Staff
    Jim Neray
    • Level 21
    • Messages : 6066

    J’ai un software failure systématique de WBL avec Protracker 3.62 sur un 600 2MB de chip/8MB de fast rom/os 3.1. Si je prend le même disque et que je le plug sur un 1200 tout fonctionne parfaitement. Sauf erreur de ma part l’exe 3.62 est 68000 et devrait donc fonctionner sur mon 600. Si vous avez une idée :scratch:

    A500 - A500 Plus - A600 HD - A1200 - A2000 - A4000T - CD32 - C=64 - 1040STE - CPC6128
    Micromiga.com - Le Webshop Amiga

    #116921
    Staff
    Zarnal
    • Level 19
    • Messages : 4747

    J’arrive à reproduire le plantage sous WinUae.

    J’ai isolé, c’est un souci CPU.

    Un A600 au 000 plante.

    Un A600 au 020 est Ok.

    Je vais aller voir si c’est compacté au cas où. Edit : non.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #116923
    Staff
    Zarnal
    • Level 19
    • Messages : 4747

    Il y a deux versions distinctes pour la 3.61 par exemple.

    Tu es certainement tombé sur la version 020+ de la 3.62.

    Edit : je suis également tombé sur une version 3.62 en 000 mais elle plante systématiquement au lancement.

    Edit 2 : reformulation. :-p

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #116928
    Staff
    Aladin
    • Level 25
    • Messages : 10337

    A priori ce serait la v3.15 maxi pour ton a600

    http://eab.abime.net/showthread.php?t=55426

    Du coup, j’ai mis 020 en configuration minimum pour la 3.62

    La 2.3 est passée en v2.3F version finale (01/2021)

    #116974
    Bruno
    • Level 2
    • Messages : 53

    J’avais fait le même constat concernant le prérequis 68020 de la v3.62 il y a quelques semaines : il refuse de fonctionner sur mon A500 avec ACA500+.
    J’avais testé cette version précisément : http://aminet.net/package/mus/edit/PT362-fix2

    Je me suis aussi rabattu sur la version 3.15-Y2K qui marche bien sur mon A500 avec ACA500+. Toutefois elle a besoin de 1 Mo de fastmem mini en plus de la configuration standard d’un A500 (512 Ko de chip + 512 Ko de slow).

     

    J’ai toujours eu du mal avec l’interface de PT2.x et prédécesseurs. Certainement parce que j’ai commencé avec le 3.15

    Je suis bien d’accord, j’utilise PT uniquement pour écouter des modules et le navigateur de fichier des version 1.x et 2.x n’est vraiment pas pratique comparé à celui de la v3.
    Après pour ce qui est de la composition de musique… n’étant pas musicien, je n’ai pas d’avis !  Et les v2.3 semblent toujours avoir leur aficionados, notamment chez les demomakers.

    #117008
    Staff
    Jim Neray
    • Level 21
    • Messages : 6066

    Edit : je suis également tombé sur une version 3.62 en 000 mais elle plante systématiquement au lancement.

    Oui c’est bien la version 000 que j’utilisais. J’ai essayé PT 3.52 également que j’ai utilisé après le 3.15 et idem.

    Un A600 au 020 est Ok.

    Bon j’aime pas l’émulation mais pour un fast test comme ca il faut avouer que ca permet de vite isoler un soucis :-)

    A priori ce serait la v3.15 maxi pour ton a600

    Oui c’est celle que j’ai réinstallé. Dommage elle est assez buggy. Je ne suis pas certain de voir l’intérêt de compiler les versions plus récentes en 020+.

    Merci pour vos retours en tout cas. :good:

    Après pour ce qui est de la composition de musique… n’étant pas musicien, je n’ai pas d’avis !  Et les v2.3 semblent toujours avoir leur aficionados, notamment chez les demomakers.

    J’imagine que si l’on a commencé sur la version 2.xx et qu’on y a pris ces petites habitudes la 3.xx doit trop modifier l’interface pour une transition en douceur. Et faut avouer que le début de la 3.xx était très très bugué ca n’a pas du aider à la transition.

    A500 - A500 Plus - A600 HD - A1200 - A2000 - A4000T - CD32 - C=64 - 1040STE - CPC6128
    Micromiga.com - Le Webshop Amiga

    #117021
    Staff
    Zarnal
    • Level 19
    • Messages : 4747

    A priori ce serait la v3.15 maxi pour ton a600 http://eab.abime.net/showthread.php?t=55426 Du coup, j’ai mis 020 en configuration minimum pour la 3.62 La 2.3 est passée en v2.3F version finale (01/2021)

    J’ai une 3.61 qui passe en A600. :unsure:

    Sans la correction Y2K.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #117022
    Staff
    Zarnal
    • Level 19
    • Messages : 4747

    Bon j’aime pas l’émulation mais pour un fast test comme ca il faut avouer que ca permet de vite isoler un soucis

    Oui. :-p

    Et de manière très fiable. En tout cas pour les machines OCS/ECS. :unsure:

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

    #117025
    Staff
    Aladin
    • Level 25
    • Messages : 10337

    Je ne suis pas certain de voir l’intérêt de compiler les versions plus récentes en 020+.

    Ben en même temps, en 1993 pour la 3.15 la norme était devenue le 1200. Je ne parle même pas de la 3.62 qui est sortie en 2000.

    Comme pour ceux qui ne jurent que par les machines stocks, le vrai protracker c’est la 2.3 :-p   Et la pas de soucis en 68000.



    #117272
    Staff
    Jim Neray
    • Level 21
    • Messages : 6066

    J’ai une 3.61 qui passe en A600. :unsure: Sans la correction Y2K.

    Ah il faut qeu je re vérifie ca merci pour l’info :good:

    Je ne suis pas certain de voir l’intérêt de compiler les versions plus récentes en 020+.

    Ben en même temps, en 1993 pour la 3.15 la norme était devenue le 1200. Je ne parle même pas de la 3.62 qui est sortie en 2000. Comme pour ceux qui ne jurent que par les machines stocks, le vrai protracker c’est la 2.3 :-p Et la pas de soucis en 68000.

    Je ne vois toujours pas pour autant l’intérêt de compiler en 020+ ce qui peut l’être en 000. De toute évidence il y a un loupé quelque part. Si les archives contiennent des versions 000 le but devait bien être de le compiler en 68000.

    A500 - A500 Plus - A600 HD - A1200 - A2000 - A4000T - CD32 - C=64 - 1040STE - CPC6128
    Micromiga.com - Le Webshop Amiga

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail
Viewing 11 replies - 1 through 11 (of 11 total)
  • Vous devez être connecté pour répondre à ce sujet.