Ecrire fichier HDF sur une CF vierge à partir du PC sur WinUAE

Forum Autour de l’Amiga Amiga OS 4 – MorphOS – UAE – AROS Ecrire fichier HDF sur une CF vierge à partir du PC sur WinUAE

  • Ce sujet contient 26 réponses, 4 participants et a été mis à jour pour la dernière fois par Tim, le il y a 10 mois.
  • Créateur
    Sujet
  • #138962
    Tim
    • Level 4
    • Messages : 112

    Bonjour à tous.

    Alors oui le titre peut faire sourire mais bien que j’ai vu quelques explications sur le net un peu datées il me semble, j’aimerais savoir s’il il existe une solution simple en 2022 ? car l’Amiga c’est bien mais ça me gave de passer des heures à faire une opération qui peut peut-être ne pas en prendre autant. Donc dans les détails , les amis, j’ai une CF de 8go et j’aimerais écrire dessus la compil MEGA AGS qui est un fichier HDF. Par la suite pour ne pas refaire tout le bazar, j’aimerais pouvoir lire cette CF 8go de mon AMIGA sur Winuae et transférer des mises à jour de jeux par exemple. Oui je sait j’en demande beaucoup… :mail:

    Si toutefois quelqu’un pouvait me répondre, je le ou la remercie déjà :heart:

     

    Amiga 1200 / AmigaOS 3.1.4.1 KS 46.143 / ACA 1233n / HxC
    C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
    ATARI 1040STE = Au placard, => MiSTer FPGA Powa !
    Amstrad CPC6128 = Au placard => MiSTer FPGA Powa !

Affichage de 11 réponses de 16 à 26 (sur un total de 26)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #139062
    Tim
    • Level 4
    • Messages : 112

      La source du MEGA AGS:

      https://archive.org/details/megaags

       

      Sinon je viens de booter avec ma CF sur mon vrai amiga et là il commence à booter et il me sort please insert a volume  containing LIBS\icon.library….???

      Alors que les fichiers existent bien dans LIBS.

      Sinon j’ai booté sur la disquette de zarnal et je vois bien mes 3 partitions nickel et les données à l’intérieur.

      Pourtant ce clone il fonctionne bien sur WinUAE.

      Bon déjà j’ai pas un failure software c’est déjà ça.

      J’ai édité la startup sequence mais je vois pas ce qu’il manque.

      Dans le genre j’ai rajouté un assign LIBS: SYS:libs mais bon je suis pas expert dans les scripts. :mail:

      Et bien sûr ca fait toujours le même soucis en rebootant.

       

      Amiga 1200 / AmigaOS 3.1.4.1 KS 46.143 / ACA 1233n / HxC
      C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
      ATARI 1040STE = Au placard, => MiSTer FPGA Powa !
      Amstrad CPC6128 = Au placard => MiSTer FPGA Powa !



      #139068
      Staff
      Zarnal
      • Level 21
      • Messages : 6824

        Sinon je viens de booter avec ma CF sur mon vrai amiga et là il commence à booter et il me sort please insert a volume containing LIBS\icon.library….???

        C’est quel WB qui est installé ( 3.1, 3.5,3.9,3.2 ) ?

        Quelle version de icon.library ? Tu peux le savoir en tapant  » version icon.library « .

        Quelle est la config de ta vraie machine, la rom physique ?

         

         

        A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

        #139069
        Staff
        Zarnal
        • Level 21
        • Messages : 6824

          Comme c’est un clone j’ai l’assurance qu’il fonctionne sur un amiga réel du coup ? Ben pas forcément en fait, car si l’image MEGA AGS en HDF a été faite avec une device UAE, là je l’ai dans le baba, obligé de passer par la case « je refait tout »… En effet ma tooltype pour hdtoolbox est scsi.device.

          Pas du tout, bien au contraire. Sorti de l’émulation cela n’a rien à voir.

          L’IDE interne d’une vraie machine utilise le scsi.device qui n’a rien à voir avec l’uaehf.device utilisé par l’émulateur pour créer ses fichiers HD.

          Sur une vraie machine par contre, tu peux monter un hdf sur le même principe qu’un adf.

           

          A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

          #139078
          stephbb75
          • Level 7
          • Messages : 515

            Salut @Tim,

            Je vais reprendre ;-)

            Fait ta config, pour un 1200 tu a juste a choisir le CPU.
            Chipset choisi AGA, Rom tu met ta ROM (version 3.0,3.1,…), Ram tu met la rame que tu as. Dans Expentions tu met si tu a une carte accel mais touche pas au reste.

            Si tu préparé ta carte sur un vrais Amiga, rien d’autre a faire que de mettre le bon disque.
            Ne change pas UAE (uaehf.device) !!!!!
            WinUae trouveras tous seul la partition bootable, quelques soit le système de fichier car c’est marqué au début de ton disque (carte).

            Si tu veut faire quelque choses sur le vrais disque (carte) depuis WinUae il faut simplement changer dans l’info de l’icon scsi.device par uaehf.device (tu met scsi.device entre parenthèses, comme cela il ne le prend plus en compte, et quand tu revient sur ton Amiga, tu retire les parenthèses et les met sur uaehf.device)

            Par contre, je te conseil de ne pas faire d’action sur un vrais disque Amiga depuis WinUae (partition, formatage, change le fils système, ….) sans maitriser un minimum, sinon tu vas passer un sacré bout de temps a recommencer plusieurs fois cas la moindre erreur de manip et cela ne fonctionne plus sur un vrais Amiga (voire même UAE!).

            J’ai passé un sacré bout de temps a maitriser un peut le truc, cois moi !
            Maintenant j’arrive a monter de vrais DD, carte SD, CF, … du monde Amiga avec WinUae, mais j’en est fait des conneries avant !!!!

            Petite info, si tu passe par un lecteur de carte sur USB, certain modèle ne fonctionnerons pas (je ne sais pas trop pourquoi)  et d’autre oui.
            Il faut mieux un lecteur de carte branché sur un port USB directement sur la carte du PC.

            Steph

            https://youtube.com/@stephbb75

            #139079
            Tim
            • Level 4
            • Messages : 112

              En fait, j’ai finalement laisser tomber pour le moment car comme tes questions le suggérait  Zarnal, j’ai des roms différentes. Je suis en 3.2 actuellement et le MegaAGS a été fait en 3.1.

              j’ai installé le wb 3.2 dessus le 3.1 mais j’avais encore des trucs bizarre dans les menus qui ne fonctionnaient pas, bref, comme ça me fatigue un peu, j’ai remis ma CF avec mon système que j’ai installé à l’ancienne et moi même à la base et je verrais plus tard pour retester, je dirais même surtout quand j’aurais l’extension CF interne à l’arrière de ma bécane, ce qui évitera de démonter à chaque fois. En tout cas Merci encore à vous 2, ça m’a remis un peu dans l’Amiga tout ça et ça a mis le doigt là où je me souvenais absolument pas des démarches à faire. :good:

               

              @stephbb75

              Ok je note ;-)

              Amiga 1200 / AmigaOS 3.1.4.1 KS 46.143 / ACA 1233n / HxC
              C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
              ATARI 1040STE = Au placard, => MiSTer FPGA Powa !
              Amstrad CPC6128 = Au placard => MiSTer FPGA Powa !

              #139096
              Staff
              Zarnal
              • Level 21
              • Messages : 6824

                j’ai installé le wb 3.2 dessus le 3.1 mais j’avais encore des trucs bizarre dans les menus qui ne fonctionnaient pas

                Normal si tu n’as pas ajusté la startup et l’user startup après coup.

                 

                A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                #139110
                Staff
                Zarnal
                • Level 21
                • Messages : 6824

                  Je viens d’essayer. Cela fonctionne. Inutile d’installer le 3.2 par dessus. Et là, plus de soucis avec la startup.

                  Il faut juste copier  » icon.library  » ainsi que  » Workbench.library  » de la disquette  » Modules A1200  » du 3.2 dans le répertoire Libs de MegaAgs.

                  Ensuite, tu édites la startup en ajoutant  » Assign ENV: Ram:  » dans la startup.  Rien de plus. Nul besoin d’une installation complète ( qui, au passage te bousille la startup d’origine entre autres choses ).

                   

                  A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                  #139211
                  Staff
                  Zarnal
                  • Level 21
                  • Messages : 6824

                    Oublie tout. Je viens de me rendre compte que ce n’était pas la même version que j’utilisais. :wacko:

                    Je viens de télécharger ( trèèèès lentement ) la version du 3 mars à l’aide de ton lien et il s’avère que la simple copie des deux libs suffit.

                    Maintenant,  je vais voir plus en profondeur pour les menus. Cela pourra être utile au besoin. Ils restent inactifs en 3.2. Ainsi que les icônes à droite.

                    Edit : en fait, c’est lorsque tu essayes de lancer un élément du menu que tout se freeze au niveau des icônes ( hormis le pointeur de la souris ).

                    :unsure:

                     

                     

                     

                    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                    #139219
                    Staff
                    Zarnal
                    • Level 21
                    • Messages : 6824

                      Il y a un virus ( Amiga ) Happy New Year dans certains exécutables du lien de l’archive ( pas dangereux mais rendant impossible l’application du patch ). Je m’en suis rendu compte en tentant de patcher TD ( ce qui semble être la solution potentielle aux soucis du menu ). Je fais un scan total de l’archive avant de poursuivre.

                      Edit : le souci au niveau des menus est réglé. Pour ceux qui seront intéressés, il faut appliquer le patch 2.2 pour TD ( ici ) pour une compatibilité avec le kickstart 3.2.

                      Attention : l’archive d’origine étant corrompue par HNY, il faudra soit la nettoyer, soit attendre que je fournisse la Dk avec les fichiers patchés.

                       

                      A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                      #139228
                      Staff
                      Zarnal
                      • Level 21
                      • Messages : 6824

                        @Tim

                        Voilà la disquette. Ici.

                        Tu copies son contenu sur la partition  » Amiga  » du HDF de MegaAGS et les menus fonctionneront normalement avec une rom 3.2 physique ( voir posts au dessus ).

                        A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



                        #140992
                        Tim
                        • Level 4
                        • Messages : 112

                          Merci Zarnal.

                          Avec tout ça, j’ai oublié de te remercier encore, je n’avais pas vu les derniers messages avec la disquette ! Cool !

                          De toutes façon dès que je reçois mon extension CF externe je reviens sur le sujet :-)   Parce que je dit souvent que je laisse tomber et en fait je reviens finalement car je peux pas m’en empêcher. je te dirais ça, mon extension est en route et à ce moment là je m’y met je démonte l’Amiga rapido et je test.

                          Amiga 1200 / AmigaOS 3.1.4.1 KS 46.143 / ACA 1233n / HxC
                          C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
                          ATARI 1040STE = Au placard, => MiSTer FPGA Powa !
                          Amstrad CPC6128 = Au placard => MiSTer FPGA Powa !

                        Partager sur vos réseaux sociaux préférés :
                        Facebooktwitterredditpinterestlinkedintumblrmail
                        Affichage de 11 réponses de 16 à 26 (sur un total de 26)
                        • Vous devez être connecté pour répondre à ce sujet.