Ecrire fichier HDF sur une CF vierge à partir du PC sur WinUAE

Forum Autour de l’Amiga Amiga OS 4 – MorphOS – UAE – AROS Ecrire fichier HDF sur une CF vierge à partir du PC sur WinUAE

  • Ce sujet contient 26 réponses, 4 participants et a été mis à jour pour la dernière fois par Tim, le il y a 10 mois.
  • Créateur
    Sujet
  • #138962
    Tim
    • Level 4
    • Messages : 112

    Bonjour à tous.

    Alors oui le titre peut faire sourire mais bien que j’ai vu quelques explications sur le net un peu datées il me semble, j’aimerais savoir s’il il existe une solution simple en 2022 ? car l’Amiga c’est bien mais ça me gave de passer des heures à faire une opération qui peut peut-être ne pas en prendre autant. Donc dans les détails , les amis, j’ai une CF de 8go et j’aimerais écrire dessus la compil MEGA AGS qui est un fichier HDF. Par la suite pour ne pas refaire tout le bazar, j’aimerais pouvoir lire cette CF 8go de mon AMIGA sur Winuae et transférer des mises à jour de jeux par exemple. Oui je sait j’en demande beaucoup… :mail:

    Si toutefois quelqu’un pouvait me répondre, je le ou la remercie déjà :heart:

     

    Amiga 1200 / AmigaOS 3.1.4.1 KS 46.143 / ACA 1233n / HxC
    C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
    ATARI 1040STE = Au placard, => MiSTer FPGA Powa !
    Amstrad CPC6128 = Au placard => MiSTer FPGA Powa !

Affichage de 15 réponses de 1 à 15 (sur un total de 26)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #138969
    Staff
    Zarnal
    • Level 21
    • Messages : 6820

      Bonjour,

      concernant ta carte, tu formates/partitionnes ta CF depuis la machine ou depuis WinUae avec le système de fichiers qui te convient le mieux.

      Ensuite, depuis WinUae, tu lances Directory Opus. Une simple copie des fichiers suffira. Attention dans la config, ne pas activer le JIT car cela bloque parfois au bout d’un moment ( au moins sur ma vieille radouille de portable, je ne sais toujours pas si c’est un souci technique ). Un mode Fastest est idéal.

      Note : cela sera un minimum long quand même, il y a énormément de fichiers. :unsure:

      ADFOPus pourrait être également une solution mais de mon coté il refuse d’ouvrir un device ( même en admin ) bien que la possibilité existe dans le menu. Ou bien j’ai mal interprété.

      Edit : non, cela semble être un souci technique ( ou bien il manque quelque chose ).

      https://sourceforge.net/p/adfopus/bugs/10/

      Edit 2 : il est évoqué une compatibilité 95/98/NT. Ceci explique peut être cela. Sans compter que ce n’est peut être pas compatible en 64 bits ( Win 7+ ).  :scratch:

      A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



      #139010
      stephbb75
      • Level 7
      • Messages : 509

        Salut @Tim,

        Plusieurs solution a ton « problème ».

        Déjà dur Amiga on peut monter un HDF (http://obligement.free.fr/articles/monter_hdf.php) cela fonctionne très bien.

        Sinon, pour copier depuis WinUae c’est possible :

        Il faut l’exécuter en mode administrateur (sinon on peut pas monter une partition réel).
        Tu fait ta config comme pour ton vrais Amiga (Chip, cpu, mémoire, ….).
        Il faut mieux que ta carte soit faite directement sur l’Amiga, plus simple.
        Dans la partie « CD & Hard drive » tu clique sur « Add Hard Drive » et tu choisie ta CF, met la en boot.
        Tu peut ajouter le HDF (add Hardfile) que tu veut copier sans le mettre en boot.

        Tu démarre le tout…..

        Ensuite y’a plus qu’a copier d’un DD à l’autre avec DiskMaster, Directory Opus ou même depuis le WB :-)

        Steph

        https://youtube.com/@stephbb75

        #139012
        Tim
        • Level 4
        • Messages : 112

          Merci pour toutes ces explications :good:

          Alors en fait, j’ai un peu galéré pour partitionner ma CF correctement pour que tout rentre, je me suis fier au nombre de « Blocks » plutôt que l’espace disk fantaisiste.

          J’espère que tout va rentrer, car j’ai mis un peu plus à chaque partitions au nombre de 3. J’ai voulus mettre du PFS3 de type 0x53465305 => « Standard » PFS3. Donc ça c’est bon car je préfère ce format.

          Le Mega AGS étant en kick 3.1 et workbench 3.1 je vais le passer en 3.2 pour plus de stabilité. Et vu que j’ai les roms en dur sur mon Miga1200 car j’ai la licence, ça devrait être bon aussi.

          je me suis commandé une extension externe de ma CF interne pour mon A1200, comme ça je pourrais switcher avec d’autres packs.

          Dire qu’il y en a qui font payer ces trucs là à 40 ou 50 euros sur ebay… Alors que le MegaAGS est gratuit par exemple.

          Bon après c’est la copie qui est longue, c’est sûr que j’aurais préféré quelque chose comme un winimage ou autre mais enfin ça je pourrais le faire après maintenant pour cloner et/ou faire un backup tout simplement.

          Merci à vous 2 :yahoo:

           

          #Zarnal:

          tes tutos que je viens de relire pour certains sont toujours extra et même si c’est un peu technique parfois, il y a de quoi s’en sortir. :mail:

          Dur de s’y remettre sur l’Amiga quand il faut faire des manipulations de ce genre mais bon on est content quand ça marche !

          #stephbb75

          C’est exactement les démarches que j’ai faite du coup ! :good:

           

          Edit: j’ai mis en 68060 en direct live sur winuae, ça fonce bien ! j’espère que ça va pas me faire foirer les copies… :wacko:

          Amiga 1200 / AmigaOS 3.1.4.1 KS 46.143 / ACA 1233n / HxC
          C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
          ATARI 1040STE = Au placard, => MiSTer FPGA Powa !
          Amstrad CPC6128 = Au placard => MiSTer FPGA Powa !

          #139018
          Tim
          • Level 4
          • Messages : 112

            Une autre question, est-ce normal que je peux pas booter sur winuae avec ma CF fraichement réalisée ? ca fait mine de booter puis ça revient au kick avec la disquette.

            J’ai ça dans les propriétés de ma CF:

            Faut-il créer obligatoirement une image disk pour que ça marche ? :scratch:

            Amiga 1200 / AmigaOS 3.1.4.1 KS 46.143 / ACA 1233n / HxC
            C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
            ATARI 1040STE = Au placard, => MiSTer FPGA Powa !
            Amstrad CPC6128 = Au placard => MiSTer FPGA Powa !

            #139022
            Staff
            Zarnal
            • Level 21
            • Messages : 6820

              Une autre question, est-ce normal que je peux pas booter sur winuae avec ma CF fraichement réalisée ? ca fait mine de booter puis ça revient au kick avec la disquette. J’ai ça dans les propriétés de ma CF: Faut-il créer obligatoirement une image disk pour que ça marche ? :scratch:

              Première remarque : tu n’es pas en IDE.

              La 1ère partition est bien <= 2 Go ?

              Lors de ton partitionnement, tu as bien coché  » Bootable pour la première.

              Que dit l’early startup ? Les partitions sont elles reconnues ?

              A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

              #139030
              Tim
              • Level 4
              • Messages : 112

                Alors j’ai mis en IDE et j’ai un gros software failure en rouge avec le cadre rouge qui clignote qu’on aime trop bien !

                Pis t’as raison j’ai oublié de cocher bootable pour la 1er partition qui est de toutes façon inférieur à 2go.

                Sinon ma early startup:

                Et enfin la taille de mon DH0:

                 

                EDIT: y’a pas une histoire où la 1ère partition doit être en FFS plutot que PFS3 ? car c’est comme ça que je suis partitionné sur mon autre image HDF.

                Bon après réflexion, c’est pas ça le problème, j’ai du merder quelque part :negative:

                Amiga 1200 / AmigaOS 3.1.4.1 KS 46.143 / ACA 1233n / HxC
                C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
                ATARI 1040STE = Au placard, => MiSTer FPGA Powa !
                Amstrad CPC6128 = Au placard => MiSTer FPGA Powa !

                #139037
                Staff
                Zarnal
                • Level 21
                • Messages : 6820

                  Alors j’ai mis en IDE et j’ai un gros software failure en rouge avec le cadre rouge qui clignote qu’on aime trop bien !

                  Il faut refaire le partitionnement de la carte en IDE.

                  EDIT: y’a pas une histoire où la 1ère partition doit être en FFS plutot que PFS3 ? car c’est comme ça que je suis partitionné sur mon autre image HDF.

                  Tu gères comme tu veux à ce niveau là. Mais bon ( et cela n’engage que moi ), autant tout formater avec le même système de fichiers ( excepté en cas de nécessité absolue ).

                  A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                  #139039
                  Tim
                  • Level 4
                  • Messages : 112

                    OK, donc j’ai plus qu’à tout recommencer :wacko: depuis le début…

                    EDIT: Quand il est en IDE je peux plus le voir avec hdtoolbox…

                     

                    Amiga 1200 / AmigaOS 3.1.4.1 KS 46.143 / ACA 1233n / HxC
                    C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
                    ATARI 1040STE = Au placard, => MiSTer FPGA Powa !
                    Amstrad CPC6128 = Au placard => MiSTer FPGA Powa !

                    #139042
                    jouet24
                    • Level 5
                    • Messages : 155

                      Salut. Pour faire une copie plus rapide de ton HDF tu peux utiliser « Raspberry Pi imager »:

                      Select OS -> Use Custom -> type de ficheir « All Files (*.*)

                      A600 3.2.1 + HstWB + Chip RAM Expansion + Furia + SD to IDE + Gotek / A1200 3.2.1 + HstWB + ACA 1221ec + SD to IDE + Gotek

                      #139043
                      Staff
                      Zarnal
                      • Level 21
                      • Messages : 6820

                        Il faut que je vérifie un truc sur le ZBD. Ok, j’ai laissé les deux possibilités, ce n’est pas plus mal. Avant, seul le scsi était reconnu pour plus de facilités.

                        Quoi qu’il en soit, comme précisé dans le tuto PFS, il faut absolument se mettre en  IDE 600/1200/4000 si l’on souhaite utiliser la carte sur une vraie machine. ;-)

                        A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.



                        #139044
                        Staff
                        Zarnal
                        • Level 21
                        • Messages : 6820

                          EDIT: Quand il est en IDE je peux plus le voir avec hdtoolbox…

                          Tu as quelle version du ZBD ?

                           

                          A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

                          #139049
                          Tim
                          • Level 4
                          • Messages : 112

                            Salut. Pour faire une copie plus rapide de ton HDF tu peux utiliser « Raspberry Pi imager »: Select OS -> Use Custom -> type de ficheir « All Files (*.*)

                            OK je tente ;)

                             

                            EDIT: Quand il est en IDE je peux plus le voir avec hdtoolbox…

                            Tu as quelle version du ZBD ?

                            Je vais faire mon boulet mais c’est quoi la ZBD ? là je sèche..

                            Amiga 1200 / AmigaOS 3.1.4.1 KS 46.143 / ACA 1233n / HxC
                            C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
                            ATARI 1040STE = Au placard, => MiSTer FPGA Powa !
                            Amstrad CPC6128 = Au placard => MiSTer FPGA Powa !

                            #139050
                            jouet24
                            • Level 5
                            • Messages : 155

                              Je vais faire mon boulet mais c’est quoi la ZBD ? là je sèche..

                              Je vais laisser répondre l’intéressé mais je dirai Zarnal Boot Disk ?

                              Quand il est en IDE je peux plus le voir avec hdtoolbox…

                              C’est pas une histoire de Tool Types de HDToolBox?

                              La ligne SCSI_DEVICE_Name=scsi.device pour un device en IDE ou SCSI_DEVICE_Name=uaehf.device pour un device UAE

                              A600 3.2.1 + HstWB + Chip RAM Expansion + Furia + SD to IDE + Gotek / A1200 3.2.1 + HstWB + ACA 1221ec + SD to IDE + Gotek

                              #139056
                              Tim
                              • Level 4
                              • Messages : 112

                                Zarnal Boot Disk ?

                                Quand il est en IDE je peux plus le voir avec hdtoolbox…

                                C’est pas une histoire de Tool Types de HDToolBox? La ligne SCSI_DEVICE_Name=scsi.device pour un device en IDE ou SCSI_DEVICE_Name=uaehf.device pour un device UAE

                                 

                                Alors, en fait ton clone avec l’outil du raspberry à fonctionné pour un HDF ! nickel ça car avec les winimage ou autre marche pas.

                                Donc déjà merci pour ça.

                                Sinon juste pour comprendre, pour faire fonctionner sur winuae j’ai mis la carte en UAE(uaehf.device) car en IDE: écran noir.

                                Comme c’est un clone j’ai l’assurance qu’il fonctionne sur un amiga réel du coup ?

                                Ben pas forcément en fait, car si l’image MEGA AGS en HDF a été faite avec une device UAE, là je l’ai dans le baba, obligé de passer par la case « je refait tout »…

                                En effet ma tooltype pour hdtoolbox est scsi.device.

                                 

                                Amiga 1200 / AmigaOS 3.1.4.1 KS 46.143 / ACA 1233n / HxC
                                C64 Reloaded / 1541 Ultimate 2+ / JiffyDos / SIDFX
                                ATARI 1040STE = Au placard, => MiSTer FPGA Powa !
                                Amstrad CPC6128 = Au placard => MiSTer FPGA Powa !

                                #139061
                                jouet24
                                • Level 5
                                • Messages : 155

                                  Comme c’est un clone j’ai l’assurance qu’il fonctionne sur un amiga réel du coup ? Ben pas forcément en fait, car si l’image MEGA AGS en HDF a été faite avec une device UAE, là je l’ai dans le baba, obligé de passer par la case « je refait tout »… En effet ma tooltype pour hdtoolbox est scsi.device.

                                  Alors là il faudra l’avis d’experts…

                                  De mon expérience je n’ai pas de problème (jusqu’a présent) a prendre ma SDcard de mon A1200 et la monter sur WinUAE et inversement (sachant que j’ai fait le setup d’un HDF sur Winuae puis flashé sur une sdcard).

                                  Je loupe peu etre un truc alors je vais cogiter dans mon coin car je n’ai pas encore cerné le probleme UAE/IDE. J’ai peu etre mal compris quelque chose. Ou puis je trouver les sources de MEGA AGS? je ferai bien un test de mon côté.

                                  Ci dessous la conf de mon « Disque Dur »

                                  Partitioning:

                                  File System Characteristics:

                                   

                                  A600 3.2.1 + HstWB + Chip RAM Expansion + Furia + SD to IDE + Gotek / A1200 3.2.1 + HstWB + ACA 1221ec + SD to IDE + Gotek

                                Partager sur vos réseaux sociaux préférés :
                                Facebooktwitterredditpinterestlinkedintumblrmail
                                Affichage de 15 réponses de 1 à 15 (sur un total de 26)
                                • Vous devez être connecté pour répondre à ce sujet.