Tutoriel – Installer et configurer Amiga Boot Selector 2

Forum News Room Actualités Tutoriel – Installer et configurer Amiga Boot Selector 2

  • Ce sujet contient 15 réponses, 7 participants et a été mis à jour pour la dernière fois par lolof, le il y a 1 mois et 4 semaines.
  • Créateur
    Sujet
  • #13089
    Amiga FranceAmiga France

      FreeMint amiga VampireAmiga Boot Selector est un outil vous permettant de choisir entre plusieurs startup-sequence au démarrage de votre Amiga. Cette nouvelle version développée par Michael Gibs et publiée cette année apporte son lot de nouveautés. Zarnal vous propose ici un tutoriel pas à pas pour vous guider dans l’installation, le paramétrage et l’utilisation de cet outil indispensable.

       

      Mise en garde : Si vous êtes sous Winuae pour préparer, veillez à ne pas utiliser le clavier comme joystick sinon les touches de directions ne fonctionneront pas dans Amiga Boot Selector v2.

       

      Procédure d’installation :

      Etape 1 :

      Bootez depuis votre disque dur principal sur votre Workbench.

      Copiez le fichier abs de l’archive dans le répertoire DH0:c (partition principale).

      Ouvrez votre répertoire DH0:c et double cliquez sur abs, attendez quelques secondes, le programme va revenir de lui même au Workbench. Un dossier AmigaBootSelector va alors se créer automatiquement dans votre DH0:s. Attention de bien avoir sélectionné au préalable dans le menu « Fenêtre » du Workbench l’option « Montrer tous les fichiers ».

      Ouvrez ce répertoire (DH0:s/AmigaBootSelector). Vous remarquerez divers fichiers.

       

      Etape 2 :

      Dans un premier temps, faites une copie du fichier DH0:s/startup-sequence dans le Ram Disk.

      Cliquez sur le fichier dans le Ram Disk puis allez sur « renommer » dans le menu Icônes puis renommez le en Startup-Sequence.bak. Recopiez le fichier ainsi renommé dans le dossier DH0:s. Vous aurez alors une copie de sauvegarde en cas de problèmes.

      Vous pouvez également utiliser un gestionnaire de fichiers pour effectuer cette opération plus rapidement. Directory Opus semble être un bon choix.

       

      Etape 3 :

      Sous le Workbench ouvrez « Fichier/Executer une commande ». Tapez ed puis appuyez sur entrée.

      Dans l’éditeur, tapez les commandes suivantes :

      abs
      Execute s:AmigaBootSelector/Boot.ABS

      Lorsque cette étape est franchie, sauvegardez le fichier en tant que DH0:s/Startup-Sequence.

      Rappel : Vous avez une sauvegarde au cas où de votre Startup-Sequence originale.

      Quittez l’éditeur.

       

      Etape 4 :

      Faites une copie de votre Startup-Sequence.bak présente dans Ram Disk: vers DH0:s/AmigaBootSelector.

      Effacez le fichier 01 initial dans DH0: s/AmigaBootSelector.

      Renommez le fichier Startup-Sequence.bak en 01.

      Rebootez votre Amiga.

      Une fois votre Amiga relancé, vous arrivez sous Amiga Boot Selector. Appuyez sur espace pour nommer votre premier choix.

      Repartez sous le Workbench pour éditer les choix suivants (dans le dossier DH0:s/AmigaBootSelector, Editez 02, 03, … soit comme pour votre 01 si vos diverses Startup-Sequences sont déjà prêtes, soit en éditant directement 02, 03, …).

      Redémarrez.

      Une fois revenu sous Amiga Boot Selector, sélectionnez la seconde ligne puis appuyez sur espace pour nommer votre label suivant (vous mettrez le nom de votre choix).

      Réitérez l’opération au besoin avec vos autres startups (troisième ligne puis espace pour 03 et ainsi de suite).

       

      Exemple pour l’amiga OS 3.9 ou tout autre système :

      Nous supposons bien entendu que ce dernier est déja installé sur l’une de vos partitions.
      Pour commencer, il faut regarder sur quelle partition DHx (DH0:, DH1:, …) se trouve votre OS.

      Nous allons maintenant éditer le label comme expliqué plus haut dans cette doc. Pour l’exemple, nous partirons du principe que l’OS 3.9 est sur DH2: (mais il peut également s’agir d’un WB 3.1). Nous utiliserons le label 3 (s/AmigaBootSelector/03).

      Il faudra donc éditer de la sorte pour que tout se passe correctement :

      DH2:C/Assign SYS: DH2:
      SYS:C/Assign C: SYS:C
      Assign Devs: SYS:Devs
      Assign Fonts: SYS:Fonts
      Assign L: SYS:L
      Assign Libs: SYS:Libs
      Assign S: SYS:S
      CD SYS:
      Execute S:Startup-Sequence

      Ces commandes sont indispensables si vous ne voulez pas vous retrouver avec des systèmes « mélangés » . Voici donc ce que vous devriez avoir :

      OS 3.9 une fois booté :

      Je vous conseille vivement d’utiliser le label 1 (01) pour l’OS 3.9 si vous utilisez ce dernier. Pourquoi ?

      Tout simplement parce que ce dernier exige un reboot avant de démarrer. Cela vous évitera de devoir le sélectionner une seconde fois lors du redémarrage.

       

      Liens :

       

      Zarnal

      Vous aimez Amiga France ? Alors aidez nous en partageant et en participant au forum. =)

    15 réponses de 1 à 15 (sur un total de 15)

    Partager sur vos réseaux sociaux préférés :
    Facebooktwitterredditpinterestlinkedintumblrmail

    • Auteur
      Réponses
    • #13229
      Staff
      JimJim
      • Level 20
      • Messages : 5061

      Gros bravo et merci à Zarnal pour son boulot sur ce tuto  :good:

      A500 - A500 Plus - A600 HD - A1200 - A2000 - A4000T - CD32 - C=64 - 1040STE - CPC6128
      Micromiga.com - Le Webshop Amiga



      #44481
      Staff
      ZarnalZarnal
      • Level 17
      • Messages : 3791

      :-p

      A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

      #60513
      Thor1230
      • Level 1
      • Messages : 10

      Super Tuto Zarnal. Tres bon taff  de la part de Michael Gibs

      Ca claque sur mes amiga.

      Quelqu’un aurait un Tuto pour émuler un vieux MAC et pour faire fonctionner le TOS avec quelques logiciels ?

      #60560
      Staff
      ZarnalZarnal
      • Level 17
      • Messages : 3791

      J’avais fait un vieux truc généraliste que je ne retrouve plus. Mais pas de spécifique.

      Jim ? Je l’ai certainement effacé de manière peu diplomatique à une époque (émulation mac les balbutiements).

      Après je peux en faire un. Fusion ou Shapeshifter. Après, le vrai souci est que le site ne peut rien fournir en rom ou en OS… :unsure:

       

      A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

      #60596
      halifaxhalifax
      • Level 7
      • Messages : 526

      Cool , merci Zarnal et Gibs, ça fait un moment que je voulais me pencher la dessus :good:

      http://www.steel-alive.fr

      https://www.youtube.com/channel/UC4jetvuTec1IT5ugFbwl2lA?view_as=subscriber

      https://www.facebook.com/steel.alive.31

      #60604
      morningstar24
      • Level 0 - Newbie
      • Messages : 8

      Excellent tuto merci infiniment
      J’espère pouvoir y arriver parce que je suis un vrai boulet

      #60649
      Staff
      JimJim
      • Level 20
      • Messages : 5061

      Jim ? Je l’ai certainement effacé de manière peu diplomatique à une époque (émulation mac les balbutiements).

      Pas effacé non il est par là

      Après ca mériterait très certainement d’être basculé en article (et ca lui donnerait une autre visibilité que perdu dans les méandres du forum … Même toi tu ne remettais pas la main dessus :-p )

      A500 - A500 Plus - A600 HD - A1200 - A2000 - A4000T - CD32 - C=64 - 1040STE - CPC6128
      Micromiga.com - Le Webshop Amiga

      #83937
      lolof
      • Level 4
      • Messages : 103

      Merci pour le tuto.  :good:

      Je dois faire une connerie car dès l’étape 1, lorsque je copie le fichier abs de l’archive dan c: et que je l’exécute, l’interface ce lance bien et quitte après quelques secondes mais tous les fichiers indiqués dans le TUTO ne sont pas présent dans S:AmigaBootSelector.

      Il manque 01, 02,… Ainsi que Boot.ABS

      Et sans ces fichiers cela ne fonctionne pas chez moi :-(

      J’ai téléchargé la dernière version d’aminet…

      Merci pour votre aide.

       

      #83939
      Staff
      ZarnalZarnal
      • Level 17
      • Messages : 3791

      Merci pour le tuto. :good: Je dois faire une connerie car dès l’étape 1, lorsque je copie le fichier abs de l’archive dan c: et que je l’exécute, l’interface ce lance bien et quitte après quelques secondes mais tous les fichiers indiqués dans le TUTO ne sont pas présent dans S:AmigaBootSelector. Il manque 01, 02,… Ainsi que Boot.ABS Et sans ces fichiers cela ne fonctionne pas chez moi :-( J’ai téléchargé la dernière version d’aminet… Merci pour votre aide.[/quote[quote quote=83937]Merci pour le tuto. :good: Je dois faire une connerie car dès l’étape 1, lorsque je copie le fichier abs de l’archive dan c: et que je l’exécute, l’interface ce lance bien et quitte après quelques secondes mais tous les fichiers indiqués dans le TUTO ne sont pas présent dans S:AmigaBootSelector. Il manque 01, 02,… Ainsi que Boot.ABS Et sans ces fichiers cela ne fonctionne pas chez moi :-( J’ai téléchargé la dernière version d’aminet… Merci pour votre aide.

      Tu as bien sélectionné  » Montrer tous les fichiers  » dans le menu du fenêtre du WB ?

      A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

      #83949
      lolof
      • Level 4
      • Messages : 103

      oui oui.

      Seul labels et timer sont créé…..



      #83957
      Staff
      ZarnalZarnal
      • Level 17
      • Messages : 3791

      Je suis en train de retester. Je poste la vidéo dès que j’ai terminé.

      A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

      #83958
      lolof
      • Level 4
      • Messages : 103

      Merci beaucoup.

      J’ai de mon côté refais la manip 3 fois. Même résultat…..

      Je ne pense pas faire une mauvaise manip. Il n’y a qu’à copier abs vers C: et le démarrer normalement… Je fais ça sous le CWB FULL  3.1, dans l’émulateur sur un dump de ma CF (hardfile).

       

      #83960
      Staff
      ZarnalZarnal
      • Level 17
      • Messages : 3791

      Tu as bien pris la version donnée à la fin du tuto ? C’est celle qui est dans les liens à la fin du tuto. Je crois que celle d’Aminet n’est pas à jour ( à l’époque où j’ai crée ce tutoriel c’était le cas ).

      Je redonne le lien au cas où :

      abs

      De mon coté, sur une installation fraiche du WB, tout est ok :

       

      A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - A1200 ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae. CPC 6128-CPC 464.

      #83965
      lolof
      • Level 4
      • Messages : 103

      C’est peut-être bien le problème alors. J’ai utilisé la version d’aminet de 2019.

      Je test avec ton archive. Merci.

      #83972
      lolof
      • Level 4
      • Messages : 103

      Avec ton dms, ça fonctionne. merci beaucoup :-)

      C’est vraiment dommage que la version fonctionnel n’est pas sur aminet.

      C’est le 1er réflex, télécharger la dernière version là-bas…

      Dans le TUTO, il faut bien mettre dans la Startup-Sequence derrière le « execute » le disque dur CF0 ou HD0…

      « execute CF0:s/AmigabootSelector/Boot.ABS » dans mon cas.

      execute s:AmigabootSelector/Boot.ABS comme indiqué dans le tuto renvoie sur le shell et non l’OS car Boot.ABS n’est pas trouvé probablement.

      Merci beaucoup pour le tuto. C’est du top nickel. Mon CD32 + TF330 est déjà content.

      Maintenant, je passe au tuto suivant pour compléter l’affaire : Tiny Launsher :-)

       

       

    Partager sur vos réseaux sociaux préférés :
    Facebooktwitterredditpinterestlinkedintumblrmail
    15 réponses de 1 à 15 (sur un total de 15)

    Vous devez être connecté pour répondre à ce sujet.