PiStorm (RPI dans le socket du 68000)

Forum News Room Actualités PiStorm (RPI dans le socket du 68000)

  • Ce sujet contient 95 réponses, 17 participants et a été mis à jour pour la dernière fois par Belfedia, le il y a 1 mois et 3 semaines.
15 réponses de 61 à 75 (sur un total de 95)

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail

  • Auteur
    Réponses
  • #128394
    jean3.5
    • Level 8
    • Messages : 609

    Quel commande il faut utiliser avec a314 ?
    je n’ai pas encore compris comment utiliser a314



    #128406
    jean3.5
    • Level 8
    • Messages : 609

    j’ai posé la question sur le discord et il faut entrer ça dans le fichier default.cfg :

    « enable_rtc_emulation 0 »

    :-)

    #128409
    jean3.5
    • Level 8
    • Messages : 609

    Voici une liste non exhaustive faite par une personne concernant la compatibilité du PiStorm actuellement. Ça donne une idée de ce qui fonctionne ou pas.

    #131356
    Belfedia
    • Level 3
    • Messages : 98

    Quelques nouvelles du pistorm : Emu68k

    Avec le nouveau core emu68k, on a un 68040, regardez les mips !
    Une émulation RTG, 128mo de fast et un disque dur sur SD.
    Actuellement ils mettent la dernière touche à la vitesse du disque dur et de l’émulation du FPU.
    Tout ça avec 2 ou 3 secondes de boot sur le kickstart de son choix.
    Plus de raspberry-pi-os, tout est en baremétal.

    #131357
    stephbb75
    • Level 4
    • Messages : 141

    Salut,

    Avec le nouveau core emu68k, on a un 68040, regardez les mips !

    Oui c’est Rapide, MAIS !

    En fait c’est pas vraiment l’émulation d’un 040, c’est juste la base.
    C’est encore en dev, béta même !
    Ils viennent de changer le code pour la lecture de la carte SD, et pour le moment … en test et des bugs ;-)
    Le FPU c’est vraiment pas pour tout de suite ;-)
    Il faut déjà qu’ils stabilise le CPU….
    Donc cela fonctionne, c’est rapide, mais pas encore stable, il faut garder à l’esprit que c’est encore en dev.

    #131378
    Belfedia
    • Level 3
    • Messages : 98

    Ce sera tjrs en dev ;)

    #131388
    stephbb75
    • Level 4
    • Messages : 141

    Salut

    Ce sera tjrs en dev ;)

    A un moment se seras plus stable, en fait c’est déjà stable, c’est simplement des amélioration, correction, …

    Je vient de tester la nouvelle version pour la carte SD, c’est plus stable, pas eu de plantage qui rendais la partition HS :-)
    Plus rapide ? oui mais pas fait de vrais test de vitesse …

     

     

    #131397
    jean3.5
    • Level 8
    • Messages : 609

    Y a un truc que je comprend pas pour créer un disque dur.

    En suivant ce tuto, je comprend qu’il faut juste copier les derniers fichiers à jours sur une carte sd. (vraiment plus simple que Musashi)

    Jusque là , j’ai pu testé Emu68 que des jeux disquettes.

    Aujourd’hui, j’ai essayé d’installer un disque dur virtuel sur la carte sd car je viens de comprendre qu’il faut mettre « brcm-sdhc.device » à la place de scsi.device dans les informations de l’icône de hdtoolbox. Mais ça m’a formater entièrement la carte sd et l’amiga ne redémarre pas.

    Qu’est-ce que j’ai louper ? :wacko:

    #131419
    stephbb75
    • Level 4
    • Messages : 141

    Salut @jean3.5

    Tout est expliqué la : https://github.com/michalsc/Emu68/tree/master/docs

    Rapide, tu partitionne ta carte SD (1e rpartition 250Mo fat32 pour Emu68) puis ensuite tu fait autant de partition que tu veut pour l’Amiga (mais il faut utiliser diskpart pour le faire).

    Ensuite 2 solution, tu fait sur Amiga ou sur PC avec WinUae (moi j’ai fait avec WinUae).
    Tu met ta carte SD dans le PC, tu exécute WinUae en mode Administrateur (obligatoire, sinon il ne pourras pas accéder au disque réel !), dans une config qui existe déjà avec un DD Amiga (cela est plus simple), qu’il soit en hdf, répertoire peut importe tu ajout la(les) partition(s) de la carte SD.
    Sous HDToolBox (pas besoin de changer dans se cas le device) tu prépare ta partition, puis tu format, …

    Dans HDToolBox, il NE FAUT PAS PRENDRE le 1er disque trouvé,il correspond a la carte SD entière !!!!!! il faut prendre les suivant…

    ET formaté.

    Je te conseil d’attendre 1 ou 2 jour, ils vont mette dans les compil de nuit la dernière version pour la gestion des carte SD sur le PI, qui est plus stable, évite de cracher les partitions et permet d’utiliser autre chose que FFS.

    comprendre qu’il faut mettre « brcm-sdhc.device » à la place de scsi.device dans les informations de l’icône de hdtoolbox. Mais ça m’a formater entièrement la carte sd et l’amiga ne redémarre pas.

    C’est parce que tu a pris le 1er disque dans la liste, qui correspond a la carte SD entière, faut pas y toucher ;-)

    #131431
    jean3.5
    • Level 8
    • Messages : 609

    Merci Stephbb75 pour ton explication  ! enfin une explication en francais :good:

    J’aurai toujours du mal avec le site Github… je m’y  perd et abondonne souvent mes recherches. :scratch:

    Je vais essayer ça ce soir :-)



    #131444
    stephbb75
    • Level 4
    • Messages : 141

    Merci Stephbb75 pour ton explication ! enfin une explication en francais

    De rien, j’ai bien galéré moi aussi au début … :yahoo:

    J’aurai toujours du mal avec le site Github… je m’y perd et abondonne souvent mes recherches.

    Oui on arrive vite à s’y paumer, mais quand tu insiste un peut tu fini par comprendre le truc.
    Mais pas possible de l’expliquer :rant:

    #131460
    jean3.5
    • Level 8
    • Messages : 609

    J’y suis pas arrivé à créer mes disques durs amiga. :cry:

    tu partitionne ta carte SD (1e rpartition 250Mo fat32 pour Emu68) puis ensuite tu fait autant de partition que tu veut pour l’Amiga (mais il faut utiliser diskpart pour le faire).

    J’ai trouvé diskpart un peu compliqué. Du coup j’ai utilisé « gérer/gestion des disques » de windows. Ça fait la même chose ?

    une fois sous winuae, j’ai sélectionné la carte SD en mode IDE(auto) et a l’adresse 0, c’est  bon ?

    mais une fois dans hdtoolbox de la disquette d’installation de WB3.2, après avoir fait « change drive type » pour lire les infos, dans « partition drive » il y a deux partitions de plusieurs giga.
    et si je modifie une partition et que je sauvegarde les infos avant de quitter, la carte n’est plus reconnu sous windows ni sur le pistorm.
    je comprend pas :scratch:

    #131461
    jean3.5
    • Level 8
    • Messages : 609

    a force de tentatives et en redémarrant une énième fois  WinUae (en admin), j’ai pu voir apparaitre distinctement dans « add hard drive » de WinUae, le disque de 250 mo (emu68) et le reste des 8 go de ma carte SD.

    Par contre, impossible de voir la partition dans hdtoolbox :-(

    …Puis après quelques manips, je n’arrive plus à voir ma partition de 250 mo sous winUae. Par contre, j’arrive à nouveau à voir une partition amiga avec hdtoolsbox.

    mais au moment de la sauvegarde, j’ai ce message qui dit que je ne suis pas administrateur, alors que je le suis, normalement. C’est incompréhensible. :wacko:

     

    #131463
    stephbb75
    • Level 4
    • Messages : 141

    Salut @jean3.5

    J’ai trouvé diskpart un peu compliqué. Du coup j’ai utilisé « gérer/gestion des disques » de windows. Ça fait la même chose ?

    Non tu est obligé de l’utiliser pour mettre les partions en mode 76 tu ne peut pas le faire avec le gestionnaire de disque.

    Les partitions Amiga ne sont pas en Fat32 !!!!!!!!!

    #131464
    stephbb75
    • Level 4
    • Messages : 141

    @jean3.5

    mais au moment de la sauvegarde, j’ai ce message qui dit que je ne suis pas administrateur, alors que je le suis, normalement. C’est incompréhensible

    C’est que tu a mal lu les info du disque en le créent dans WinUae, donc il ne peut pas écrire dessus … et en plus elle sont en Fat32, donc il peut vraiment pas, Windows doit lui en empêcher !!!!

Partager sur vos réseaux sociaux préférés :
Facebooktwitterredditpinterestlinkedintumblrmail
15 réponses de 61 à 75 (sur un total de 95)
  • Vous devez être connecté pour répondre à ce sujet.