Bug/glitch tracking WinUae/FPGA/A1200 stock

Forum Amiga Divers Bug/glitch tracking WinUae/FPGA/A1200 stock

Ce sujet a 67 réponses, 4 participants et a été mis à jour par Zarnal Zarnal, il y a 1 semaine et 2 jours.

8 sujets de 61 à 68 (sur un total de 68)

Partager sur vos réseaux sociaux préférés :
Facebooktwittergoogle_plusredditpinterestlinkedintumblrmail

  • Auteur
    Messages
  • #48722
    Staff
    Jim
    Jim
    • 3 587 Messages

    Dik Power. A bitch is a bitch … Ah p*tain les slogans on avait peur de rien à l’époque  :lol:

    A500 Plus - 2Mo de Chip - 128Mo Fast - 8Gb CF - 68080@78Mhz (Vampire V2+ inside)



    #48757
    Staff
    Zarnal
    Zarnal
    • 1 971 Messages

    :whistle: :whistle:   :whistle:   Va faire cela de nos jours… :lol:

    Malgré ce que j’avais écrit hier soir, je m’en suis tapé quelques unes.

    Je vais stopper provisoirement les 96 pour repasser aux 94/95. Trop de choses exigent une FPU pour démarrer et presque tout le reste se transforme en quasi slideshow genre 1/8 de VBL quand j’ai de la chance sur la machine stock.

     

    En cours :

    Ok :

    Essence-Extreme démo 1996 ok mais un truc me chiffonne. :rant:   :rant:

    Balance-Freak (1996) confirmée sur hard

     

     

     

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - CM A1200 complète ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae.

    #48772
    Staff
    Jim
    Jim
    • 3 587 Messages

    A bitch is a bitch …

    Malgré ce que j’avais écrit hier soir, je m’en suis tapé quelques unes.

    Bravo … jolie manière de terminer l’année !  :lol:

    A500 Plus - 2Mo de Chip - 128Mo Fast - 8Gb CF - 68080@78Mhz (Vampire V2+ inside)

    #48783
    Staff
    Zarnal
    Zarnal
    • 1 971 Messages

    A bitch is a bitch …

    Malgré ce que j’avais écrit hier soir, je m’en suis tapé quelques unes.

    Bravo … jolie manière de terminer l’année ! :lol:

     

    :yahoo: :yahoo:   :yahoo:   :yahoo:

     

    Au moins cela a le mérite d’être clair :

     »

    WIP

    ImpactDK-Clounds (1996)

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - CM A1200 complète ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae.

    #48835
    Staff
    Zarnal
    Zarnal
    • 1 971 Messages

    Bon petite magouille pour  » Ramses-Benoit (Mandelbrot) « . Je la laisse dans problématiques cependant, ne poussons pas mamie dans les orties :-p .

    Il suffit de faire une savestate sous WinUae 3.1 au tout début de la démo (après le check CPU qui engendre l’alerte) et de la charger sous la 4.1.0 (pas pire que de charger un adf B-) ). Tout se passe alors bien. :yahoo:.

    Maintenant, concernant la zerogravity 3 de scoopex, un doute m’assaille concernant la FPU. A revoir en priorité sur machine stock+fast pour analyse de comportement.

     

    99% of AGA demo/game problems are caused by CPU timing. Chipset timing is known (only possible chipset issue is program doing blitter register writes while blitter is active).

    Looks like this demo misses « some time counter == time to switch part » check and waits forever..  »

    As was already mentioned above, not even basic 68020 is cycle-exact yet.

    Motorola documentation does not really mention anything about instruction’s cycle sequencing, just some theoretical total cycle usages that are mostly useless. (I’ll randomly do some logic analyzer testing, 68020 CE will improve randomly but slowly..)

    Full 68020 CE is practically impossible without some undocumented information, for example multiplication and division algorithms are totally unknown and they have variable instruction cycle count.

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - CM A1200 complète ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae.

    #48899
    Staff
    Zarnal
    Zarnal
    • 1 971 Messages

    Abordons aujourd’hui le cas Freezers-Symptom. Cette dernière est placée dans problématiques. Voici le problème sur machine émulée stock sans fast.

    Maintenant voyons ce qu’il se passe avec de la fast :

    Le glitch n’est plus présent MAIS

    Après contrôle de TW sur hard, le glitch n’apparait pas sur une machine stock 2Mo. :unsure:

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - CM A1200 complète ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae.

    #48936
    Staff
    Zarnal
    Zarnal
    • 1 971 Messages

    J’ajuste mon protocole en passant à un kickstart 3.1 au lieu de 3.0 pour la suite. :-p

    Floppy-embraced ok **

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - CM A1200 complète ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae.

    #49295
    Staff
    Zarnal
    Zarnal
    • 1 971 Messages

    Je reprends la semaine prochaine après une pause provisoire. :lol:

    Je ne sais plus où j’en suis pour l’heure. :lol: :lol: :lol:

    Triage en vue, je crois que la première page est +- à jour si ce n’est les stats. :-p

    A1200 Commodore mutant " FrankenAmiga" + 68040 + 8MO + SD 8go - CM A1200 complète ESCOM. HD 20MO. Mon meilleur et seul A500 : WinUae.

Partager sur vos réseaux sociaux préférés :
Facebooktwittergoogle_plusredditpinterestlinkedintumblrmail
8 sujets de 61 à 68 (sur un total de 68)

Vous devez être connecté pour répondre à ce sujet.